• Welcome to WebsiteBaker Community Forum. Please log in or sign up.
Welcome, Guest
News
Support WebsiteBaker
Your donations will help to:
PayPal
  • Pay for our dedicated server
  • Pay for domain registration
  • and much more!
You can donate by clicking on the button below.

php Seiten von 2.8.3 in 2.10 importieren

Started by Naragarth, October 10, 2017, 07:32:07 PM  ( Read 26,976 times )

Naragarth

Ich habe 2.10 neu installiert. Kann ich die gespeicherten php Seiten von 2.8.3 wieder einbinden?
Ich habe sie in den ordner kopiert, angezeit werden sie jedoch nicht.

Danke für die Hilfe

    DarkViper

    Erst mal Zahnarzt spielen und einen Zahn ziehen.. ;)
    Es gibt in WB, egal welcher Version, keine HTML oder PHP Seiten, die direkt angezeigt werden können und auch nur den kleinsten Hauch von sichtbarem Inhalt haben. Die einzige Ausnahme ist eine evt. vorhandene intro.php.
    WB speichert die Inhalte von Seiten grundsätzlich modulorientiert in der Datenbank. Erst wenn eine Seite aufgerufen wird, stellt WB die Seite zur Laufzeit aus ihren Einzelelementen zusammen und gibt sie direkt aus.
    Die von Dir vermutlich zitierten "php - Seiten" sind schlicht nur automatisch erstellte Zugriffsdateien, die kaum mehr als die Nummer der zugehörenden Seite enthalten.
    Allerdings frage ich mich immer wieder, wozu wir uns die Mühe machen und mit jeder Version eine Upgrade-/Installationsanleitung schreiben und mitliefern. Zusätzlich von hunderten von Forenbeiträgen zu diesem Thema.

    Manuela
      Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen[br]
      [i][b][color=red]"We need education to cope with digitalization - and NOT the digitalization of education.!"[/color][/b][/i][br]
      [i]Tägliches Stoßgebet: [b]Oh Herr, wirf Hirn vom Himmel ![/i]

      Naragarth

      Natürlich habe ich versucht ein Update zumachen, dieses hat aber einen so gossen Fehler verursacht das ich die Seite neu raufladen musste.

      Also gibt es keine möglichkeit einer wiederherstellung? Dann komme ich um ein neuschreiben nicht rum... Ja dann :)

        DarkViper

        Falls Du noch ein Backup der alten Datenbank hast, ist Polen vielleicht doch nicht verloren...  ;)
          Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen[br]
          [i][b][color=red]"We need education to cope with digitalization - and NOT the digitalization of education.!"[/color][/b][/i][br]
          [i]Tägliches Stoßgebet: [b]Oh Herr, wirf Hirn vom Himmel ![/i]

          jacobi22

          man kann halt nicht ewig warten....   :|

          QuoteNatürlich habe ich versucht ein Update zumachen, dieses hat aber einen so gossen Fehler verursacht das ich die Seite neu raufladen musste.

          Details wären hier interessant, was wo als Fehler auftauchte

            Naragarth

            Quote from: DarkViper on October 10, 2017, 10:43:08 PM
            Falls Du noch ein Backup der alten Datenbank hast, ist Polen vielleicht doch nicht verloren...  ;)

            Ich habe die ganze alte datenbank noch :) Kann ich meine aktuelle Seite einfach wieder über diese laufen lassen?
            Wenn ja, wie mache ich das? Oder wie soll ich das ansonsten anstellen? Danke für deine Hilfe, bin echt froh  :-)

              dbs

              QuoteIch habe die ganze alte datenbank noch
              Gut gemacht  (Y)
              Hast du auch die kompletten Dateien der alten Installation noch?
              Es wäre tatsächlich hilfreich, wenn du deinen alten Zustand wiederherstellen könntest und das Upgrade nochmal durchgehst.
              Hierbei jede Fehlermeldung notieren + was du vorher getan hast.
              Wir haben inzwischen etliche Upgrades durch.

                Naragarth

                Quote from: dbs on October 11, 2017, 12:00:56 PM
                QuoteIch habe die ganze alte datenbank noch
                Gut gemacht  (Y)
                Hast du auch die kompletten Dateien der alten Installation noch?
                Es wäre tatsächlich hilfreich, wenn du deinen alten Zustand wiederherstellen könntest und das Upgrade nochmal durchgehst.
                Hierbei jede Fehlermeldung notieren + was du vorher getan hast.
                Wir haben inzwischen etliche Upgrades durch.

                Ich habe die alte Seite wieder Hergestellt (einfach alles auf die alte database umgestellt) und das Upgrade hat es auch gut gemacht diesmal.
                Jetzt habe ich alle PHP seiten wieder, diese werden schön aufgeführt und ich kann die bearbeiten, jedoch werden sie nicht angezeigt, wenn man sie im Browser ansehen will. Wenn ich die Webseite eingebe bleibt auch alles weiss.
                Gibt es dafür einen Trick?

                  hgs

                  #8
                  Wenn du uns einen Link zur betroffenen Seite gibt, können wir bestimmt etwas mehr sagen.

                  QuoteJetzt habe ich alle PHP seiten wieder, diese werden schön aufgeführt und ich kann die bearbeiten, jedoch werden sie nicht angezeigt
                  Wie sollen wir das verstehen?
                  Wie und wo bearbeitest du die php-Seiten?
                  Hast du Zugang zum BackEnd?
                  Welche php-Version läuft auf dem Server? WB 2.10.x läuft nicht mehr mit php kleiner Version 5.6!

                    LG Harald

                    "Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

                    "Never begin to stop - never stop beginning." Marcus Tullius Cicero (106-43 BC)

                    jacobi22

                    @hgs: Setze ich voraus, das Wiederherstellung und Upgrade im Rahmen der Anleitungen passierten, wird es wohl wieder eine Filtergeschichte sein. Ich klink mich hier aus

                      Naragarth

                      Quote from: hgs on October 11, 2017, 12:14:55 PM
                      Hast du Zugang zum BackEnd?
                      Welche php-Version läuft auf dem Server? WB 2.10.x läuft nicht mehr mit php kleiner Version 5.6!

                      Aktuell PHP 7.0.22
                      Natürlich mach ich das im BackEnd. Da sind jetzt auch alle Seiten drin. Nur die Bilder werden nicht angezeigt (was aber kein Problem ist). Ich kann da auch bearbeiten und speichern, aber angezeigt wird dann nichts. Ich bin sicher ich finde die Lösung noch, hahaha :)

                      www.blackjade.ch

                        dbs

                        Da der jacobi sich ausklingt wird es schwer mit schneller Hilfe.
                        Im Backend ist oben ein Button mit einem X drauf, der enthält die Fehlermeldungen. Den Inhalt könntest du hier mal posten.

                          hgs

                          Quote from: jacobi22 on October 11, 2017, 12:43:35 PM
                          ..... wird es wohl wieder eine Filtergeschichte sein. ....

                          Guter Ansatz, danke jakobi22
                          Dann teste doch mal die Output-Filtereinstellung im BE.
                          Bei mir sind die Filter wie auf dem Bild gesetzt.
                            LG Harald

                            "Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

                            "Never begin to stop - never stop beginning." Marcus Tullius Cicero (106-43 BC)

                            jacobi22

                            da wirst du dich dran gewöhnen müssen, mein Plan war, bei 4500 Postings den Rolladen runter zu machen, allerdings hätte ich gern das Problem vom Rumen noch vorher gelöst
                            Was soll ich hier antworten, wenn meine Fragen ignoriert werden?

                              jacobi22

                              #14
                              www-blackjade-ch - 500 Internal Server Error  :-o :-o :-o  *mittlerweile erledigt

                                Naragarth

                                Quote from: jacobi22 on October 11, 2017, 01:21:20 PM
                                www-blackjade-ch - 500 Internal Server Error  :-o :-o :-o  *mittlerweile erledigt

                                Ja, langsam läufts! :)

                                Aber jetzt habe ich eine ganz konkrete Frage, wie bekomme ich diese Meldung weg?
                                [15-Oct-2017 07:25:06 Etc/UTC] show_menu2 error: $aOptions is invalid. No flags supplied!
                                Das ist der einzige Fehler der noch angezeigt wird.


                                  evaki

                                  Die Forensuche ist Dein Freund: show_menu2 error: $aOptions is invalid. No flags supplied!
                                  Sollte helfen  :-)
                                  MfG. Evaki

                                    Naragarth

                                    Quote from: evaki on October 15, 2017, 10:08:27 AM
                                    Die Forensuche ist Dein Freund: show_menu2 error: $aOptions is invalid. No flags supplied!
                                    Sollte helfen  :-)
                                    MfG. Evaki

                                    Die ist ein guter Freund, danke. Aber ich bin einfach zu doof dazu  :-D

                                    Meine Zeile sieht so aus:
                                    show_menu2(1,SM2_ROOT,SM2_CURR+1,SM2_ALL,'','<li><a href="[url]" class="[class]">[menu_title]</a>','</li>','<ul>','</ul>',false,false);

                                    Wenn ich jetzt verstehen würde wo ich was ändern muss, ja dann, ja dann wäre die Suche mein wahrer Freund  :roll:

                                      dbs

                                      SM2_ALL,'',
                                      Das müsste es sein. Entferne das:  '',  zu
                                      show_menu2(1,SM2_ROOT,SM2_CURR+1,SM2_ALL,'<li><a href="[url]" class="[class]">[menu_title]</a>','</li>','<ul>','</ul>',false,false);

                                        \n\n