Author Topic: Internet Explorer 8: big display problems with the template  (Read 13720 times)

Offline midiweb

  • Posts: 181
Internet Explorer 8: big display problems with the template
« on: November 20, 2009, 03:24:29 PM »
Hi, with the browser IE 8,  the layout of my homepage with WB 2.8 and the templates Industry 1 is rather "crappy" and looks very rough. With Firefox, Opera and Safari, I have no designproblems.

What are for Internet Explorer 8 the right and optimal parameters in the CSS sheets of the template, to display properly the homepage?

here are my problems:

the pages are not centered anymore
the fonts are too big or rough, coarse,..
the page "Clients" is not displayed anymore
There s a white  gap between the banner and the top menu

Who knows, how to fix all these snags :-))  ?


See here yourself:

http://www.jurgschat-consulting.eu/
« Last Edit: November 27, 2009, 07:53:26 PM by midiweb »

erpe0812

  • Guest
Re: Internet Explorer 8: big display problems with the template
« Reply #1 on: November 20, 2009, 04:10:29 PM »
Hi

if IE 7 is ok put this in the head of xour index.php:

Code: [Select]
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7" />

Hope it helps.

rgds

erpe


Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #2 on: November 20, 2009, 06:03:35 PM »
hi, it has changed nothing.


erpe0812

  • Guest
Re: Internet Explorer 8: big display problems with the template
« Reply #3 on: November 20, 2009, 06:27:47 PM »
Then your page is not ok even in IE 7.
Please validate and see what errors appear.
http://validator.w3.org/

rgds

erpe

aldus

  • Guest
Re: Internet Explorer 8: big display problems with the template
« Reply #4 on: November 21, 2009, 03:06:06 PM »
Hm ... still wondering why there is a <script>-tag "before" the html one in line one!
Also ... needed IE=EmulateIE7-meta tag is missing in the head ...

Regards
Aldus

Offline maverik

  • Posts: 1572
  • Gender: Male
  • ..:: viva los tioz ::..
Re: Internet Explorer 8: big display problems with the template
« Reply #5 on: November 21, 2009, 03:44:56 PM »
sorry but source code from your page is a big chaos

have a look http://validator.w3.org/check?uri=http%3A%2F%2Fwww.jurgschat-consulting.eu%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

Code: [Select]
<strong><big>
<span style="font-size: large;">
<span style="font-family: Verdana;">Herzlich willkommen bei</span>
</span>
</big>
</strong>

 :?  :?

have a look at the following pages, maybe it helps you to work out your code

http://help.WebsiteBaker.org/pages/en/advanced-docu.php

http://www.css4you.de/

Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #6 on: November 22, 2009, 12:46:18 PM »
thanks a lot for help. I noticed myself also the  errors
I installed the template "Industry1" as it is. I changed only a few lines for modules or dropplets.
I added css tags to personnalize the design.

And now, in which file(s) have I to change something? index.php in "templates" directory or only the css sheet or the index.php in the root directory of my server?

From  which file do come the problems?


« Last Edit: November 22, 2009, 10:07:00 PM by midiweb »

aldus

  • Guest
Re: Internet Explorer 8: big display problems with the template
« Reply #7 on: November 22, 2009, 02:30:52 PM »
As for the missplaced "<script>" tag ... definitive the "index.php" of the template,
as for the "HTML-Mess" the WYSIWYG Editor you are using, oiow the way you are
handling the content itself within it.
There are some couple of things i realy don't understand, e.g.

http://www.jurgschat-consulting.eu//pages/kunden.php

The // inside the link ... and on the page itself in the generated HTML-Source mess like
Code: [Select]
<td width="350" valign="top" a="" class="text">
There is no argument "a" for a "<td>"-tag!
and caotic &nbsp; like
Code: [Select]
<font color="#0000a0">Leistungen &nbsp;&nbsp;&nbsp;&nbsp;&nbsp;&nbsp;

As far as i can see: you will have to remove all formatings in the content and rebuild the page ...
as this chaos will always result in problems, not only within the IE8

Regards
Aldus


Offline maverik

  • Posts: 1572
  • Gender: Male
  • ..:: viva los tioz ::..
Re: Internet Explorer 8: big display problems with the template
« Reply #8 on: November 22, 2009, 02:47:00 PM »
thats original industry and the source looks a "LITTLE" bit different to your source code

#######link entfernt##########

Quote
I installed the template "Industry1" as it is. I changed only a few lines for modules or dropplets.

i think you have changed a little bit more than a few lines ;-)

Quote
rebuild the page ...
as this chaos will always result in problems, not only within the IE8

full ack
« Last Edit: November 28, 2009, 02:39:38 AM by maverik »

Waldschwein

  • Guest
Re: Internet Explorer 8: big display problems with the template
« Reply #9 on: November 22, 2009, 10:23:44 PM »
Hello!

Please always validate all your sites before publishing them. In most cases when your site validates (X)HTML / CSS2 in W3C (like the F12-Developertools from IE8 provide some links, or the Webdeveloper Toolbar for Firefox) you have a good chance it looks quite the same in all modern browsers (not IE 5.5 or even Netscape... but how uses that in 2009?). At least now as Microsoft stated they want to achieve HTML5 / CSS3 fully compatibility in IE9 besides getting ACID3 test and some CSS tests right.

Yours Michael
  

Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #10 on: November 25, 2009, 10:54:06 PM »
Hi, thanks for your precious help. I fixed a lot of errors, particularly with the <script> and <head> tags.


http://validator.w3.org/check?uri=http%3A%2F%2Fwww.jurgschat-consulting.eu%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

shows still now  8 errors only. It's become  very better, isn't it?

The site under IE8 is now better but not properly yet.

My menu entry "Kunden" cannot display under IE8 . I don't why. I'm still looking hard for the solution.

Regards,


MD

Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #11 on: November 26, 2009, 03:58:29 PM »
I'm wondering if I have to insert  the doctype in both index.php, in the root path and in the template path and maybe in all pages.php

Is this doctype ok:


Code: [Select]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head><title>Jurgschat-Consulting </title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE8"></head>
<body>

Offline maverik

  • Posts: 1572
  • Gender: Male
  • ..:: viva los tioz ::..
Re: Internet Explorer 8: big display problems with the template
« Reply #12 on: November 26, 2009, 04:32:28 PM »
doctype only in index.php of template

Code: [Select]
<?php
// redirect if this file is invokded directly
if(!defined(&#39;WB_URL&#39;)) {
    
header(&#39;Location: ../index.php&#39;);
    
exit(0);
}
?>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="de" lang="de">
<head>
<title><?php page_title(); ?></title>
<meta http-equiv="Content-Type" content="text/html; charset=<?php
if(defined(&#39;DEFAULT_CHARSET&#39;)) { echo DEFAULT_CHARSET; } else
{ echo &#39;utf-8&#39;; }?>
" />

Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #13 on: November 27, 2009, 07:53:00 PM »
when I insert your doctype code in the index.php of template, I have a crappy dull Display under IE8 but when I copy this code in the index.php of the root path, all works fine, good display and "Kunden" page is diplayed. How to understand this?


Offline BerndJM

  • Posts: 1764
  • Gender: Male
Re: Internet Explorer 8: big display problems with the template
« Reply #14 on: November 28, 2009, 02:27:15 AM »
'cause you have a email-adress at gmx.de
I try to answer you in german:

Junge, in deinem System ist irgendwo absoluter Müll, ich hab das in mittlerweile drei Jahren mit WB noch nie erlebt, das irgendwelcher doctype code in der root-index irgendwas rausreißt, was er in der index des templates nicht könnte. das würde ja das ganze System ad absurdum führen.

Du sagst "nur noch 8 Fehler" - es wird langsam besser - also mach doch die 8 Fehler auch noch weg!
Wenn M§ mit der 8er-Version diesmal wriklich ernst gemacht hat und wirklich strict Standardkonform ist.dann vielleicht so standardkonform, daß es jedem Schußler/Rumfrickler/Baseltyp irgednwann ins Knie beißt.

Grüßle Bernd
In theory, there is no difference between theory and practice. But, in practice, there is.

Waldschwein

  • Guest
Re: Internet Explorer 8: big display problems with the template
« Reply #15 on: November 28, 2009, 02:39:34 AM »
Du sagst "nur noch 8 Fehler" - es wird langsam besser - also mach doch die 8 Fehler auch noch weg!
Wenn M§ mit der 8er-Version diesmal wriklich ernst gemacht hat und wirklich strict Standardkonform ist.dann vielleicht so standardkonform, daß es jedem Schußler/Rumfrickler/Baseltyp irgednwann ins Knie beißt.
*hust* Der IE8 ist in manchen Belangen gar nicht so großzügig wie seine Mitstreiter, wenn der Code nicht valide ist. Da kann es einem schnell das komplette Template zerschießen. Zumindest hab ich öfters Probleme, so >100 HTML Error Templates im IE8 auch nur halbwegs anzugucken (ja, es gibt den "Use teH old browser" Button... aber man ist ja faul). Ist zwar ziemlich abrupt, aber man könnte meinen sie wollen die Leute zwingen sich vom IE6 & Konsorten zu verabschieden...
Gruß Michael

Offline maverik

  • Posts: 1572
  • Gender: Male
  • ..:: viva los tioz ::..
Re: Internet Explorer 8: big display problems with the template
« Reply #16 on: November 28, 2009, 02:54:10 AM »
wenn ich so etwas

Code: [Select]
<div>
<meta content="text/html; charset=utf-8" http-equiv="Content-Type">
<meta content="Word.Document" name="ProgId">
<meta content="Microsoft Word 11" name="Generator">
<meta content="Microsoft Word 11" name="Originator"><span style="font-size: xx-small;"><span style="font-family: Verdana;"><big>  <br />
</big></span></span>
<link href="file:///C:%5CDOKUME%7E1%5CJ&amp;P%5CLOKALE%7E1%5CTemp%5Cmsohtml1%5C01%5Cclip_filelist.xml" rel="File-List" /><span style="font-size: xx-small;"><span style="font-family: Verdana;"><big><!--[if gte mso 9]><xml>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:HyphenationZone>21</w:HyphenationZone>
<w:PunctuationKerning />
<w:ValidateAgainstSchemas />
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:Compatibility>
<w:BreakWrappedTables />
<w:SnapToGridInCell />
<w:WrapTextWithPunct />
<w:UseAsianBreakRules />
<w:DontGrowAutofit />
</w:Compatibility>
<w:BrowserLevel>MicrosoftInternetExplorer4</w:BrowserLevel>
</w:WordDocument>
</xml><![endif]--><!--[if gte mso 9]><xml>
<w:LatentStyles DefLockedState="false" LatentStyleCount="156">
</w:LatentStyles>
</xml><![endif]--></big></span></span><style type="text/css"></style><span style="font-size: xx-small;"><style type="text/css"></style><span style="font-family: Verdana;"><big><!--[if gte mso 10]>
<style>
/* Style Definitions */
table.MsoNormalTable
{mso-style-name:"Normale Tabelle";
mso-tstyle-rowband-size:0;
mso-tstyle-colband-size:0;
mso-style-noshow:yes;
mso-style-parent:"";
mso-padding-alt:0cm 5.4pt 0cm 5.4pt;
mso-para-margin:0cm;
mso-para-margin-bottom:.0001pt;
mso-pagination:widow-orphan;
font-size:10.0pt;
font-family:"Times New Roman";
mso-ansi-language:#0400;
mso-fareast-language:#0400;
mso-bidi-language:#0400;}
</style>
<![endif]-->                    </big></span></span>                                                                                                                </meta>

</meta>
</meta>
</meta>
</div>

im quelltext finde und das mehrfach auf einer seite wundere ich mich das überhaupt etwas von der seite angezeigt wird bzw wundere ich mich nicht das der ie späßchen macht. irgendwo eiert noch ein thread zu diesem thema rum und dort habe ich schon einige hilfreiche links zur doku und selfhtml gesetzt.

bei dieser lernresistenz weiß ich auch keinen rat mehr  :?
« Last Edit: November 28, 2009, 03:17:01 AM by maverik »

Offline BerndJM

  • Posts: 1764
  • Gender: Male
Re: Internet Explorer 8: big display problems with the template
« Reply #17 on: November 28, 2009, 03:12:57 AM »
das war genau diese "Beratungsresistenz" die mich dazu bewog mal auf deutsch umzuschalten ;-)
Denn es kann ja nicht sein ....
In theory, there is no difference between theory and practice. But, in practice, there is.

Offline phillbooth

  • Posts: 27
Re: Internet Explorer 8: big display problems with the template
« Reply #18 on: November 30, 2009, 04:39:20 PM »
Words of wisdom:

CSS always use the following...

flow: left
clear: both / left / right / none
with: xxx px

This should fix most browser issues but you will have to make sure that all your divs have clear both and flow left in.


Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Internet Explorer 8: big display problems with the template
« Reply #19 on: December 06, 2009, 03:55:56 AM »
OMG, what a mess... You use a mix of several heads and bodies, and silly and faulty instructions. I can't imagine the original template is so crappy. If so, it should be removed from the repository immediately. If not, install the original template again and start fresh.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #20 on: December 06, 2009, 06:15:46 PM »
hi,

I would like to post first here my current index.php and css file from the template directory "industry1" in order to have your opinion.

Code: [Select]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="de">
<head><title>Jurgschat-Consulting - Deutschland</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<!--<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>-->
</head>
<body>
<?php

// $Id: index.php 989 2009-06-15 13:12:39Z aldus $


$starttime array_sum(explode(" ",microtime()));

// Include config file
require_once(dirname(__FILE__).&#39;/config.php&#39;);

// Check if the config file has been set-up
if(!defined(&#39;WB_PATH&#39;)) {
    
header("Location: install/index.php");
    exit(
0);
}

require_once(
WB_PATH.&#39;/framework/class.frontend.php&#39;);
// Create new frontend object
$wb = new frontend();

// Figure out which page to display
// Stop processing if intro page was shown
$wb->page_select() or die();

// Collect info about the currently viewed page
// and check permissions
$wb->get_page_details();

// Collect general website settings
$wb->get_website_settings();

// Load functions available to templates, modules and code sections
// also, set some aliases for backward compatibility
require(WB_PATH.&#39;/framework/frontend.functions.php&#39;);

// redirect menu-link
$this_page_id PAGE_ID;
if(
version_compare(phpversion(), &#39;4.3&#39;, &#39;>=&#39;)) $php43 = TRUE; else $php43 = FALSE;
$query_this_module $database->query("SELECT module, block FROM ".TABLE_PREFIX."sections WHERE page_id = &#39;$this_page_id&#39; AND module = &#39;menu_link&#39;");
if(
$query_this_module->numRows() == 1) { // This is a menu_link. Get link of target-page and redirect
    // get target_page_id
    
$table TABLE_PREFIX.&#39;mod_menu_link&#39;;
    
$query_tpid $database->query("SELECT * FROM $table WHERE page_id = &#39;$this_page_id&#39;");
    if(
$query_tpid->numRows() == 1) {
        
$res=$query_tpid->fetchRow();
        
$target_page_id $res[&#39;target_page_id&#39;];
        
$r_type $res[&#39;redirect_type&#39;];
        
$anchor $res[&#39;anchor&#39;];
        
$extern $res[&#39;extern&#39;];
        
if($anchor != &#39;0&#39;) $anchor = &#39;&#39;.$anchor;
        
else $anchor FALSE;
        
// set redirect-type
        
if($r_type==&#39;301&#39;) {
            
if($php43) @header(&#39;HTTP/1.1 301 Moved Permanently&#39;, TRUE, 301);
            
else @header(&#39;HTTP/1.1 301 Moved Permanently&#39;);
        
}
        if(
$target_page_id == -1) {
            if(
$extern!=&#39;&#39;) {
                
header("Location: $extern".($anchor?&#39;#&#39;.$anchor:&#39;&#39;));
            
}
        } else {
            
// get link of target-page
            
$table TABLE_PREFIX.&#39;pages&#39;;
            
$query_link $database->query("SELECT link FROM $table WHERE page_id = &#39;$target_page_id&#39;");
            if(
$query_link->numRows() == 1) {
                
$res=$query_link->fetchRow();
                
$target_page_link $res[&#39;link&#39;];
                
header(&#39;Location: &#39;.WB_URL.PAGES_DIRECTORY.$target_page_link.PAGE_EXTENSION.($anchor?&#39;#&#39;.$anchor:&#39;&#39;));
                
exit;
            }
        }
    }
}

// Backwards compatible Frontend filter support
// include the output filter module routines
if(file_exists(WB_PATH .&#39;/modules/output_filter/filter-routines.php&#39;)) {@require_once(WB_PATH .&#39;/modules/output_filter/filter-routines.php&#39;);}
// Load Droplet engine
if(file_exists(WB_PATH .&#39;/modules/droplets/droplets.php&#39;)) { @require_once(WB_PATH .&#39;/modules/droplets/droplets.php&#39;); }

//Get pagecontent in buffer for Droplets and/or Filter operations
ob_start();
require(
WB_PATH.&#39;/templates/&#39;.TEMPLATE.&#39;/index.php&#39;);
$output ob_get_contents();
ob_end_clean();
if(
function_exists(&#39;evalDroplets&#39;)) { $output = evalDroplets($output); }
if(function_exists(&#39;filter_frontend_output&#39;)) { $output = filter_frontend_output($output); }
echo $output;

?>

</body>
</html

and the css industry file with a few changes from me:


Code: [Select]
body {
font-family : Verdana, Geneva, Arial, helvetica, sans-serif;
font-size : 10pt;
padding : 0;
margin-top : 10px;
}
#nav {
width : 980px;
height : 22px;
border-top : 5px solid black;
position : relative;
margin : 0;
margin-top : 0px;
margin-bottom : 0px;
padding-left : 0px;
text-align : right;
background: url(../../media/oberrand.jpg) no-repeat;
}
#nav li {
padding-left : 16px;
padding-right : 10px;
display : inline;
height : 20px;
background: url(../../media/vertical2.jpg) no-repeat;
}
#nav li a {
color : black;
font : bold     normal normal 10px/20px "Lucida Grande", Lucida, Verdana, sans-serif;
}
#nav li a:hover
{
color: #cb1625;
}
#main {
font-family : Verdana, Geneva, Arial, helvetica, sans-serif;
font-size : 9pt;
width : 980px;
margin-left : auto;
margin-right : auto;
border-right : 1px solid #666666;
border-left : 1px solid #666666;
}
#hero {
margin : 0 10px;
width : 218px;
height : 106px;
background-image : url(../../media/jurgschatbanner.jpg);
background-repeat : no-repeat;
float : left;
}
#hero2 {
margin : 0;
margin-left: 286px;
margin-right: auto;
height : 106px;
background-image : url(../../media/topbanner3.jpg);
background-repeat : no-repeat;
}
.gear {
width : 970px;
height : 0px;
margin-top : 0;
margin-left : 15px;
}
#header h1 {
position : absolute;
left : 94px;
top : 8px;
color : white;
font-size : 48px;
font-weight : bold;
margin : 0;
}
#header em {
font-style : normal;
text-decoration : underline;
}
#wrapper {
display : inline;
padding-top : 0;
background-color : white;
position : relative;
}
/*#wrapper:after {
content : '.';
display : block;
height : 0;
clear : both;
visibility : hidden;
}*/
#sidebar {
float : left;
text-align : center;
margin-left : 0;
margin-top : 0;
position : relative;
padding : 10px 10px 20px 10px;
width : 160px;
height : 2850px;
border-right : 1px dotted ;
}
#aktuelles {
float : right;
text-align : center;
margin-left : 0;
margin-top : 0;
position : relative;
padding : 12px 10px 20px 10px;
width : 140px;
height : 2850px;
border-left : 1px dotted;
background-color: #e6e6e6;
}
#aktuelles h4 {
color : #232219;
text-align: center;
text-decoration: underline;
}
/*#sidebar h3 {
font-size : 18px;
border-bottom : 1px solid black;
margin-bottom : 4px;
margin-top : 16px;
clear : both;
}*/
#sidebar ul {
margin-left : 1em;
padding-left : 0;
}
#sidebar p {
margin-bottom : 8px;
}
#sidebar div.subtabs ul {
list-style : none;
width : 155px;
margin : 0;
padding : 0;
}
#sidebar div.subtabs ul ul {
list-style : none;
width : 130px;
margin : 0;
padding : 0 0 0 25px;
}
#sidebar div.subtabs ul ul ul {
list-style : none;
width : 125px;
margin : 0;
padding : 0 0 0 5px;
}
#sidebar div.subtabs ul a {
width : 100%;
margin : 3px;
text-align : left;
text-decoration : none;
display : block;
padding : 3px 3px 3px 5px;
border-bottom : 1px solid #949494;
border-left : 4px solid #cccccc;
font: bold 0.8em Verdana, Arial, Helvetica, sans-serif;
color: #0a0a0a;
}
#sidebar div.subtabs ul a:hover {
text-decoration : none;
background : #eaeaea url(img/menubg2.gif) repeat-x left;
color : #da0434;
border-left : 4px solid #110200;
}
#content {
margin : 0 0 0 180px;
min-height : 310px;
height : auto !important ;
width : 600px;
display : block;
position : relative;
padding : 0 3px 20px 10px;
color : #0b0b0b;
}
#content h1 {
font-size : 20px;
margin : 0;
}
#content h2 {
font-size : 18px;
margin : 0;
}
#content .date {
float : right;
}
#content .postedBy {
float : left;
}
#content .meta {
height : 1em;
}
#content p {
text-align : justify;
text-indent : 1em;
line-height : 1.3em;
}
/*.comments {
border-top : 1px dotted #666666;
border-bottom : 1px dotted #666666;
padding : 4px;
text-align : right;
margin-bottom : 2em;
background-image : url(images/comment_edit.gif);
background-repeat : no-repeat;
background-position : center left;
}*/
a {
color : #3c3b96;
}
/*.pullout {
background-color : #eeeeee;
padding : 5px;
float : right;
margin : 8px;
}*/
#footer {
margin-top: 0px;
width : 980px;
height : 38px;
padding-top : 0;
padding-bottom : 0;
margin-left : 0px;
margin-right : auto;
color : #6a72b5;
text-align : center;
background: url(../../media/bottombanner.jpg) no-repeat center;

}
.right {
float : right;
}
.csskeyword {
color : blue;
}
.cssvalue {
color : red;
}
p.caption {
text-align : center;
}
small.super {
vertical-align : top;
font-size : 0.75em;
line-height : 1.3em;
}
.nodisplay {
display : none;
}


and now the index.php at the root :

Code: [Select]
<?php

// $Id: index.php 989 2009-06-15 13:12:39Z aldus $


$starttime array_sum(explode(" ",microtime()));

// Include config file
require_once(dirname(__FILE__).&#39;/config.php&#39;);

// Check if the config file has been set-up
if(!defined(&#39;WB_PATH&#39;)) {
    
header("Location: install/index.php");
    exit(
0);
}

require_once(
WB_PATH.&#39;/framework/class.frontend.php&#39;);
// Create new frontend object
$wb = new frontend();

// Figure out which page to display
// Stop processing if intro page was shown
$wb->page_select() or die();

// Collect info about the currently viewed page
// and check permissions
$wb->get_page_details();

// Collect general website settings
$wb->get_website_settings();

// Load functions available to templates, modules and code sections
// also, set some aliases for backward compatibility
require(WB_PATH.&#39;/framework/frontend.functions.php&#39;);

// redirect menu-link
$this_page_id PAGE_ID;
if(
version_compare(phpversion(), &#39;4.3&#39;, &#39;>=&#39;)) $php43 = TRUE; else $php43 = FALSE;
$query_this_module $database->query("SELECT module, block FROM ".TABLE_PREFIX."sections WHERE page_id = &#39;$this_page_id&#39; AND module = &#39;menu_link&#39;");
if(
$query_this_module->numRows() == 1) { // This is a menu_link. Get link of target-page and redirect
    // get target_page_id
    
$table TABLE_PREFIX.&#39;mod_menu_link&#39;;
    
$query_tpid $database->query("SELECT * FROM $table WHERE page_id = &#39;$this_page_id&#39;");
    if(
$query_tpid->numRows() == 1) {
        
$res=$query_tpid->fetchRow();
        
$target_page_id $res[&#39;target_page_id&#39;];
        
$r_type $res[&#39;redirect_type&#39;];
        
$anchor $res[&#39;anchor&#39;];
        
$extern $res[&#39;extern&#39;];
        
if($anchor != &#39;0&#39;) $anchor = &#39;&#39;.$anchor;
        
else $anchor FALSE;
        
// set redirect-type
        
if($r_type==&#39;301&#39;) {
            
if($php43) @header(&#39;HTTP/1.1 301 Moved Permanently&#39;, TRUE, 301);
            
else @header(&#39;HTTP/1.1 301 Moved Permanently&#39;);
        
}
        if(
$target_page_id == -1) {
            if(
$extern!=&#39;&#39;) {
                
header("Location: $extern".($anchor?&#39;#&#39;.$anchor:&#39;&#39;));
            
}
        } else {
            
// get link of target-page
            
$table TABLE_PREFIX.&#39;pages&#39;;
            
$query_link $database->query("SELECT link FROM $table WHERE page_id = &#39;$target_page_id&#39;");
            if(
$query_link->numRows() == 1) {
                
$res=$query_link->fetchRow();
                
$target_page_link $res[&#39;link&#39;];
                
header(&#39;Location: &#39;.WB_URL.PAGES_DIRECTORY.$target_page_link.PAGE_EXTENSION.($anchor?&#39;#&#39;.$anchor:&#39;&#39;));
                
exit;
            }
        }
    }
}

// Backwards compatible Frontend filter support
// include the output filter module routines
if(file_exists(WB_PATH .&#39;/modules/output_filter/filter-routines.php&#39;)) {@require_once(WB_PATH .&#39;/modules/output_filter/filter-routines.php&#39;);}
// Load Droplet engine
if(file_exists(WB_PATH .&#39;/modules/droplets/droplets.php&#39;)) { @require_once(WB_PATH .&#39;/modules/droplets/droplets.php&#39;); }

//Get pagecontent in buffer for Droplets and/or Filter operations
ob_start();
require(
WB_PATH.&#39;/templates/&#39;.TEMPLATE.&#39;/index.php&#39;);
$output ob_get_contents();
ob_end_clean();
if(
function_exists(&#39;evalDroplets&#39;)) { $output = evalDroplets($output); }
if(function_exists(&#39;filter_frontend_output&#39;)) { $output = filter_frontend_output($output); }
echo $output;

?>



BUT when I don't write the doctype, the <html>, the <head> in the root index, my homepage is crappy and looks bad.

I mean I have to write the following code in  order to have a correct display:

Code: [Select]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="de">
<head><title>Jurgschat-Consulting - Deutschland</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1"/>
<!--<meta http-equiv="X-UA-Compatible" content="IE=EmulateIE7"/>-->
</head>
<body>
<?php
.......................
............................
.....................................
?>

</body>
</html>

That 's why two bodies, two html and so on...

AND I go round in circles.... What I write in backend, what I insert is not what I get in the front end. It's because of FCKeditor.

who can advise me? Thanks. Sorry when some remarks are redundant...
Now I'm stuck here and can't go further.

« Last Edit: December 06, 2009, 06:21:21 PM by midiweb »

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Internet Explorer 8: big display problems with the template
« Reply #21 on: December 07, 2009, 12:35:19 AM »
First of all: you should never have to edit the index.php in the WB root at all! Do not touch it unless you know exactly what and why you are doing.

Second: the code of the template index.php you posted contains weird stuff.

Third: you should never use multiple heads and body tags in one file.

Fourth: the "industry1" template is not part of the official repository. I only found it once in an old post in the forum, from 2007. I removed it from there. You'd better stop using it.

Look for another template that suits your wishes, from the official repository please.
« Last Edit: December 07, 2009, 12:37:18 AM by Argos »
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline midiweb

  • Posts: 181
Re: Internet Explorer 8: big display problems with the template
« Reply #22 on: December 07, 2009, 01:16:48 PM »
Hi, thanx! I'll do it but how to adapt new template to an existing content?

The pages content stay thre same,   BUT can I use my current css sheet for a new existing template?

It´'s another post,..

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Internet Explorer 8: big display problems with the template
« Reply #23 on: December 07, 2009, 01:22:09 PM »
Hi, thanx! I'll do it but how to adapt new template to an existing content?
The pages content stay thre same,   BUT can I use my current css sheet for a new existing template?

Modifying a template is just about the same as working on a static webpage.

You can only use basic visual styling elements from your current stylesheet, like colors and such. Every template is built differently, and uses its own structure and tags. The index.php and stylesheet are not two separate entities that you can swap at will, they belong together for that particular template. You should never use a complete stylesheet from another template. If you do, chances are almost 100% that you site will not look right, and probably will fail completely.
« Last Edit: December 08, 2009, 01:09:43 PM by Argos »
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

 

postern-length