Author Topic: WebsiteBaker-2.12.0 (stable) published  (Read 653 times)

Offline dbs

  • Betatester
  • **
  • Posts: 7411
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
WebsiteBaker-2.12.0 (stable) published
« on: May 20, 2018, 11:54:19 PM »
Hello everybody,

we are pleased to announce today the stable version 2.12.0 of WebsiteBaker!

WB-2.12.0 is the successor version of 2.11.x. It is a complete package and contains everything that has been published in the context of the 2.11.x Core.
An upgrade is possible from all of the 2.10.x versions. But never from earlier ones versions before 2.10.x.

You can download from our Add-on Repository as WB-2.12.0.zip or as WB-2.12.0.gz

For install and upgrade instructions please have a look into the file /DOCU/README.EN which is delivered with the downloaded paket.

The most important changes

for EU-GDPR (german DSGVO)
  • News comments
    with checkbox for privacy policy
  • Form
    - with checkbox for privacy policy
    - stored submissions can be set to 0 for no saving submissions
  • Signup
    Configuration in WB settings "Frontend Login and Signup Options ..."

Other changes
  • frontendUser.css
    You can now use in modules a own frontendUser.css which will automatically loaded and not overwritten by upgrades. If there is not this file WB will load the frontend.css (like before).
  • Update CKEditor to version 4.9.2
    contains a security fix for the Enhanced Image plugin, so an upgrade is highly recommended
  • Wysiwyg Fix
    very long texts are possible again (database structure type longtext)
  • jQuery upgrade ! jQuery v1.12.4
    - and jQuery UI upgrade ! jQuery UI - v1.12.1
    - added jquery-migrate-min.js to jquery /framework/frontend.functions.php to work with older plugins
  • Recoding LoadOnFly.js, prevent css links in body
  • function xnl2br improved
    suppresses linebreaks convert with <br /> if line ends with an HTML tag
  • Media Management
    - disable Modify Settings save buttons, if sizeof inputs var are higher than max_input_vars level in php.ini
    - if more input variables are sent than allowed with this directive,
    an error of level E_WARNING is thrown and further input variables are not accepted.
  • session.cookie_secure fix
    fix HTTPS usage with a load balancer/proxy
  • new static public methode ObfuscateIp() in Login.php class
    anonymise login ipv4/ipv6 adress, hidden last blocks from user ip
  • remvoing user ips older than 30 days from user table
  • get database instance within functions/methodes
    $database = database::getInstance();
  • 1und1Fix
    date_default_timezo ne_set('UTC');
  • Calling wb_info and errorlog global, from framework/helpers
    for better recoding and changing in theme, class.admin
  • media png rezise fix
    fixes fuzzy PNG images when resizing

Have fun with WebsiteBaker 2.12.0
The WebsiteBaker team
« Last Edit: May 23, 2018, 06:14:11 PM by Luisehahne »