Author Topic: Problem with specialchars in Czech  (Read 11695 times)

honzasevcik

  • Guest
Problem with specialchars in Czech
« on: April 14, 2008, 09:54:30 PM »
Hello, i have web on adress http://www.certifikacepracovniku.cz . I use the czech language for this system. And I have this problem : Special characters don´t show corectly ! The spec. characters are show incorrectly only in headlines, pages and News. In administration and other pages are show correctly. Previously I testing the same presentation on http://force.euweb.cz - Its work correct ! I set the same setting and charset ! I don´t know where i do problem or where is a problem. Thanks for help

P.S. Sorry for my English

doc

  • Guest
Re: Problem with specialchars in Czech
« Reply #1 on: April 14, 2008, 10:19:32 PM »
Hello,

what is the WebsiteBaker version you are using? What is your template; what charset is specified in your setting and the template? What is your WYSIWYG editor?

Regards Christian

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #2 on: April 15, 2008, 02:34:27 PM »
My WebsiteBaker is in version 2.6.7 , in all settings is utf-8. Wysiwyg editor is default in this version of WebsiteBaker (2.6)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #3 on: April 15, 2008, 03:39:40 PM »
Hello,

as far as i know the czech language file for WB 2.6.7 is buggy. You can download the WB 2.7RC3a package and use the language czech language file from there.

Also we recommand to use FCKEditor as WYSIWYG Editor. HTMLArea is outdated.

Last but not least WB 2.6.7 did not 100% support UTF8. We fixed that in WB 2.7 wich will be released in the next days. So we recommand to update your WB a soon as possible.

Matthias

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #4 on: April 15, 2008, 08:16:57 PM »
O.K , I was instaled version 2.7RC3. My problem now is in instalation ! When I click to "Install Web Baker", broswer show this attention :

Code: [Select]
Warning: mkdir() [function.mkdir]: Unable to access ../temp/test_permissions/ in /www/doc/www.certifikacepracovniku.cz/www/install/save.php on line 119

Warning: fileperms() [function.fileperms]: Unable to access ../temp/test_permissions/ in /www/doc/www.certifikacepracovniku.cz/www/install/save.php on line 120

Warning: fileperms() [function.fileperms]: stat failed for ../temp/test_permissions/ in /www/doc/www.certifikacepracovniku.cz/www/install/save.php on line 120

Warning: rmdir() [function.rmdir]: Unable to access ../temp/test_permissions/ in /www/doc/www.certifikacepracovniku.cz/www/install/save.php on line 121

Warning: Cannot modify header information - headers already sent by (output started at /www/doc/www.certifikacepracovniku.cz/www/install/save.php:119) in /www/doc/www.certifikacepracovniku.cz/www/framework/class.login.php on line 100

I look for "test_permissions" in folder "temp", becose a didn´t found it !

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #5 on: April 15, 2008, 10:02:36 PM »
Prevous problems are resolved. Now is special characters run in headlines of categories too. In general headline and News aren´t run.

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with specialchars in Czech
« Reply #6 on: April 15, 2008, 10:38:00 PM »
Hello,

Quote from: from certifikacepracovni ku.cz
Warning: require() [function.require]: SAFE MODE Restriction in effect. The script whose uid/gid is 33/33 is not allowed to access ../config.php owned by uid/gid 56661/56661 in /www/doc/www.certifikacepracovniku.cz/www/pages/oblasti-certifikace.php on line 3

hmm, safe mode ON is not supported.

Also, while http: //force.euweb.cz uses UTF-8, http: //www.certifikacepracovniku.cz uses ISO-8859-2

thorn.
« Last Edit: April 15, 2008, 10:42:25 PM by thorn »

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #7 on: April 16, 2008, 02:11:41 PM »
I test both of them and its the same ! Characters don´t show correct !

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #8 on: April 16, 2008, 03:27:13 PM »
Hello,

Did you use the same charset in WB and in the template?
Did your hoster have some different values for charset on his server?

Also changing the charset after pages are created or content is available breaks the specialchars in content.

Can you try with a clean install, let WB to default UTF8 and use a builtin template like round or simple. Did this work?

Matthias

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #9 on: April 16, 2008, 04:08:12 PM »
No, now i have got a clean instalation. And if a started, a test it, didn´t work. In MySQL and WB is the default charset utf-8. A have been test a both of them (Latin 2 and UTF-8). In template is charset set UTF-8 too ! Text "O nás" is wrote in file index.php (in root directory of the template) and its show correct.

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #10 on: April 23, 2008, 04:13:50 PM »
I solved this problem. Thanks for your endeavour.

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #11 on: April 23, 2008, 04:20:33 PM »
Hello,

could you tell us how you solved it? Maybe it is for interest for other users too.

Thanks

Matthias

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #12 on: April 23, 2008, 05:54:21 PM »
The set of MYSQL isnt correct. Its only like a correct. I have to set for mysql server a default charset cp1250_general_ci and for database utf-8. Thats ALL

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #13 on: April 25, 2008, 02:55:42 PM »
A have a new problem. Special chars show correctli in all broswers, but Internet Explorer dont show correctly " ž ". He   supply it " ľ " (This letter isnt in Czech language) . This error is only in Internet Explorer, another broswer show " ž " correct. Have you got solution ?

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #14 on: April 25, 2008, 05:21:27 PM »
Hello,

Quote
This error is only in Internet Explorer, another broswer show " ž " correct. Have you got solution ?

We don't developp the Internet Explorer. Ask Microsoft for help.  :-D

I'm pretty shure it has to do with charset settings of IE. Check that. But to go shure all browsers use the correct charset for your page, think the best is to add a .htaccess on your server wich advices all browsers to use the charset you define there.

Matthias

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #15 on: April 25, 2008, 05:30:14 PM »
Ok, I can´t do it (the set of .htaccess). Please, help, what can i do ?

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #16 on: April 25, 2008, 05:31:44 PM »
ask bill gates  :-D

Matthias

Quote
I can´t do it (the set of .htaccess)

Why?

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #17 on: April 25, 2008, 05:37:10 PM »
You sad, that i add a .htaccess on my server wich advices all broswers to use the charset me define there. What can i do it ? I detest Bill   :-(

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #18 on: April 25, 2008, 06:07:30 PM »
Hello,

create on your lokal machine with an editor a file called .htaccess. Add the following content to it if you wanna have all in UTF8.

Code: [Select]
php_value default_charset UTF-8
Upload the file to your webserver in the dir where config.php is.

Matthias

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #19 on: April 25, 2008, 10:41:12 PM »
I created file .htaccess in root file of WebsiteBaker

Code: [Select]
# Example .htaccess wich allows to parse .html as php
AddType application/x-httpd-php .html
php_value default_charset iso-8859-2

It doesnt work. I dont know, where is the problem ?

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8388
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with specialchars in Czech
« Reply #20 on: April 26, 2008, 08:30:57 AM »
Hello,

I'm a little bit confused about your Kollation and charsets settings. A few posts above you said you set your database to UTF8. So for a workin WB you need to set WB in options also to UTF8 and use the same in the .htaccess. So why did you now mix this again? Only if all is in same charset before you create any page you can be shure that it works. Mixing or changes after pages are created breakes the content.

Matthias

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #21 on: April 26, 2008, 11:31:04 AM »
But i first set UTF-8, it didnt work. So i tested iso-8859-2

honzasevcik

  • Guest
Re: Problem with specialchars in Czech
« Reply #22 on: April 26, 2008, 11:46:42 AM »
OK, i dont know it  :-D . I set to .htaccess file charset iso-8859-2 , and id work correct. In mysql is a UTF-8 .

 

postern-length