Author Topic: WB-compatibility with PHP 7.4 or 8.0?  (Read 624 times)

Offline VSG

  • Posts: 257
WB-compatibility with PHP 7.4 or 8.0?
« on: January 12, 2022, 08:44:28 PM »
Hello and a belated happy new year everyone!

I was wondering if anybody had experiences with running WebsiteBaker with PHP 7.4 or even 8.0?
My hoster kills support for PHP 7.3 beginning next month and using the old version will be quite costly.

Are there any quirks known when running WB with PHP 7.4?
I only found a compatibility-list here.
Since PHP 7.4 will probably only be supported until early next year, are there any plans on supporting PHP 8.0 with WB?

Thanks in advance for any input and for the ongoing great work everyone on the dev-team is doing! (Y)
Best regards
VSG

Offline hgs

  • Betatester
  • **
  • Posts: 1539
    • EFG MG
Re: WB-compatibility with PHP 7.4 or 8.0?
« Reply #1 on: January 13, 2022, 07:37:51 AM »
WebsiteBaker is fully php 8 compatible and has been for over a year if you are using the current version 2.13.
The next version 2.13.1 will only run with php 8 or higher at all.
Download WB 2.13

Whether this is true for all deployed modules that are not included with WebsiteBaker is another question.

In our addon section the modules from third party vendors are also up to date.
« Last Edit: January 13, 2022, 07:47:48 AM by hgs »
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline astricia

  • Posts: 780
  • Gender: Female
    • netSchmiede24
Re: WB-compatibility with PHP 7.4 or 8.0?
« Reply #2 on: January 13, 2022, 10:29:01 AM »
Danke für die Info. Die Domain addon.WebsiteBaker. org kannte ich gar nicht für die Downloads! Der Link auf WebsiteBaker.org (https://WebsiteBaker.org/pages/en/downloads.php) führt zu http://wiki.WebsiteBaker.org/doku.php/downloads - und da steht noch was von PHP 7.3 !

Da muss ich wohl einige Kunden-Websites umstellen in diesem Jahr...

LG,
Astrid

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4512
  • Gender: Male
Re: WB-compatibility with PHP 7.4 or 8.0?
« Reply #3 on: January 13, 2022, 11:05:59 AM »
Danke für die Info. Die Domain addon.WebsiteBaker. org kannte ich gar nicht für die Downloads! Der Link auf WebsiteBaker.org (https://WebsiteBaker.org/pages/en/downloads.php) führt zu http://wiki.WebsiteBaker.org/doku.php/downloads - und da steht noch was von PHP 7.3 !

Da muss ich wohl einige Kunden-Websites umstellen in diesem Jahr...

LG,
Astrid

Danke fürden Hinweis, ist korrigiert

Dietmar
Note: Once the code has been generated, it is easy to debug. It's not a bug, it's a feature!

Offline VSG

  • Posts: 257
Re: WB-compatibility with PHP 7.4 or 8.0?
« Reply #4 on: January 13, 2022, 06:14:37 PM »
WebsiteBaker is fully php 8 compatible and has been for over a year if you are using the current version 2.13.
The next version 2.13.1 will only run with php 8 or higher at all.
Download WB 2.13

Whether this is true for all deployed modules that are not included with WebsiteBaker is another question.

In our addon section the modules from third party vendors are also up to date.

Thanks!