Author Topic: Update von sehr alter WB-Version?  (Read 142 times)

Offline xantiva

  • Posts: 5
Update von sehr alter WB-Version?
« on: December 31, 2021, 02:13:08 AM »
Hallo,

ich habe eine Webseite mit einer sehr alten WB-Version (ich glaube 2.07?). Wenn ich es richtig verstanden habe, dann funktioniert kein Update mehr, sondern ich sollte die neue Version installieren und dann die alte DB wieder importieren? Pages, media und das alte Template habe ich auch kopiert.

Der erste Fehlermeldung ist dann:
Code: [Select]
There was an uncatched exception
missing template file warning.html
in line (1123) of (/framework/class.wb.php):

Ok, das bekomme ich gefixt, wenn ich in wb_settings den Eintrag für default_template lösche. Dann kommt aber folgende Fehlermeldung:

Code: [Select]
WebsiteBaker Logo
Momentan in Bearbeitung - http://example.com/
Dieser Webauftritt hat für diese Sprache (DE) noch keine Seiten
Dieser Webauftritt hat für diese Sprache (DE) noch keine Seiten

Bitte versuchen Sie es später noch einmal ...

Die Suche hat mich auf den Beitrag geführt: https://forum.WebsiteBaker.org/index.php?topic=31765.0

Aber wenn ich versuche die /admin/login/index.php oder /admin/index.php aufzurufen, dann erhalte ich wieder nur die erste Fehlermeldung mit dem "missing template file ..."

Da komme ich jetzt aber nicht weiter, bzw. so einfach scheint ein Upgrade nicht möglich zu sein. Irgendjemand eine Idee, wie ich hier vorgehen muss?

Danke,
Mike

Offline dbs

  • Betatester
  • **
  • Posts: 8705
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Update von sehr alter WB-Version?
« Reply #1 on: December 31, 2021, 07:33:02 AM »
Hi, deine Webseite ist so groß, dass ein kompletter Neuaufbau zu umfangreich wäre?
Ein Vorschlag wäre, Neuinstallation (auf Subdomain) und dann die Inhalte per Copy&Pase einzufügen.
Auch könntest du auf der Subdomain ein Upgrade versuchen.

Quote
ich sollte die neue Version installieren und dann die alte DB wieder importieren?
Du hast dann einen Mix aus alt und neu, welcher nicht gut funktionieren wird. Das stand so auch nicht in deinem verlinkten Thread.

Quote
Ok, das bekomme ich gefixt, wenn ich in wb_settings den Eintrag für default_template lösche.
Das sollte auch nirgends zu finden sein. Der neue Eintrag sollte DefaultTemplate lauten

Kannst auch mal einen Blick hier rein werfen, zu den alten Upgradeanweisungen.
Da würde es reichen, wenn du bis WB 2.83 upgradest und dann zur neueste Version upgradest.
https://forum.WebsiteBaker.org/index.php/topic,23658.msg160358.html#msg160358

Offline hgs

  • Betatester
  • **
  • Posts: 1481
    • EFG MG
Re: Update von sehr alter WB-Version?
« Reply #2 on: December 31, 2021, 08:02:40 AM »
Aus reinem Interesse :)

Kannst du uns ein komplett Backup von Datenbank und WebSpace zur Verfügung stellen? 
Damit können wir im Testzentrum mal testen, ob ein upgrade nicht doch funktioniert.
Der Weg über die Version 2.8.3 (wie DBS geschrieben) hat immer funktioniert.

Wenn ja, bekommst du eine pm mit den Zugangsdaten für einen FTP-Server von uns.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline xantiva

  • Posts: 5
Re: Update von sehr alter WB-Version?
« Reply #3 on: December 31, 2021, 10:08:08 AM »
@dbs: Nur wird die 2.8.3 leider nicht mehr zum Download angeboten - sonst hätte ich das schon gemacht.

@hgs: Danke, mache ich gerne. Ich habe noch Deine Mailadresse, ich schicke Dir einen Link für den Download.

Ansonsten ist die Seite in der Tat aber so klein, dass ich sie auch neu erstellen könnte. Nur wenn das nicht erforderlich ist, ... ;)

Ciao,
Mike

Offline paulchen

  • Posts: 173
  • Gender: Male
    • PV-Steuer-Shop
Re: Update von sehr alter WB-Version?
« Reply #4 on: December 31, 2021, 11:45:23 AM »
@dbs: Nur wird die 2.8.3 leider nicht mehr zum Download angeboten - sonst hätte ich das schon gemacht.

...

Passt diese Version nicht?
---> https://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?type=0&cid=997&page=5


Offline hgs

  • Betatester
  • **
  • Posts: 1481
    • EFG MG
Re: Update von sehr alter WB-Version?
« Reply #5 on: December 31, 2021, 01:57:10 PM »
Jepp, das ist der richtige Download für die 2.8.3
Dateien habe ich mir gezogen, Danke für die Links
Mal sehn was passiert.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline hgs

  • Betatester
  • **
  • Posts: 1481
    • EFG MG
Re: Update von sehr alter WB-Version?
« Reply #6 on: December 31, 2021, 02:52:29 PM »

Ansonsten ist die Seite in der Tat aber so klein, dass ich sie auch neu erstellen könnte. Nur wenn das nicht erforderlich ist, ... ;)

Ciao,
Mike


Eine saubere 2.13.0 mit php 8.0 und einer frischen aktuellen DB  wäre wahrscheinlich der beste Weg.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline dbs

  • Betatester
  • **
  • Posts: 8705
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Update von sehr alter WB-Version?
« Reply #7 on: December 31, 2021, 03:25:02 PM »
Quote
Eine saubere 2.13.0 mit php 8.0 und einer frischen aktuellen DB  wäre wahrscheinlich der beste Weg.
Das würde auch das Problem mit Umlauten ersparen. Alte Installationen haben da definitiv ein "Problem" nach dem Upgrade (zumindest macht es Umstände).