Author Topic: Benutzer mit gleicher Email nach löschen wieder anlegen  (Read 1042 times)

Offline klaumich

  • Posts: 114
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Benutzer mit gleicher Email nach löschen wieder anlegen
« on: May 31, 2021, 02:50:39 PM »
Hallo Community,

ich habe zwar einen Beitrag zu der Thematik gefunden und bin auch über meinen anfänglichen "Fehler" gestolpert, aber gelöst ist das Problem noch immer nicht!
Meine bessere Hälfte hat scheinbar ihr PW für den BE Zugang falsch eingeben, das neue, zugeschickte hat laut Aussage auch nicht funktioniert ....
Jetzt wollte ich dem Benutzer ein neues PW verpassen und scheitere immer an dem Passus "Email wird bereits verwendet", klar ich will/wollte ja eigentlich nur das PW ändern ....
Nach dem ich den Dreh über deaktivieren und dann entfernen rausgefunden habe (ich bin der Meinung das dies etwas verwirrend ist), ist der Benutzer zwar jetzt gelöscht aber beim neu anlegen kommt der "Mist" mit der Email wieder ..... wird der Nutzer nicht komplett auch der DB entfernt, wenn man auf entfernen/löschen geht?!
Eigentlich sollte das doch der Fall sein oder, klar kann man den Benutzer ja nur deaktivieren und bei Bedarf wieder aktivieren, nur wenn diese meldung auch beim ändern des PW aufpoppt hilft das dann nicht wirklich weiter .....
Was muss ich also machen damit ich den Benutzer wieder anlegen kann, selber Name, Email und neuem Password??
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.13.0 r63]

Offline klaumich

  • Posts: 114
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Benutzer mit gleicher Email nach löschen wieder anlegen
« Reply #1 on: May 31, 2021, 07:06:29 PM »
Jetzt hat sich das Problem leider noch erweitert, warum auch immer komme ich jetzt auch mit dem Admin Login nicht mehr in das BE .... es kommt diese Fehlermeldung:

There was an uncatched exception
Call to undefined function bin\replace()
in line (357) of (/framework/Login.php):


Ich hab ein komplettes Backup zurückgespielt, auch die Datenbank, in der Hoffnung der ehemalige Benutzer wäre wieder da und ich könnte das mit dem Password noch mal quercheken ..... nur jetzt steh auch ich jetzt vor der verschlossenen Türe ......
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.13.0 r63]

Offline dbs

  • Betatester
  • **
  • Posts: 8660
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4459
  • Gender: Male
Re: Benutzer mit gleicher Email nach löschen wieder anlegen
« Reply #3 on: May 31, 2021, 08:23:44 PM »
Unbedingt updaten auf WB 2.13.0. Die gibt es im Wiki inzwischen als Final.

Dietmar
Note: Once the code has been generated, it is easy to debug. It's not a bug, it's a feature!

Offline klaumich

  • Posts: 114
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Benutzer mit gleicher Email nach löschen wieder anlegen
« Reply #4 on: June 01, 2021, 07:24:55 AM »
Hi, schau mal ob dir das weiterhilft:
https://forum.WebsiteBaker.org/index.php/topic,30914.msg215516.html#msg215516
Müsste ich probieren, nur ist das jetzt etwas kurios ..... bin jetzt in der Firma und hier ist der Login in´s BE problemlos möglich .... ist aber auch ein W10 Rechner wie zuhause  :-o
Das sind so Dinge wo ich vor der Kiste sitze und es mir die Fragezeichen nur so raushaut .... gestern fast 2 Stunden rumgemacht zuhause und nix ging und jetzt geht der Login ..... die Frage ist, funzt das daheim jetzt auch ?!? Vielleicht bezieht sich ja das Loginprob meiner Frau auch auf den lokalen Rechner zuhause .... nur warum?!? Was hat das lokale BS mit dem Server im Web zu tun ?!?

Unbedingt updaten auf WB 2.13.0. Die gibt es im Wiki inzwischen als Final.

Dietmar
Werde ich wohl machen, gibt es mit der Version 2.12.0 ein Problem mit Windows? Bisher liefen alle Seiten Problemlos damit, ich update immer etwas ungern wenn die Seiten keine Probleme machen, da ich auch bei diversen Updates schon ziemlichen Trouble hatte ..... ich bin immer froh wenn alles läuft, weil ich eben nicht so die Ahnung habe warum was nicht mehr läuft oder anders aussieht, bzw. nicht mehr angezeigt wird ....
Für die Meisten hier sind meine Problemchen sicherlich trivial, aber für mich war schon so mancher "Kieselstein" ein fast unüberwindbarer Berg  :?

#Edit: Noch zur Info, hier am Rechner geht auch der Login mit dem angelegten Benutzer .... also hat oder ist scheinbar die Kiste zuhause das Problem .... wobei meine Frau keine Fehlermeldung erhalten hat, sondern die Meldung das PW oder Benutzer nicht korrekt sein .... irgendwie merke ich, dass ich immer weniger verstehe ... Ich hab das gestern mit Edge und FF probiert mit dem Admin-Login, selbes Ergebnis .... hier mit Edge funzt es ....  :-o :-o :-o
« Last Edit: June 01, 2021, 07:35:44 AM by klaumich »
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.13.0 r63]

Offline dbs

  • Betatester
  • **
  • Posts: 8660
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Benutzer mit gleicher Email nach löschen wieder anlegen
« Reply #5 on: June 01, 2021, 08:05:44 AM »
Du solltest von dir selbst aus immer versuchen aktuell zu bleiben.
"Never change a running system" gilt hier nicht, weil sich die PHP Versionen zu schnell ändern und deshalb auch WB immer angepasst werden muss.

Um Kopfschmerzen mit dem Upgrade zu vermeiden, leg dir eine test Subdomain an und kopiere deine Seite da rein. Dann treibt dich ein Problem nicht gleich in den Wahnsinn und übt weniger Druck aus.

Die Sache mit den nichtfunktionierend en Logins haben manche, aber ich habe keine Ahnung warum.

Offline klaumich

  • Posts: 114
  • Gender: Male
  • Ziemlich Ahnungsloser
    • michler-web
Re: Benutzer mit gleicher Email nach löschen wieder anlegen
« Reply #6 on: June 01, 2021, 11:53:57 AM »
Du solltest von dir selbst aus immer versuchen aktuell zu bleiben.
"Never change a running system" gilt hier nicht, weil sich die PHP Versionen zu schnell ändern und deshalb auch WB immer angepasst werden muss.
nun ja .... da will ich ja nicht wiedersprechen, aber soo "alt" ist die 2.12. version ja auch noch nicht .... wenn ich überlege wie lange ich die Seiten mit 2.8.3 SP7 laufen hatte ... irgendwie wird das alles wahnsinnig kurzlebig und als DAU kommt man einfach nicht mehr mit  :|

Um Kopfschmerzen mit dem Upgrade zu vermeiden, leg dir eine test Subdomain an und kopiere deine Seite da rein. Dann treibt dich ein Problem nicht gleich in den Wahnsinn und übt weniger Druck aus.
Wäre eine Option, allerdings muss ich mich dann mit dem Thema auch erst mal befassen  :roll: :-o :-D Der Stress oder Druck wäre dann nicht ganz so groß, das ist korrekt, nur wenn ich dann auch in der Subdomain "Fehler" oder Probs habe, hilft mir das bei einem "akuten" Problem mit der eigentlichen Seite auch nicht direkt weiter .....

Die Sache mit den nichtfunktionierend en Logins haben manche, aber ich habe keine Ahnung warum.
Tja ...... wie geschrieben, mit dem Rechner im Büro fetzt alles, auch über mein MS Surface geht alles ....  allerdings wenn ich mich aus dem WLAN des Firmennetzwerkes auslogge und Mobil über Hotspot am S20 über das MS Surface in´s BE einloggen möchte, bekomme ich wieder die Meldung

There was an uncatched exception
Call to undefined function bin\replace()
in line (357) of (/framework/Login.php):


aber NUR bei der Domain mit der Vesion 2.12.0, bei den Domains mit den Versionen 2.12.1, 2.10.0 und 2.12.2 r379 geht der Login auch über die Hotspotverbindung  ....
das versteh wer will, ich bin da absolut raus .... werde dann mal den Patch von Dietmar probieren, bevor ich upgrade .....
Immer in der Hoffnung, dass das Licht am Ende des Tunnels der Ausgang ist ...
[WB vers. 2.13.0 r63]

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4459
  • Gender: Male
Re: Benutzer mit gleicher Email nach löschen wieder anlegen
« Reply #7 on: June 01, 2021, 04:25:25 PM »
Hallo,

dbs hat bereits alles gesagt, Jedes Jahr eine neue PHP Version, deswegen jedes Jahr umfangreiche Anpassungen des CMS. Ich empfehle auf die 2.13.0 upzugraden, Anwender hatten bereits ABUSE Mitteilungen Ihrer Provider, die reichlich in den 2.12.x Versionen und älter vorhanden sind.

Desweiteren sind wir auch bemüht Thirdparty Addons im Schweisse unseres Angesichtes  :evil: auf den neuesten PHP Stand zu bringen.

Ebenfalls ist bereits der größte Teil des Code, unter PHP 8 lauffähig. Probleme werden von uns wenn möglich zeitnah gefixt.

Dietmar
Note: Once the code has been generated, it is easy to debug. It's not a bug, it's a feature!

 

postern-length