Author Topic: SSL - all images not showing. How to fix?  (Read 754 times)

Offline styzer1137

  • Posts: 26
SSL - all images not showing. How to fix?
« on: March 16, 2021, 07:09:58 PM »
Hi,

I've implemented SSL for a website, but now all images disappeared both in the admin and on the website.

https://www.fredkaplanmusic.com/

I followed these excellent instructions. https://forum.WebsiteBaker.org/index.php/topic,31672.0.html

How can I correct all images links in MEDIA content?

Thanks!

Andre

Offline dbs

  • Betatester
  • **
  • Posts: 8626
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: SSL - all images not showing. How to fix?
« Reply #1 on: March 16, 2021, 07:24:46 PM »
Hi, you should als fofollow the instructions for .htaccess in this link.
Your site ist callable with and without www.
The right url is visible in the config.php. If clear if with or without www you have to change it in the .htaccess.

We can not recommand to use a old WB version. Please upgrade.

Offline styzer1137

  • Posts: 26
Re: SSL - all images not showing. How to fix?
« Reply #2 on: March 16, 2021, 07:45:59 PM »
Thank you for the reply.

I did follow the instructions for both the config.php and htaccess files.

https://forum.WebsiteBaker.org/index.php?action=post;quote=221659;topic=31672.0;last_msg=221664

But how could I force all http inages to be served as https?

I hear you for the upgrade, this will be done at a different time, though, as my client prefers to wait for now ($).

Regards,

Andre






Offline dbs

  • Betatester
  • **
  • Posts: 8626
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: SSL - all images not showing. How to fix?
« Reply #3 on: March 16, 2021, 07:51:29 PM »
Ah, sorry, thought there was also a code for https.
You can use the forum search for "htaccess ssl" or "htacess https".
Hope it helps.

Offline dbs

  • Betatester
  • **
  • Posts: 8626
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: SSL - all images not showing. How to fix?
« Reply #4 on: March 16, 2021, 07:54:13 PM »
I mean this post:
https://forum.WebsiteBaker.org/index.php/topic,31672.msg221659.html#msg221659

There you have add the www or not. Look into your config.php, is there a www?

Offline styzer1137

  • Posts: 26
Re: SSL - all images not showing. How to fix?
« Reply #5 on: March 16, 2021, 08:01:29 PM »
Thank you,

Is it safe to post this here? This is my config.

Code: [Select]
define('WB_PATH', dirname(__FILE__));
define('WB_URL', 'https://www.mywebsitemusic.com');

And I use the http/https rewrite rule from the post mentioned.

In the htaccess file, I also have this:

Code: [Select]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

But my images are not using https. That's why they are not showing. How come the rewrote rule does not extend?
« Last Edit: March 16, 2021, 08:10:01 PM by styzer1137 »

Offline styzer1137

  • Posts: 26
Re: SSL - all images not showing. How to fix?
« Reply #6 on: March 16, 2021, 08:12:05 PM »
UPDATE: the problem was that line in the htaccess:

Code: [Select]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

I removed it and everything is working perfectly as it should.

Thank you! Danke!! Merci!! Gracias! :)

Blessings,

Andre