Author Topic: Foldergallery 3.0.14 problem  (Read 475 times)

Offline svsanchez

  • Posts: 562
Foldergallery 3.0.14 problem
« on: January 19, 2021, 06:53:49 AM »
Hello!

I have upgrade a site to WB 2.12.2 with Foldergallery being upgraded to version 3.0.14.

The pictures do appear but all messed up, it seems that the CSS is not being loaded (please see attached image):



The Edit Css button shows only the following:

@charset "utf-8";
@import url('templates/default/css/default.css');

On previous versions of Folder Gallery, the pictures were nicely rendered in a grid, like this:

How do I make my gallery appear again as a grid?

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #1 on: January 19, 2021, 09:12:58 AM »
Hi, seems something is missing in your template.
I see JS error $.insert is not a function.

- Be sure in the index of your template is the line with
  register_frontend_m odiles('css');
  (only this line, the other two lines with register_ you can comment, is not needed)
- Deactivate your call for jquery from googleapis.com
- remove the line with mdcr.js (or comment it)
- go to Admin-Tools > Output Filter Frontend > tick the checkbox jQuery
  uncheck (if it is checked) the checkbox RegisterModFiles
  (a click on the filters show a little description of the filters)
- we need also the checkboxes for frontend css js, Droplets, LoadOnFly and ScriptVars.

Your call for a script from provimetales.com produce a error. Comment or delete this line.

I hope this helps a little bit.
I found your page with Google. Next time a link from you would be nice.

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #2 on: January 19, 2021, 05:04:50 PM »
You, Mr. dbs, are THE man!



You deserve a beer, here's a fine Guatemalan beer for you... Cheers!

Thank you!!!

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #3 on: January 19, 2021, 05:13:53 PM »
The next time I'm in Guatemala, we'll toast.  8)

Cheers

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #4 on: January 19, 2021, 08:15:20 PM »
Sure thing dbs!

Is there some documentation about the Foldergallery 3.0.14? I am trying to make it work on another site but I can't tell it which folder to use (it is showing everything under the MEDIA folder).

On the previous versions, I could tell FG the folder where the images where, but on this new version it seems to use MEDIA for all the galleries, and then I have to select which folder I want to show:



But since the folder is INSIDE another folder, it won't show...

Here's the URL: https://fotos.deguate.net/mujeres/chapinas/gabriela-asturias/gaby-asturias-hot.php



Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #5 on: January 19, 2021, 09:29:25 PM »
Please try the version 3.4.0-dev1 (attached).
-dev means it is in development but should work.
« Last Edit: January 19, 2021, 11:43:31 PM by dbs »

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #6 on: January 19, 2021, 10:52:38 PM »
I get this message, even though I'm using 2.12.2  :?

It is not possible to upgrade or install from a WebsiteBaker Versions before 2.12.2


Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #7 on: January 19, 2021, 11:49:55 PM »
Seems the FG is for next WB version 2.13. Forget thi version, try 3.0.16.
It works for me in a 2.12.2.

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #8 on: January 20, 2021, 03:23:06 AM »
Thank you, I was able to install this one but I'm still having the same problem: I can't tell FG which folder to use for each gallery. The MEDIA folder is chosen by default and it doesn't show the subfolders:



I have about 80 pages each with a gallery which are structured like this:

media > mujeres > chapinas > gabriela-asturias > gaby-asturias-hot

In this particular case, I only want to show the pictures on the last sub-folder (gaby-asturias-hot). But, the page shows the breadcrumbs, then a link to the subfolders (starting from media) and finally the pictures from the chosen subfolder:



This specific gallery should appear on this URL: https://fotos.deguate.net/mujeres/chapinas/gabriela-asturias/gaby-asturias-hot.php

I have no idea what I'm doing wrong.


Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #9 on: January 20, 2021, 10:03:19 AM »
Hi, please test this:
- go to Extensions > Modules > Advanced > choose "upgrade" Foldergallery  (and pray)

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4442
  • Gender: Male
Re: Foldergallery 3.0.14 problem
« Reply #10 on: January 20, 2021, 12:26:42 PM »
In my view a thumbnail size of 100px is not recommed. A size of min 150px is a better value.

In the moment the size wouldn't decrease font-size

Dietmar
Note: Once the code has been generated, it is easy to debug. It's not a bug, it's a feature!

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #11 on: January 20, 2021, 06:14:57 PM »
Hi, please test this:
- go to Extensions > Modules > Advanced > choose "upgrade" Foldergallery  (and pray)

Hi dbs, I "upgraded" folder gallery from the add-ons menu but it still doesn't allow me to change "media". HOWEVER, I just noticed the following:

The rest of the galleries are working, this is how their settings look by default:



However they all have by default the Lightbox effect "colorbox" which I don't like.



So, when I go to the gallery to change it to a nicer Lightbox effect, the problem occurs and the whole filesystem folder appears below, from the Media folder to the last subfolder:



So, what is triggering this problem is when I try to change the Lightbox effect. I'm not sure if changing another setting would also trigger the problem (I already messed up 4 galleries and didn't want to mess another one).

My questions:

1) How can I fix the messed up galleries so that FG shows only the pictures from the subfolder I want?

2) How can I change the lightbox effect without messing up my other categories?

Thank you...

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #12 on: January 20, 2021, 06:18:21 PM »
In my view a thumbnail size of 100px is not recommed. A size of min 150px is a better value.

In the moment the size wouldn't decrease font-size

Dietmar

Hello Luisehahne, I used 100px thumbnails so that 3 pictures can be shown in a row on Mobiles.

Does the size of the thumbnails affect in any way the problem that I am having?

Please explain, thank you!

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #13 on: January 21, 2021, 05:26:15 AM »
Is there a way to change the lightbox effect via phpMyAdmin? I tried to change it on another site's gallery but it didn't work  :-(

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #14 on: January 21, 2021, 08:33:45 AM »
Hi, yes, here:             

table
mod_foldergallery_s ettings

column
s_name      column s_value 
lightbox                   jqueryFancybox


With phpMyAdmin you can also do a database export and also a import for your test environment.  ;)

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #15 on: January 21, 2021, 09:10:43 AM »
Hello dbs, I'm not sure what's wrong but something didn't work, I upgraded this old site http://fsantiago.com/pages/galeria.php from WB 2.8.3 to WB 2.12.2 and this happened:

1. Updated foldergallery to 3.0.14 and I got the following error:

There was an uncatched exception
Call to a member function fetchRow() on null
in line (131) of (/modules/foldergallery/view.php):

2. So, I updated foldergallery to 3.4.0-dev1 and the error message disappeared (BUT, when I go to add-on modules, it says it's not 3.4.0-dev1 but 3.0.16!!!).

3. Since changing the Lightbox effect via the WB Admin messed up the galleries on my other sites, I changed the Lightbox effect via phpMyAdmin, but nothing happens (NO lightbox effect, images open on the whole page)

4. Backed up everything and decided to risk changing the Lightbox effect via the admin. The good news is that it did NOT messed up the galleries, the bad nes is that the Lightbox effect doesn't change, images still open on the whole page :-o

Hgs sent me a link to a page with several modules, including foldergallery 3.4.0-dev2 which works great on that test site (on WB 2.13). If possible, I would like to try FG 3.4.0-dev2 on this site!!!

Or, maybe you know how to fix the LIghtbox from messing the galleries when it is changed via the Admin (see my post from anuary 20, 2021, 06:14:57 PM on this same thread).

Thank you

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Foldergallery 3.0.14 problem
« Reply #16 on: January 21, 2021, 09:49:24 AM »
The Foldergallery update makes often problems. Clear solution is uninstall and install new.
This is easy if no image descriptions are in use.

Your lightbox effect have the right name?
The .htt of this lightbox is really to find in /modules/foldergallery/templates/your-used-template/

Your linked page has no jQuery loaded. Remenber Admin-Tools > Output Filter > jQuery

Offline svsanchez

  • Posts: 562
Re: Foldergallery 3.0.14 problem
« Reply #17 on: January 21, 2021, 11:07:09 PM »
Thank you so much for your help with the Foldergallery. I was able to make work FG v3.0.16 both on desktop and mobile, with the lightbox working OK.

HOWEVER, on Mobile the categories do not look OK, because they appear inside some "boxes" with the text too low, making it impossible to read:



The text does come up when you tap on the image, but it's not very useful this way on Mobile because if you tap on the picture you will open the tapped gallery without being able to read what the name of the gallery is. Most people won't know that they have to "long tap" on the picture to avoid opening the gallery.

Is it possible to make the "boxes" a little wider, or to get the text up without the animation?

The URL, in case you want to check it, is http://www.fsantiago.com/pages/galeria.php (remember, the problem is on MOBILE!)