Author Topic: Error message when trying to write text to a new page in WB 2.12.2  (Read 348 times)

Offline VSG

  • Posts: 254
Hi everyone,

further testing my XAMPP-installation of WB 2.12.2, I am constantly getting the following error-message:
Code: [Select]
[74] Field 'content_comment' doesn't have a default value
This happens when I try to add text to a newly created site (only WYSIWYG-section).
I can modify already existing sites, but not create text in new ones. Creating the site itself works like a charm.

I reuploaded all the package-files already, but to no avail.

Any help is appreciated. Thanks!
Best regards,
VSG

PS: Does anybody know if there is a way to get the Page-Cloner-module running on 2.12.2? That module is so handy …

Offline dbs

  • Betatester
  • **
  • Posts: 8399
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Error message when trying to write text to a new page in WB 2.12.2
« Reply #1 on: June 06, 2020, 01:40:38 PM »
Hi, i know this message and in my case it comes from an old hack named "wysiwyg with history".
It has to do with mysql in strict mode.
If you not use this hack anymore you should delete the old database fields.


Offline VSG

  • Posts: 254
Re: Error message when trying to write text to a new page in WB 2.12.2
« Reply #2 on: June 06, 2020, 01:50:11 PM »
Hi DBS!

Thanks for the info. I'll try that. Yes, that module was worth it's weight in gold. :|

Could you tell me what database fields WB actually needs - right now I have the following:

section_id
page_id
last_version
hist_autosave
hist_autosave_num
user_id
user_id_working
content
content_comment
text

Unfortunately those modules didn't come with an uninstall-functionality.

Best regards,
VSG

Offline VSG

  • Posts: 254
Re: Error message when trying to write text to a new page in WB 2.12.2
« Reply #3 on: June 06, 2020, 02:24:24 PM »
Found it, thanks!

Base-WB only needs the sections "section_id, page_id, content, text" in the "wb_mod_wysiwyg"-table.

Offline VSG

  • Posts: 254
Re: Error message when trying to write text to a new page in WB 2.12.2
« Reply #4 on: June 08, 2020, 06:54:25 PM »
After having installed WB 2.12.2 (overcoming my own mistakes along the way), I still encounter the 'problem' that the Page-Cloner-module will quit with an error message upon trying to clone a page:
Code: [Select]
Field 'link' doesn't have a default value

Anyone successful in getting it to work with 2.12.2?
Thanks in advance!
Best regards,
VSG

Offline dbs

  • Betatester
  • **
  • Posts: 8399
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Error message when trying to write text to a new page in WB 2.12.2
« Reply #5 on: June 08, 2020, 06:59:19 PM »
It is a mysql strict thing, not a WB 2.12.2 problem.
I will have a look.

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4397
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: Error message when trying to write text to a new page in WB 2.12.2
« Reply #6 on: June 08, 2020, 10:18:52 PM »
It is a mysql strict thing, not a WB 2.12.2 problem.
I will have a look.

Correct  (Y)

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline dbs

  • Betatester
  • **
  • Posts: 8399
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests