Author Topic: SMTP-Maileinstellungen: Authentifikation läßt sich nicht aktivieren  (Read 49427 times)

Offline rjscd

  • Posts: 26
Hallo liebe WB-Community,

ich bin immer noch dabei, die Updatefehler, die beim Update von der Vers. 2.8 auf 2.12.1 aufgetreten sind mit meinem Provider zu klären. Leider kommen wir nur Stückchen für Stückchen voran. Das Problem mit den Droplets ist gelöst. Nun arbeiten wir daran, warum das Kontaktformular, erstellt mit Form 3.1.9 nicht so funktioniert, wie es soll. So läßt sich z. B. SMTP-Authentifikation nicht mit enem Häckchen aktivieren. Weiß hier jemand warum dies so ist?

Und das zweite auffällige Problem ist, dass ich das Formular im Frontend zwar ausfüllen kann, aber wenn ich es absende, erscheint die beigefügte Fehlermeldung. Sie spricht von einem Fehler im PHP-Mailer, obwohl auf SMPT umgestellt wurde?

Leider bin ich hier nicht so tief im Thema drin, als das ich da auch nur einen Lösungsansatz sehe. Ich hoffe hier wieder auf eure tolle Unterstützung. Dafür wollte ich übrigens mal ein Lob aussprechen!

Ich freue mich auf eure Antworten. Vielen Dank für eure Mühe.

Gruß
RJSCD

Offline dbs

  • Betatester
  • **
  • Posts: 8027
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Hi, eigetlich steht in der Fehlermeldung, dass die SMPT Verbindung nicht geklappt hat.
Hast du die Zugangsdaten mehrfach geprüft? Ist es eine Emailadresse vom Verein bzw. der gleichen Domain?

Leider ist nicht klar wie der Hoster WB aktualisiert hat. Wirklich von 2.8 auf 2.12.1? Da wäre eigentlich erst der Schritt zu 2.8.3 nötig gewesen.

Offline rjscd

  • Posts: 26
Danke dbs für den Tipp! Ja, ich habe die Zugangsdaten mehrfach geprüft und auch mit den Einstellungen auf meiner eigenen Homepage verglichen. Ich bin streng nach den Angaben vom Hoster vorgegangen. Aber es könnte wirklich daran liegen, dass der Schritt auf 2.8.3 übersprungen wurde und gleich auf 2.10 oder 2.11 upgegradet wurde. Ist es denn unbedingt notwendig auf 2.8.3 upzugraden und warum ist das so? (Nur damit ich es meinem Provider klarmachen kann!).

Vielen Dank

Viele Grüße

RJSCD
« Last Edit: July 25, 2019, 08:38:15 AM by dbs »

Offline hgs

  • Betatester
  • **
  • Posts: 1116
    • EFG MG
Ja , das ist so erforderlich.
Ein Upgrade auf 2.10 bis 2.12.x geht nur ab WB 2.8.3 Rev. 1611

Alles davor bitte nach dieser Anleitung auf die WB 2.8.3 Rev. 1611 bringen
Quote
Zitat aus der README_DE.md im Ordner /DOKU
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[6] Aktualisieren Sie WebsiteBaker von älteren Versionen vor WB-2.8.3
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Bevor Sie ein Upgrade von einer älteren Version vor WB-2.8.3 durchführen, müssen Sie zuerst auf [WB 2.8.3 vom Feb.2012] upgraden.
Diese Version kann von jedem dieser Links heruntergeladen werden:
https://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?id=0EA85F12
oder
https://wiki.WebsiteBaker.org/doku.php/en/downloads#websitebaker_283

Upgrade Anweisungen für WebsiteBaker finden Sie in unserem Forum:
english: https://forum.WebsiteBaker.org/index.php/topic,23412
deutsch: https://forum.WebsiteBaker.org/index.php/topic,23658


LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline rjscd

  • Posts: 26
VIelen Dank für deine Auskunft!
« Last Edit: July 25, 2019, 08:38:43 AM by dbs »

Offline dbs

  • Betatester
  • **
  • Posts: 8027
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Bitte keine Vollzitate in direkten Antworten.

Bei so alten Versionen wie 2.8 ist der Schritt notwendig. Dier erfolgten Änderungen in der DB würden sonst fehlen.
Das steht aber auch in der Upgrade-Anleitung der 2.12.1. Hätte der Hoster lesen können. Aber vielleicht hat er es ja richtig gemacht. Man weiß es nicht.

Häufigstes Problem bei Upgrades: nicht alle Dateien wurden übertragen/überschrieben. Dann einfach mehrfach machen.

Offline rjscd

  • Posts: 26
Sorry, bin noch ein wenig ungeübt mit dem Forum.

Hat denn sonst keiner ein Problem, das Häkchen bei SMTP-Authentifizierung zu setzen? Es wird ja erkannt, dass wenn ich mit der Maus über das Kästchen fahre es sich um eine Funktion handelt. Der Pfeil wandelt sich ja in eine Hand mit Zeigefinger um. Nur wenn ich drauf klicke tut sich nichts.

Ich kann es auch bei einer Neuistallation von Vers. 2.12.1 auf einem anderen Server und Provider nicht setzen. Ist das ein Programmfehler im CMS oder habe ich dort etwas falsch gemacht?

Ich freue mich auf eure Erfahrungen und Antworten.

Gruß RJSCD

Offline dbs

  • Betatester
  • **
  • Posts: 8027
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Die 2.12.1 ist nicht die aktuelle Version. Wir sind bei 2.12.2.
Dort gibt es unter Optionen > Erweiterte Optionen > Maileinstellungen  kein Kasten für Häckchen mehr.

Wenn der Emailversand allgemein nicht funktionieren würde mit SMTP würden hier sehr viel mehr Threads darüber entstehen.
Versuch die 2.12.2 und vielleicht auch testweise bei einem anderen Hoster. WB funktioniert ohne viel Gefummle auf sehr vielen modernen Server-Konfigurationen.

Offline rjscd

  • Posts: 26
Danke dbs für den Tipp. Habe mir die aktuelle Version herunter geladen.

Gibt es eine Anleitung, wie das mit dem Upgradescript funktioniert irgendwo zum nachlesen? Die offizielle Doku https://wiki.WebsiteBaker.org/doku.php/info/install/upgrade gibt da nicht unbedingt etwas her.

Danke für eure Mühen.


Offline dbs

  • Betatester
  • **
  • Posts: 8027
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Hier in der offiziellen Ankündigung gibt’s auch deutsch.
https://forum.WebsiteBaker.org/index.php/topic,31528.0.html

Offline rjscd

  • Posts: 26
Re: SMTP-Maileinstellungen: Authentifikation läßt sich nicht aktivieren
« Reply #10 on: July 27, 2019, 08:21:59 AM »
Danke liebe Community für die Tipps!

Offline dbs

  • Betatester
  • **
  • Posts: 8027
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: SMTP-Maileinstellungen: Authentifikation läßt sich nicht aktivieren
« Reply #11 on: July 27, 2019, 08:45:20 AM »
Aber nicht vergessen, der richtige Weg wäre:
Von deiner 2.8 > 2.8.3 > 2.12.2 (bzw. aktuellste Version)

Module, die du selbst installiert hast, könnten inzwischen veraltet sein und Fehlermeldungen produzieren. Deshalb nachschauen ob es aktuellere Versionen gibt. Z.B hier: https://addon.WebsiteBaker.org/pages/en/browse-add-ons.php

Offline rjscd

  • Posts: 26
Re: SMTP-Maileinstellungen: Authentifikation läßt sich nicht aktivieren
« Reply #12 on: July 29, 2019, 11:15:14 AM »
Ja danke dbs. Das System ist inzwischen bereits auf 2.12.1 aktuallisiert. Nun probiere ich mal die Neueste Version über die Update-Funktion zu installieren. Zunächst erst einmal auf einer Präsenz, die z. Zt. nicht aktiv ist. Falls ich was falsch machen sollte.

Nochmals Danke für deinen Rat und deine Mühe.

Gruß RJSCD

Offline jacobi22

  • Posts: 5872
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: SMTP-Maileinstellungen: Authentifikation läßt sich nicht aktivieren
« Reply #13 on: July 29, 2019, 12:03:38 PM »
Nur mal zur Aufklärung um diese Checkbox zur SMTP-Authentifikation

- diese Checkbox ist seit WB 2.10 disabled, also deaktiviert. Die Übermittlung des Wertes findet zwar statt, jedoch erfolgt keine Auswertung. In der save.php wird dieser Wert mit TRUE behandelt - in einfachen Worten: wurde aktiviert.

- die Authentifikation wird automatisch aktiviert, wenn in den WB-Settings SMTP als Methode für den Mailversand gewählt wurde. Sie soll sicher stellen, das nur als vertrauenswürdig eingestufte Benutzer Mails versenden dürfen. Mit einer einfachen PHP-Mail ist es z.b. für Besucher möglich, Spam-Mails über bestimmte Module zu versenden - im Namen des Webseitenbetreibers

Da es in der Vergangenheit öfter zu Unklarheiten geführt hatte, ob diese Box nun aktiviert werden muß oder nicht, wurde diese Einstellung per default aktiviert. Etwas anderes macht in unseren Breiten (Europa + SMTP) wenig Sinn. Da es aber auch Benutzer gibt, die diese Option benötigen, blieb sie im Code erhalten und kann durch Anpassung zweier Zeilen wieder schaltbar gemacht werden, durch Überschreibung in einer Zeile der CSS-Dateien wieder sichtbar.

Abhängig von der benutzten WB-Version ist die Checkbox mal zu sehen, aber deaktiviert, mal ist sie per CSS ausgeblendet, so wie in der aktuellen WB-Version. Einige Browser bzw Browsertools stellen sie aber auch jetzt noch dar, ausgegraut und nicht schaltbar.

So, wie im Bild würde der Spaß in einer WB 2.12.2 aussehen, wenn man das CSS gewollt oder ungewollt manipuliert




Wer nicht will, findet Gründe, wer will, findet Wege.

Offline rjscd

  • Posts: 26
Re: SMTP-Maileinstellungen: Authentifikation läßt sich nicht aktivieren
« Reply #14 on: August 07, 2019, 06:06:02 PM »
Danke jacobi22 für deine ausführliche Erlklärung. So kann ich das Verhalten von WB verstehen. Diese Info kannte ich nicht. Inzwischen habe ich auf Vers. 2.12.2 upgedated.

Gruß

RJSCD