Author Topic: wblink does not work  (Read 503 times)

Offline noname8

  • Posts: 145
wblink does not work
« on: December 13, 2018, 10:58:06 AM »
I'm in the stage of updating old baker site 2.8.1
to 2.8.3 SP5 (and then more)

but in this stage the [WBLINK223] does not work in the frontend.
They worked with the old version and i did not change template files. No error is produced
They work in the admin nicely

I have in the template, header section:

Code: [Select]
<?php 
if (function_exists('register_frontend_modfiles')) {
//register_frontend_modfiles('css');
//register_frontend_modfiles('jquery');
register_frontend_modfiles('js');
?>


Just Before the body closing tag there is

Code: [Select]
register_frontend_modfiles_body();
i found preprocess -function from class.frontend.php and put die() in it. It is never called


Offline noname8

  • Posts: 145
Re: wblink does not work
« Reply #1 on: December 13, 2018, 11:01:11 AM »
wow, found out fast. Old template didn't have buffer.
This fixed it

Code: [Select]
<?php 
    ob_start
();
    
page_content(1); ?>
<!-- Content Block 2 - Header Content -->
...
$output = ob_get_contents();
    ob_end_clean();
    $wb->preprocess($output);
    echo $output;


Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: wblink does not work
« Reply #2 on: December 13, 2018, 11:22:24 AM »
Hi, i think you have nothing to fix.
Do the needed upgrade steps from 2.8.1 to 2.8.3 and then upgrade. Don't check the website.
Make the next step, upgrade to 2.12.1.
Update your modules if it is possible. Now fix what is needed.