Author Topic: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?  (Read 261 times)

Offline imebro

  • Posts: 745
Hallo,

nach dem Update meines Webs auf die Version 2.12.1 suche ich nun ein aktuelles WB-Portable, um meine Webseite wieder lokal verfügbar zu machen.
Grund ist, dass ich gerne ein neues Template testen möchte.

Weiß jemand von Euch, wo ich das aktuellste WB-Portable finde? Die Suche hier im Forum ergibt keine Ergebnisse  :roll:
Eines für 2.11 mit PHP 7.1 habe ich hier gefunden:
https://portable.WebsiteBaker.org//en/about-portable-edition.php. Oder ist das schon die aktuellste Version?

Hierzu suche ich freie Templates, die Responsive Design bieten.

Hat hier auch jemand von Euch Tipps, wo ich solche Designs (möglichst free) finden kann?

Danke & schöne Grüße,
imebro

Offline dbs

  • Betatester
  • **
  • Posts: 7549
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #1 on: October 16, 2018, 10:46:57 AM »
Moin, die Portable in deinem Link ist die aktuellste. Wichtig hierbei ist nur die 7er PHP Version.
Das WB darin kannst du genauso upgraden wie bei deiner Homepage.

Jede Menge Templates findest du bei Chio: https://WebsiteBaker.at/wb/templates.php

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #2 on: October 16, 2018, 11:00:01 AM »
OK und danke...
Habe mir die Version jetzt runtergeladen und schon meine Onlinesicherung dort über FTP eingefügt.
Aber leider startet das "Apache" nicht über das USB-Webserver-Fenster. Auch wenn ich es manuell starte, dann startet es, es erscheint kurz ein grüner Haken, aber kurz darauf erscheint wieder das rote Ausrufezeichen.

Bei http://localhost:4001/phpmyadmin erscheint dann eine Meldung "Verbindung fehlgeschlagen", wenn ich auf den Button "PHPMyAdmin" klicke. Das Gleiche auch mit http://127.0.0.1:4001/phpmyadmin.

Hast Du ne Idee, woran das liegen könnte?

LG
imebro
« Last Edit: October 16, 2018, 11:05:25 AM by imebro »

Offline dbs

  • Betatester
  • **
  • Posts: 7549
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #3 on: October 16, 2018, 12:16:45 PM »
Das könnte an PHP7 liegen.
Du brauchst möglicherweise "vc_redist.x86.exe" für dein Windows.
Einem User hier half das auch (klick).

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #4 on: October 16, 2018, 12:50:13 PM »
Hallo nochmal.
Habe jetzt die Version von VC für 86 und 64 Bit installiert, aber leider besteht das Problem nach einem Neustart des Laptops noch immer  :roll:

LG
imebro

Offline jacobi22

  • Posts: 5199
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #5 on: October 16, 2018, 12:58:12 PM »
schau mal in den Ordner apache2/logs in die Datei error.log, ob und was da drin steht
Läuft denn MySQL?
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #6 on: October 16, 2018, 02:39:07 PM »
Danke Dir "jacobi22".

Ich hatte mich schon gewundert, dass ich über den USBWebserver das Log nicht aufrufen konnte.
Habe jetzt in dem von Dir angegebenen Pfad nachgesehen... das Verzeichnis "logs" ist leer  :roll:

MySQL läuft im USBWebserver  (Y)

LG
imebro

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #7 on: October 16, 2018, 03:50:27 PM »
...gerade eben habe ich gesehen, dass man im USBWebserver über den Button "Apache" und dann einen Klick auf "Logs" ein neues Log erstellen kann (siehe Anhang). Das wird dann zwar angelegt, aber nicht mit Inhalt gefüllt.

Ich habe z.B. eben dann den Apache-Server nochmal gestartet, dann in "Allgemein" auf "PHPMyAdmin" geklickt und erhielt dann wieder die Fehlermeldung (siehe mein erster Post). Als ich dann die "error.log" geöffnet habe, war sie leer  :|

Nochwas:
Wenn man im USBWebserver auf "www.USBWebserver.co m" klickt, landet man auf einer leeren Webseite  :roll:
Also irgend etwas scheint mit dem Teil noch nicht so wirklich rund zu laufen...

Habt Ihr noch ne Idee?

Danke und Gruß,
imebro
« Last Edit: October 16, 2018, 03:56:39 PM by imebro »

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #8 on: October 16, 2018, 04:06:56 PM »
...habe mir den USBWebserver (v8.6.2 - with PHP 7.1 - 11/11/2017) gerade mal testweise manuell heruntergeladen von der Seite https://usbwebserver.yura.mk.ua/. Nach dessen Start ist jedoch genau das gleiche Problem vorhanden. Apache startet nicht  :oops:

Jetzt bin ich mit meinem Latein aber echt am Ende...

LG
imebro

Offline dbs

  • Betatester
  • **
  • Posts: 7549
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #9 on: October 16, 2018, 04:23:42 PM »
Hier können wir nur noch schwer helfen.
Du hast dir jetzt von einer gefundenen Seite im Netz eine exe runtergeladen.  :-o  :-)

Hast du Skype nebenher laufen? Das benutzt auch Port 80 wie dein neuer Portable. Falls ja, Port ändern.
Hatte die Firewall dich was gefragt wegen Portable?

Offline jacobi22

  • Posts: 5199
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #10 on: October 16, 2018, 04:34:10 PM »
bin grad erst wieder rein und auch gleich wieder weg...
Das Programm aus deinem 1. Post läuft bei mir, allerdings muß sowohl für den Apache wie auch für Mysql jeweils der Zugriff der Windows-Firewall auf die jeweiligen Ports genehmigt werden. Das war auch bei Portable so und ist immer ein einmaliger Vorgang

Ein Anleitung für Windows:
1. Klicke auf Start und schreibe ins Suchfeld die Buchstaben  cmd
2. angezeigt wird dir u.a. der Treffer  "Eingabeaufforderung"
3. klicke mit der rechten Maustaste auf das Feld "Eingabeaufforderung und wähle die Option "als Administrator" öffnen
4. Verschiebe den Ordner "usbwebserver" auf eine andere Festplatte oder (wenn nicht vorhanden) als separaten Ordner unter Festplatte C:
5. Nun ins Fenster der Eingabeaufforderung, das ist ein schwarzes DOS-Fenster, angezeigt wird normalerweise der Pfad  C:\WINDOWS\system32>
6. schreibe dort zuerst hin:  cd.. drücke ENTER, schreibe erneut cd.. drücke erneut ENTER, damit navigiert man in den Ordner, cd heißt hinein, cd.. heißt hinaus

Nun solltest du im Hauptverzeichnis C:\ sein
7. Nachfolgendes ist abhängig vom Ort, an dem sich der Ordner usbwebserver nun befindet, die Festplatten wechselt man mit Angabe des Buchstabens, gefolgt von einem Doppelpunkt, z.b. F:
Nun wechselt man mit cd.... in den jeweiligen Ordner , das schaut bei mir so aus   F:\usbwebserver
nun wechselt man weiter in das Verzeichnis apache2, danach in das Verzeichnis bin
also F:\usbwebserver\apache2\bin>
nun schreibst du dahinter httpd_usbwv8.exe
schaut in etwa so aus



nun sollte Apache entweder starten, ggf nach der Firewqall fragen oder eine Menge Informationen liefern, warum es nicht startet
Diesen Text bitte komplett mit der Maus kopieren (STRG + C) und hier einfügen (STRG + V) oder einen Screenshot machen
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #11 on: October 16, 2018, 05:26:58 PM »
@ "dbs":
Skype läuft bei mir nicht. Dazu hatte ich auch schon im Internet Hinweise gefunden und das schon überprüft. Port 80 ist offenbar also nicht belegt.

@ "jacobi22":
Danke für die Mühe... hat bis zum Start der Datei "usbwv8.exe" auch funktioniert.
Aber dann kam die folgende Fehlermeldung:

Code: [Select]
httpd_usbwv8.exe: Syntax error on line 44 of C:/usbwebserver2/apache2/conf/httpd.conf: ServerRoot must be a valid directory

Beim ersten Start der "WebsiteBaker-Portable.exe" waren auch genau diese beiden Abfragen der Windows Firewall gekommen. Ich hatte beide dann durch den entsprechenden Haken auch zugelassen.

Aber jetzt gibt es wohl einen Fehler in der config-Datei...
Werde mir das mal anschauen, aber mal schauen, ob ich damit was anfangen kann  :roll:

Danke & Gruß,
imebro

---------------------
EDIT:

Habe mir soeben die Datei "httpd.conf" angeschaut. Dort steht in der Zeile 44 (siehe Fehlermeldung) der Pfad von dort, wo der "usbwebserver" vorher lag. Das werde ich nun mal ändern und den Pfad zu "C:/usbwebserver2/apache2" dort eintragen und dann nochmal testen.

EDIT 2:

Dieser Pfad muss offenbar mehrfach angepaßt werden in der "httpd.conf". Werde mal über Suchen/Ersetzen alle Pfade ändern

« Last Edit: October 16, 2018, 05:42:37 PM by imebro »

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #12 on: October 16, 2018, 05:47:18 PM »
...das mit dem Verschieben macht keinen Sinn. Jetzt folgen immer mehr Folgefehler darauf (siehe Screenshot).

Ich werde jetzt den USBWebserver nochmal komplett von meinem System entfernen (hoffe dass ein löschen ausreicht...) und zwar im ersten Pfad und auch vom Laufwerk C. Danach den Rechner neu starten und dann das Teil nochmal neu runterladen und direkt auf C installieren. Vielleicht gehts dann.

LG
imebro


Offline crnogorac081

  • Posts: 1879
  • Gender: Male
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #13 on: October 16, 2018, 06:12:05 PM »
Open firewall and delete all exceptions. Then dissable firewall and try again.
no bb in signature

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #14 on: October 16, 2018, 06:21:48 PM »
Danke Dir "crnogorac081".
Habe es aber schon geschafft, indem ich jetzt komplett alle beiden USBWebserver nochmal vom System gelöscht habe.
Dann Rechner nochmal neu gestartet.
Anschließend den "CCleaner" ausgeführt.
Danach habe ich ihn nochmal neu heruntergeladen und dann direkt auf Laufwerk C:\ entpackt und zwar nur mit dem Namen "usbwebserver".
Dann die "WebsiteBaker-Portable.exe" gestartet und jetzt klappt es  (Y)

Jetzt werde ich die "wbdemo" von vorher in dieses Verzeichnis kopieren nach "C:\usbwebserver\root", dann die SQL-Datei zurück kopieren und dann testen, ob ich meine Webseite dann lokal sehe  :lol:

Danke für Eure Hilfe bis dahin...

LG
imebro

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #15 on: October 16, 2018, 06:37:26 PM »
Mensch...  :oops: :cry:

Hier wird es einem aber echt schwer gemacht...

Jetzt wollte ich die SQL-Datei über PHPMyAdmin hochladen... geht auch... aber nach Klick auf OK wird mir folgende Fehlermeldung angezeigt:

Code: [Select]
Möglicherweise wurde eine zu große Datei hochgeladen. Bitte lesen Sie die Dokumentation zur Lösung diese Problems.

Diese Dokumentation ist ellenlang und auch noch in englischer Sprache  :roll: echt super!

>>> http://localhost:4001/phpmyadmin/doc/html/faq.html#faq1-16

Meine SQL-Datei hat 14.996 kb, also ein Vielfaches der offenbar möglichen 2.048.
Habe jetzt einige Angaben aus der Dokumentation in der "php.ini" verändert, aber auch danach läßt sich meine SQL-Datei nicht hochladen mit dem gleichen Fehler, obwohl ich die entsprechenden Größenangaben ja angepaßt hatte.

Habt Ihr ne Idee? Keine Ahnung, wonach ich in dieser Dokumentation überhaupt sonst noch suchen soll

LG
imebro
« Last Edit: October 16, 2018, 06:51:09 PM by imebro »

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #16 on: October 16, 2018, 07:25:32 PM »
...was lange währt, wird endlich gut  :-D

Hab die SQL-Datei einfach gezippt und dann am Ende mit ".sql.zip" benannt.
Dann war sie nur 1.500 kb groß und der Import klappte  (Y)

Frontend klappt auch und meine Webseite wird nun lokal angezeigt  (Y)

LG
imebro

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #17 on: October 16, 2018, 11:08:07 PM »
Nun habe ich doch nochmal eine Frage...

Jetzt läuft meine Seite lokal... dachte ich... denn es funktioniert ausschließlich die Startseite.
Will ich eine andere Seite aufrufen, muss ich zunächst oben im Pfad zusätzlich ein "/wbdemo" eingeben... also z.B. so:

http://localhost:4001/wbdemo/tools/

Ich habe schon mit der ".htaccess" herum probiert und auch mit der "config.php". Aber bisher habe ich noch keine Lösung gefunden, den Zusatz "/wbdemo" automatisch hinzuzufügen oder zu bewirken, dass es eben auch ohne diesen Zusatz klappt.

LG
imebro

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #18 on: October 16, 2018, 11:27:56 PM »
...OK - auch wenn ich hier nur mit mir selbst herum schreibe (sorry dafür)  :roll:

Problem mit dem Pfad habe ich jetzt gelöst über ein verändertes "ShortLinks"-Droplet.
Funktioniert jetzt alles.

Danke für Eure Hilfe  (Y)

LG
imebro

Offline dbs

  • Betatester
  • **
  • Posts: 7549
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #19 on: October 17, 2018, 08:14:59 AM »
Moin, was nicht sofort ganz klar wird beim Portable: wenn ein Ordner wie /wbdemo/ verwendet wird, befindet sich die Installation in einem Unterordner, also nicht im Root. Deshalb muss bei Shorturl die .htaccess angepasst werden (wie hier klick).
Wenn du das durch Ändern des Droplets erreicht hast, auch gut.

Für dich hat der ganze Prozess hier aber auf jeden Fall einen positiven Lerneffekt.  :-)

Übrigens: du musst keinen ordner wbdemo oder die Hilfeseiten verwenden, könntest die Installation also eine Ebene höher schieben (config.php anpassen) und vorher alles rausschmeissen was da so rumliegt.

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #20 on: October 17, 2018, 10:50:34 AM »
Hallo "dbs" und danke für die weitere Erläuterung.

Ja... habe wohl ne Menge dazu gelernt  (Y)
Aber etwas habe ich noch nicht verstanden.

Habe in der ".htaccess" jetzt folgende Änderung vorgenommen:
von: RewriteRule ^([\/\sa-zA-Z0-9._-]+)$ short.php?_page=$1 [QSA]
zu:   RewriteRule ^([\/\sa-zA-Z0-9._-]+)$ /wbdemo/short.php?_page=$1 [QSA,L]

>>> was bewirkt eigentlich der Zusatz ",L" am Ende dieser Zeile? <<<

Danach habe ich das Droplet "ShortLinks" mal testweise deaktiviert. Dann erhalte ich jedoch wieder das zusätzliche "/pages"-Verzeichnis, was ich ja eben nicht will.
Nach erneutem aktivieren der "ShortLinks" habe ich jetzt wieder den Pfad z.B. "http://localhost:4001/wbdemo/tools/".

WBDEMO:
Ich würde das Verzeichnis "/wbdemo" aber gerne auch noch loswerden. Du hast ja geschrieben, dass ich den Inhalt der Webseite auch direkt unter "/root" einfügen kann (also quasi so, wie ich es ja online auch habe).

Im Moment gibt es jedoch im ROOT noch folgende Verzeichnisse und Dateien:
- docs
- temp
- wbdemo
- index.php

Die "index.php" hat folgenden Inhalt:
Code: [Select]
<?php
### English: Choose the directory which should used at serverstart.
### Deutsch: Wähle das Verzeichnis, welches bei Serverstart verwendet werden soll.

$start '/docs/index.php';   // 'docs'  ,  'wbdemo'  ,  'wbdemo/admin'
$sProtokol = ((!isset($_SERVER['HTTPS']) || $_SERVER['HTTPS'] == 'off' ) ? 'http' 'https') . '://';
$sHost $_SERVER['HTTP_HOST'];
$sPort in_array((int) $_SERVER['SERVER_PORT'], [80443]) ? '' ':'.$_SERVER['SERVER_PORT'];

### don't touch this
header("Location: $sProtokol$sHost$start");

Sollte ich diese 3 Verzeichnisse plus die "index.php" einfach löschen und vom Inhalt des Verzeichnisses "wbdemo" überschreiben lassen?

CONFIG.PHP:
Ich nehme an, dass ich dort lediglich die folgende Zeile anpassen müßte:
Code: [Select]
define('WB_URL', 'http://localhost:4001/wbdemo');

Hier dann einfach das "/wbdemo" aus dieser Zeile löschen dürfte ausreichen... und dann am Ende KEINEN Slash einfügen... richtig?  :roll:

Oder muss ich zusätzlich auch noch die folgende Zeile irgendwie ändern, da ja dort auch der Begriff "wbdemo" auftaucht:
Code: [Select]
define('DB_NAME',  'wbdemo');

Die ".htaccess" würde ich dann einfach wieder so abspeichern, wie vorher (also ohne "/wbdemo").

Danke und Gruß,
imebro
« Last Edit: October 17, 2018, 10:55:46 AM by imebro »

Offline dbs

  • Betatester
  • **
  • Posts: 7549
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #21 on: October 17, 2018, 11:36:23 AM »
Quote
>>> was bewirkt eigentlich der Zusatz ",L" am Ende dieser Zeile? <<<
Einfach mal googeln, htaccess ist keine WB spezifische Sache.

Droplet Shorturl ist allein für die Links zuständig. Damit ein Klick also nicht zu /pages/xx führt.

Vielleicht schrieb ich etwas missverständlich zu WB Root, aber es sollte heißen, dass du alles rauschmeissen kannst was im Root ist.
-----
edit:
 Natürlich nicht den Inhalt von /wbdemo löschen, den willst du ja eins höher schieben. Den Hilfeordner kannst du auch behalten um nochmal reinzuschauen.
-----
Auf deinem Server lässt du da ja auch nichts sinnloses oder störendes drin rumliegen.
Die Dateien sind nur zur Darstellung der Demoversion gedacht, also weg damit.

In der config.php nur die richtige URL eintragen/ändern.
Datenbanknamen werden nur bei Serverumzug angepasst, weil die dort angelegte DB meistens anders heißt.
« Last Edit: October 17, 2018, 12:00:50 PM by dbs »

Offline imebro

  • Posts: 745
Re: Neues WB-Portable für 2.12 und freies Template mit Responsive Design?
« Reply #22 on: October 17, 2018, 12:24:24 PM »
Hi und danke nochmal...

Habe jetzt den Inhalt von "wbdemo" eins höher verschoben, also direkt nach "/root".
Dann die "config.php" abgeändert sowie die ".htaccess".
Danach den "usbwebserver" neu gestartet und jetzt funktioniert es.

Habe jetzt durchweg solche Verzeichnisse (lokal):
http://localhost:4001/tools/

Und wieder was gelernt  :lol:

Danke und Gruß,
imebro