Author Topic: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE  (Read 711 times)

Offline kct-networx

  • Posts: 20
Hey guys,

i recently upgraded from WB2.8.3+SP6 to 2.10 and everything went fine.
Many thanks to the team for that great job!

After that I've tried to upgrade to 2.11, but the upgrade script failed for the following reason at Step 10 (Checking all addons with a newer version (upgrade)):
Use of undefined constant GLOB_BRACE (line 55 in /framework/functions.php)

My Hoster: Strato
used PHP Version: 7.1.13
used SQL Version: 5.6.37

Does anybody know how to fix this?

Thanks in Advance!

Best regards
Markus

PS: I managed to complete the script, by removing GLOB_BRACE in line 55. But I'm not sure what else will be broken by using this "dirty fix".

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4200
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #1 on: March 07, 2018, 12:50:20 AM »
Hi,

Note: The GLOB_BRACE flag is not available on some non GNU systems, like Solaris. Most of the Server by Strato are Solaris,

We are working for another sulotion without GLOB_BRACE.

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline kct-networx

  • Posts: 20
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #2 on: March 07, 2018, 01:05:55 AM »
Hi Dietmar,

thank you for your fast response!
Exactly, it seems to be a Solaris OS.

Would you recommend to stay at 2.10 until a fix is available?
Or is it safe to remove the GLOB_BRACE variable from /framework/function.php line 55?

Thank you!

Best regards
Markus

Offline jacobi22

  • Posts: 5414
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #3 on: March 07, 2018, 01:36:56 AM »
the fix is ready for intern test's - i've the same problem like you on strato server and it works

if interest for a test, send a PM - i hope, we can publish this fix tomorrow
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline kct-networx

  • Posts: 20
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #4 on: March 08, 2018, 09:56:05 PM »
I'd like to say Thank you to both of you.
The fix I've tested works like a Charme for me.
It seems to be ready to move into the upcoming Release/Bugfix-release.

Great job!

Best regards
Markus


Offline evaki

  • Posts: 2353
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #5 on: March 09, 2018, 12:54:26 PM »
Ist in rev79 drin?
MfG. Evaki
Einmal Pizza Quattro Stagioni bitte, aber ohne Herbst.

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4200
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #6 on: March 09, 2018, 03:30:40 PM »
Ist in rev79 drin?
MfG. Evaki

Yes announcwment in work

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline evaki

  • Posts: 2353
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #7 on: March 09, 2018, 03:41:38 PM »
>>Yes announcwment in work  8-)  (Y)

(Kommt gelegen, da bei uns noch jemand ein "altes" Solaris -mit ZFS un so- betreibt.)

MfG. Evaki
Einmal Pizza Quattro Stagioni bitte, aber ohne Herbst.

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4200
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: update-script 2.10 -> 2.11: Use of undefined constant GLOB_BRACE
« Reply #8 on: March 09, 2018, 03:50:24 PM »
Quote
WebsiteBaker 2.11.0 incl. Fixes released
2018-03-03 : read more about …
Have Fun

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

 

postern-length