Author Topic: CKEditor Not showing in WYSIWYG module for pages/news posts  (Read 438 times)

Offline kibmcz

  • Posts: 221
  • Gender: Male
    • KComputer  Zone
CKEditor Not showing in WYSIWYG module for pages/news posts
« on: March 14, 2017, 12:42:31 PM »
On my debian 8 (just updated the other day) testing server/nas I have been testing clean installs and upgrades to the new 2.10.0. I first found that when i upgraded a 2.8.3+SP7 test install that when i went to edit pages/news posts CKEditor was no longer being presented in the WYSIWYG module. Yet oddly  CKEditor shows up when toggled for the header/footer edit in settings. Same behavior happens on clean installs so that should rule out upgrade issues?

Other than test on another server config i'm not sure what to try next?

Server Details (From admin)
-----------------------------
Webserver Software: Linux Zoidberg 3.16.0-4-amd64 #1 SMP Debian 3.16.39-1+deb8u2 (2017-03-07) x86_64
PHP-Erweiterung: mysqli  Dokumentation curl  Dokumentation mbstring  Dokumentation
PHP-Version: 5.6.30-0+deb8u1
WebsiteBaker-Version: 2.10.0
« Last Edit: March 14, 2017, 12:52:26 PM by kibmcz »

Offline jacobi22

  • Global Moderator
  • *****
  • Posts: 4249
  • Gender: Male
    • Jacobi22
Re: CKEditor Not showing in WYSIWYG module for pages
« Reply #1 on: March 14, 2017, 12:55:13 PM »
please check at first the used frontend template. do you have there or in a subfolder called "editor" files called editor.css and wb_ckconfig.js?
if YES, please rename it for a test

then go to WB-Setting -> advanced Setting and check the WYSIWYG EDITOR - select field, choose here CKeditor

the editor in WB-Settings has a own setting in the DEFAULTTHEME-Folder and run's stand-alone - has nothing to do with the editor in the modules like wysiwyg or news
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline kibmcz

  • Posts: 221
  • Gender: Male
    • KComputer  Zone
Re: CKEditor Not showing in WYSIWYG module for pages/news posts
« Reply #2 on: March 14, 2017, 01:21:34 PM »
Well on the default frontend template (DefaultTemplate) there was editor.css  (just that no editor folder) but when renamed made no difference. Also tried my own custom one same result.

This is a puzzling thing to happen as i've been using it for since the early days and this is delaying the upgrade of quite a few sites.

Offline jacobi22

  • Global Moderator
  • *****
  • Posts: 4249
  • Gender: Male
    • Jacobi22
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline sky writer

  • Posts: 829
Re: CKEditor Not showing in WYSIWYG module for pages/news posts
« Reply #4 on: March 14, 2017, 04:30:14 PM »
Check filename in modules/ckeditor/ckeditor/CKEditor.php
It must have the correct case (capital CKE)- CKEditor.php

Offline jacobi22

  • Global Moderator
  • *****
  • Posts: 4249
  • Gender: Male
    • Jacobi22
Re: CKEditor Not showing in WYSIWYG module for pages/news posts
« Reply #5 on: March 14, 2017, 05:14:35 PM »
Check filename in modules/ckeditor/ckeditor/CKEditor.php
It must have the correct case (capital CKE)- CKEditor.php

 (Y)

but i'm sure, if this is the problem, the editor will also not run in WB-Settings
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline sky writer

  • Posts: 829
Re: CKEditor Not showing in WYSIWYG module for pages/news posts
« Reply #6 on: March 14, 2017, 07:21:34 PM »
Check filename in modules/ckeditor/ckeditor/CKEditor.php
It must have the correct case (capital CKE)- CKEditor.php

 (Y)

but i'm sure, if this is the problem, the editor will also not run in WB-Settings

That's what I thought too... but when I tested, the CKEditor did still show in WB-Settings.

Offline jacobi22

  • Global Moderator
  • *****
  • Posts: 4249
  • Gender: Male
    • Jacobi22
Re: CKEditor Not showing in WYSIWYG module for pages/news posts
« Reply #7 on: March 15, 2017, 12:24:01 AM »
only a info: a linux-system is case-sensitive, in (default) windows it doesnt matter - but i must say, i've never test it on my live-server  :oops:
Du warst hier in meiner Seele und bist jetzt meilenweit entfernt
Wenn ich in Liedern von dir erzähle, war das jede Träne wert!
Alex Diehl- In meiner Seele

Offline colinS

  • Posts: 1
Re: CKEditor Not showing in WYSIWYG module for pages/news posts
« Reply #8 on: May 01, 2017, 11:49:38 PM »
I just installed 2.10 and had the same problem.  No WYSIWYG editor in a WYSIWYG section.
I found the cause was a coding issue in /modules/ckeditor/include.php where line 58 had:

$ModPath = str_replace($url['path'],'',$modRelPath).'/';

This removes all slashes from the path, wherever they might be, then tacks one on the end.
The problem was that if $modRelPath had slashes within it, they were also removed, breaking the path.
So I commented out that line and put in:

    $ModPath = $modRelPath.'/';

Even if it added an unnecessary slash at the end (because $modRelPath already had one possibly) *nix doesn't care about repeating slashes, just treat them as a single slash.

Now the editor shows just fine.  :-D

 

postern-length