Author Topic: PayPal: Things don't appear to be working at the moment. Please try again later.  (Read 2784 times)

Offline seanie_morris

  • Posts: 283
Hi,

I get the following error message when testing my bakery shop for the past 2 days: Things don't appear to be working at the moment. Please try again later. It is only in the past 2 days that I have tried it as part of my testing. Has anyone else seen this in their Bakery shop and might know what causes it? My PayPal account is only waiting on a verification of the email address, but it should work otherwise.


Thanks,

Seanie.


Offline freeSbee

  • Moderator
  • **
  • Posts: 1107
    • BAKERY - Website Baker shop module
I guess it has to do with the non-verified email address.

If you want to get more information about the failure enable the IPN debug mode:
/modules/bakery/payment_methods/paypal/ipn.php
at line 33
Code: [Select]
$debug = true;       // Enable debug mode

It logs requests to PayPal into 'ipn.log' at the same directory. I hope this will help clarify the issue.

Offline seanie_morris

  • Posts: 283
Thanks for the suggestion freeSbee, but it didn't work, ipn.log remains empty. I have tried it a couple times, each time deleting the cache, history, etc. of my browser (FF) before testing it like a new customer. I still get the error from the redirect to PayPal. I will look into my PayPal dashboard a bit more to make sure of a few things. I know I have IPN already turned on, the PDT Token is correct and so on.

Seanie.

Offline freeSbee

  • Moderator
  • **
  • Posts: 1107
    • BAKERY - Website Baker shop module
Make sure that your log file is writable. If you are not sure about file permissions change mode to 777 and try again.
Disable the debug mode an delete the log file after testing.

Offline seanie_morris

  • Posts: 283
I was able to change it to 777, and I tried it twice more in the past 10 minutes, and the log file is still empty!

How do I disable the debug mode? I am not aware of that.

Seanie.

Offline seanie_morris

  • Posts: 283
Scrap that comment I made above, I obviously didn't read freeSbee's post properly (my fault).  :oops:

I did those instructions i.e.

1. modules/bakery/payment_methods/paypal/ipn.php -> changed line 33 to $debug    = true;       // Enable debug mode
2. Saved and re-uploaded ipn.php to its place.
3. Enabled CHMOD 777 on ipn.log in the same directory.
4. Deleted all cache, cookies, history, etc. in Firefox and closed it.
5. Re-opened Firefox (and on Chrome) and made a purchase in the online shop.
6. Still get the PayPal error message when redirected to PayPal for the payment.
7. Checked ipn.log and it is still an empty file.

The PayPal account has been verified with no restrictions in place now.

I'm stuck!

Seanie.


Offline freeSbee

  • Moderator
  • **
  • Posts: 1107
    • BAKERY - Website Baker shop module
Please check if you have set the PayPal payment settings properly at
WebsiteBaker backend > Select a "Module Bakery" page > "Payment Methods" > "Modify Payment Method" > select "PayPal"
At least your email address you use at PayPal must match.

http://www.bakery-shop.ch/#payment_methods
http://www.bakery-shop.ch/#paypal

Offline seanie_morris

  • Posts: 283
Yep, the emails match. Also made sure of spellings!

I even tried using another friend's PayPal account That has been used many times before, replacing the IPN page address, redirect address and PDT token, and still not getting anywhere. Does this mean something on the website's end, and not PayPal, is the problem?

Seanie.
« Last Edit: February 14, 2017, 08:03:50 PM by seanie_morris »

Offline seanie_morris

  • Posts: 283
I also tried renaming my existing /bakery directory, then uploaded a clean, unmodded /bakery directory and (after deleting cache, etc.) tried making a purchase, and still getting the error message. I am wondering if it might be on PayPal after all. More investigation needed (by me).

Seanie.

Offline seanie_morris

  • Posts: 283
PENDING: I have found out that the hosting package might need to be upgraded due to PayPal's change in TLS operation, so I am also checking this out, though I might not get back here for a day yet. I am going to contact the hosting vendor, who offers the upgrade (on to Next Generation (NG) Linux package) and see what happens there.

Seanie.

Offline seanie_morris

  • Posts: 283
UPDATE: I am still no further ahead. To be sure of a few things, here's what happened since my last post:

1. Contacted the hosting vendor to find out the hosting account is already on the NG Linux plan.
2. Made sure that the PayPal account is all up to date (no errors or red flags exist on the PayPal account anyway).
3. When making a transaction, using Chrome and FF, on an iMac and Windows laptop, I made sure all fields of the contact form were filled in.

Still getting the same 'error message', so I sent PayPal support an email outlining what is going on to see if there is a red flag on the PayPal account from their end. After this, I am confused!

There is this help page from the hosting vendor which outlines a few things, but the vendor tells me that the hosting is fine anyway:
https://help.blacknight.com/hc/en-us/articles/212520829-Connection-Issues-To-Payment-Providers-PayPal-Realex-And-Others

I am not altogether clued in on cURL stuff.

Currently I am not using an SSL cert, and the other website that is working with similar settings and same vendor does not have an SSL either, and still works fine.

Anyone have extra suggestions I can try?

Seanie.

Offline freeSbee

  • Moderator
  • **
  • Posts: 1107
    • BAKERY - Website Baker shop module
It is best to not set the CURLOPT_SSLVERSION and let it use the default since this will attempt to figure out the remote SSL protocol version.

Anyway, if you want to give it a try add the line
Code: [Select]
curl_setopt($ch, CURLOPT_SSLVERSION, 6);
to the files:
/bakery/payment_methods/paypal/ipn.php add it after line 105
/bakery/payment_methods/paypal/check_payment.php add it after line 75


Offline seanie_morris

  • Posts: 283
It is best to not set the CURLOPT_SSLVERSION and let it use the default since this will attempt to figure out the remote SSL protocol version.

Anyway, if you want to give it a try add the line
Code: [Select]
curl_setopt($ch, CURLOPT_SSLVERSION, 6);
to the files:
/bakery/payment_methods/paypal/ipn.php add it after line 105
/bakery/payment_methods/paypal/check_payment.php add it after line 75

Thanks for the added suggestion, but alas it did not work. Still getting the same error... This is most confusing and frustrating for me, and I am pretty sure it is not a WB problem, but I just can't figure it out yet.

Seanie.

Offline freeSbee

  • Moderator
  • **
  • Posts: 1107
    • BAKERY - Website Baker shop module
I suppose the SSL certificate is not valid for your domain name. The SSL server test reports another domain name extracted from the certificate (parallels.com). Please try yourself and investigate with your ISP:
https://www.ssllabs.com/ssltest/index.html

Offline seanie_morris

  • Posts: 283
SOLVED: Now, it took a few days to resolve this, but the problem was, as I suspected, at PayPal's end. I phoned their support network from Ireland and found that the account was restricted, despite not showing up in the Resolution Centre of the PayPal CP. The problem was FATCA - Foreign Account Tax Compliance Act. I won't go into too much info of it on this post, but you can read more about it here: https://en.wikipedia.org/wiki/Foreign_Account_Tax_Compliance_Act

Apparently, even though it is to do with US financial law, it looks like it extends to the EU because PayPal is a US company. I never heard of it before, and this is the first time that a commercial (business) PayPal account that I have worked on had to make itself FATCA compliant. That's all I had to do. The PayPal rep on the phoned followed up with an email with a link to the newly-discovered FATCA section of my CP, answered 3 questions, and about 32 hours later (yes, THAT long) the restriction on the PayPal account was lifted (confirmed via email, and transactions worked immediately).

So, the problem I had with PayPal is now solved!

Seanie.

 

postern-length