Author Topic: Error installing WB 2.8.4  (Read 7402 times)

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Error installing WB 2.8.4
« on: January 07, 2014, 03:09:35 PM »
I tried to install WB 2.8.4, but got an error about a missing file "wb/framework/class.wbmailer.php":

Code: [Select]
Warning: include(/var/www/vhosts/[i]MYDOMAIN[/i]/httpdocs/wb/framework/class.wbmailer.php): failed to open stream: No such file or directory in /var/www/vhosts/argosmedia.eu/httpdocs/wb/framework/class.wb.php on line 29

Warning: include(): Failed opening '/var/www/vhosts/[i]MYDOMAIN[/i]/httpdocs/wb/framework/class.wbmailer.php' for inclusion (include_path='.:/usr/share/pear:/usr/share/php') in /var/www/vhosts/argosmedia.eu/httpdocs/wb/framework/class.wb.php on line 29

When I looked for it, I noticed that the file has capitals and is actually called class.WbMailer.php. I copied the file to another one without capitals, refreshed, and then the error was gone.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #1 on: January 07, 2014, 03:35:58 PM »
I think you used one of the buggy 2.8.4 releases.
Please use the current SVN or that one: http://testme.zweiwelt.com/media/WebsiteBaker_2.8.4_Rev2078.zip

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Error installing WB 2.8.4
« Reply #2 on: January 07, 2014, 03:50:01 PM »
I used 2071, which I downloaden from SVN some days ago. So this error has already been solved? Good. I'll update to 2078
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #3 on: January 07, 2014, 04:18:58 PM »
I used 2071, which I downloaden from SVN some days ago.
There the error existed and it was mainly the bug why 2.8.4 was removed.
So this error has already been solved?
Yes.  :wink: I hope so. Please test it intensive.

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Error installing WB 2.8.4
« Reply #4 on: January 07, 2014, 04:36:56 PM »
FCKEditor is not working. I just have a text editor instead of WYSIWYG.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #5 on: January 07, 2014, 04:39:30 PM »
FCKEditor is not working. I just have a text editor instead of WYSIWYG.
It won't work and it's hard to get it working on IE11. I also would like to see it dead. But I can't decide it.  :-)

If the problem is with IE: You can try to activate the Compatibility Mode for that site. But in IE11 it's not always working, so... Use a working editor instead, I'm afraid.

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Error installing WB 2.8.4
« Reply #6 on: January 07, 2014, 04:45:32 PM »
Yes, I use IE11, which is the leading browser for clients at the moment. FCKEditor is the default editor for WB. It's unacceptable for a CMS having no working WYSIWYG editor in the most used browser. This is a step back, not a step forward. So I hope the devs come up with a better situation than this. WB has already VERY strong competition from Wordpress. A new WB version should really impress and be better than the previous version. Having no working editor is the fastest way to WB death.

I know, it's a work in progress, but in my opinion a new official WB version cannot lack a decent editor. Not in any modern browser.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

Offline cwsoft

  • Posts: 605
Re: Error installing WB 2.8.4
« Reply #7 on: January 07, 2014, 06:29:19 PM »
Hi,

A new WB version should really impress and be better than the previous version. Having no working editor is the fastest way to WB death. I know, it's a work in progress, but in my opinion a new official WB version cannot lack a decent editor. Not in any modern browser.
+1 for replacing the outdated FCKEditor in WB 2.8.4 with the latest CKEditor module from Marmot, which works in older and latest browser version. The CKEditor module from Marmot is well enough tested by the Community to justify this step. This step is long overdue and I can't think off any reasonable excuse for not doing it - can you??

Cheers
« Last Edit: January 07, 2014, 06:35:38 PM by cwsoft »

jacobi22

  • Guest
Re: Error installing WB 2.8.4
« Reply #8 on: January 07, 2014, 08:43:44 PM »
i think, its not the best way, if you use a module in the standard package when nobody from the DEV-Team work on it.

i understand, that wb in the vers 2.8.4 use a "new coding standard" or a "different kind of code writing", also new funcions etc
on the other side, marmot make's a top job with the ckeditor, he is also a very good supporter for (nearly) everything in the forum, but it looks not possible, that somebody take's this two parts and put it together  :roll:

i work with marmot's CKE on the most of my WB's without problems, i use also a recoded WB-test-version of this CKE (maybe "recoded" is to hard to say), also without problems. i understand, that the DEV-Team say's, we have to change something in the code before we use it as a standard wb-module.
as example: wb2.8.4 use a new class to build (wb-)links to every modules sub-page (like news-pages, a special topic, a bakery item, a booking- or event-item etc) i used it also on a private module like (a small) members. you need only a file wblink.php in your module with a table- and a field name (and a little more), thats all. in my CKE-Test-Editor i can choice every bakery item, topics item etc in the wblink dialog
we build the same for the "marmot edition" (yes, me too), but its need a programmed database query and you need a query for every module, in the actual version the CKEditor has 3 different query's for news, topics and bakery
everybody knows, its not a good solution, if you make in one module a call to the next (additional) module
thats only one example
from my point of view its looks very easy: everybody works together and everything its fine   - i have a dream... :wink:
maybe some little mistakes, some wrong words "in the last year" are a big problem today, but if nobody talk with the other part, nobody can fix the problems
I'm not a coder, i can read the code and sometime i understand. if not, i try different ways. it works for me, but its not enough for a complexe module like the CKE

P.S.:....sometimes i remember me, that nearly everybody says, the Internet Explorer is not a browser and today i dont understand, why the IE 11 is the "only one"
no question - the FCK is not the best, but i see no other solution in the moment

Offline cwsoft

  • Posts: 605
Re: Error installing WB 2.8.4
« Reply #9 on: January 07, 2014, 08:48:09 PM »
Hi,

i think, its not the best way, if you use a module in the standard package when nobody from the DEV-Team work on it.
Don't think the DEV team is working on FCKEditor either - but this was no reason to get rid of it. The consequence of the above said would be to ship WB without any Editor, which means good bye WB in my eyes :-)

Cheers

P.S.: The CKEditor on the WB-Addons repository (v4.3.1) throws some notice warnings, while the latest version from Marmot I linked two posts below (v4.3.1.1) doesn't throw notices - at least in WB 2.8.4 and PHP 5.4.19.

P.P.S: Seems that WB 2.8.4 REV 2082 can't upload images etc. via the WB media center. Can this be confirmed by somebody? Tested on Windows testserver with PHP 5.4.19 and Firefox 26.0
« Last Edit: January 07, 2014, 11:07:23 PM by cwsoft »

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #10 on: January 07, 2014, 09:15:14 PM »
no question - the FCK is not the best, but i see no other solution in the moment
No, it isn't. FCKEditor is in my eyes no solution at all, not the last 3 years - it was good at the WB 2.6/2.7 time, but that is history.
But I have a different opinion regarding WYSIWYG editors anyway - so don't count on it.  :-)
« Last Edit: January 07, 2014, 09:18:30 PM by easyuser »

Offline Tez Oner

  • Posts: 257
  • "...it's possible..."
    • VA-MDS / MMO | communications
Re: Error installing WB 2.8.4
« Reply #11 on: January 07, 2014, 09:22:43 PM »
Hey Argos,

I know, it's a work in progress, but in my opinion a new official WB version cannot lack a decent editor. Not in any modern browser.

+1 - Let's not even speak about OS X and Safari ;)

Cheerz,

Tez Oner
Tez | VA-MDS / MMO | communications
--------------------------------------------
info@va-mds.com / http://va-mds.com

Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Error installing WB 2.8.4
« Reply #12 on: January 07, 2014, 09:26:27 PM »
Quote
P.P.S: Seems that WB 2.8.4 REV 2082 can't upload images etc. via the WB media center. Can this be confirmed by somebody? Tested on Windows testserver with PHP 5.4.19 and Firefox 26.0
PHP5.3, FF26, Update 2082 - no problem with upload

So far i know the FCK want work in the IE9 compatibilitymode.
« Last Edit: January 07, 2014, 09:28:24 PM by dbs »

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #13 on: January 07, 2014, 09:29:42 PM »
P.P.S: Seems that WB 2.8.4 REV 2082 can't upload images etc. via the WB media center. Can this be confirmed by somebody? Tested on Windows testserver with PHP 5.4.19 and Firefox 26.0
Also have no problems with upload... Neither Windows nor Ubuntu, IE11, Chrome 31, PHP 5.4/5.5...

So far i know the FCK want work in the IE9 compatibilitymode.
That can't be activated easy / nor at all on new Windows 8.1 installations! You have to change your OS to use WebsiteBaker as a client (keyword: change your GPOs - any customer with technical background... *keep cool*)!
« Last Edit: January 07, 2014, 09:33:39 PM by easyuser »

Offline cwsoft

  • Posts: 605
Re: Error installing WB 2.8.4
« Reply #14 on: January 07, 2014, 09:31:23 PM »
@dbs, easyuser: Thanks for testing and reporting back. Will try again on a clean install with default admin theme.

Cheers

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #15 on: January 07, 2014, 09:32:35 PM »
@dbs, easyuser: Thanks for testing and reporting back. Will try again on a clean install with default admin theme.

Cheers

BTW @ dbs: Is the new argos-theme available? Perhaps that's the problem...

Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Error installing WB 2.8.4
« Reply #16 on: January 07, 2014, 09:40:05 PM »
I thought its better to ask argos before i start to change his theme.
He will may change his theme self.

Offline easyuser

  • Posts: 832
Re: Error installing WB 2.8.4
« Reply #17 on: January 07, 2014, 09:52:29 PM »
I thought its better to ask argos before i start to change his theme.
He will may change his theme self.
Well, at least he should know there is a working argos-theme for 2.8.4.  :-) But of course he should be asked before releasing.

Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Error installing WB 2.8.4
« Reply #18 on: January 07, 2014, 09:58:28 PM »
Yes he know it.
That's the reason for trying to install 2.8.4 i think.

jacobi22

  • Guest
Re: Error installing WB 2.8.4
« Reply #19 on: January 07, 2014, 10:34:20 PM »
no problems for me with media uploads in wb media center with wb_theme and with original argos_theme 1.7 on Linux / PHP 5.3.28 / Firefox 26, Chrome 31 and IE10

Offline cwsoft

  • Posts: 605
Re: Error installing WB 2.8.4
« Reply #20 on: January 07, 2014, 11:03:08 PM »
Hi,

no problems for me with media uploads in wb media center with wb_theme and with original argos_theme 1.7 on Linux / PHP 5.3.28 / Firefox 26, Chrome 31 and IE10
Uups, my fault. Max file upload size was limited to 2MB for testing purposes of another project via php.ini.

Result was a failed upload, which made WB respond with a "file with same name already exists" message, which finally led me to the wrong conclusion :wink:

Cheers
« Last Edit: January 07, 2014, 11:06:31 PM by cwsoft »

Offline Argos

  • Posts: 2542
  • Gender: Male
    • Argos Media
Re: Error installing WB 2.8.4
« Reply #21 on: January 07, 2014, 11:50:27 PM »
Yes he know it.
That's the reason for trying to install 2.8.4 i think.

Exactly!  :-D
Tonight I started working on a new Argos theme for 2.8.4, using a completely new, default WB install, and latest CKEditor.
Jurgen Nijhuis
Argos Media
Heiloo, The Netherlands
----------------------------------------------------------------
Please don't request personal support, use the forums!

 

postern-length