Author Topic: 2.8.4 (R2072) Fehlermeldung bei Installation  (Read 5773 times)

Offline nordsee

  • Posts: 3
2.8.4 (R2072) Fehlermeldung bei Installation
« on: January 03, 2014, 12:09:12 PM »
Hi,
bekomme folgende Fehlermeldungen bei einer frischen Installation:
-----------------------------cut-
Warning: include(/xxx/wb/framework/class.wbmailer.php): failed to open stream: No such file or directory in /xxx/wb/framework/class.wb.php on line 29

Warning: include(): Failed opening '/xxx/wb/framework/class.wbmailer.php' for inclusion (include_path='.:/usr/local/lib/php') in /xxx/wb/framework/class.wb.php on line 29

Warning: Cannot modify header information - headers already sent by (output started at /xxx/wb/framework/class.wb.php:29) in /xxx/wb/framework/class.admin.php on line 71
----------------------------cut-
Mir ist aufgefallen dass die Schreibweise der Datei "class.wbmailer.php" im Directory "class.WbMailer.php" ist
(Meinen Domainnamen habe ich durch "xxx" ersetzt).
Gruß
Thomas
« Last Edit: January 03, 2014, 12:11:33 PM by nordsee »

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #1 on: January 03, 2014, 12:46:07 PM »
dann ersetze doch mal testweise den Namen der Datei in der framework/class.wb.php // Zeile29
Original
Code: [Select]
if(!class_exists('wbmailer', false)){ include(WB_PATH.'/framework/class.wbmailer.php'); }
neu
Code: [Select]
if(!class_exists('wbmailer', false)){ include(WB_PATH.'/framework/class.WbMailer.php'); }
ich bin leider nicht so schnell, brauche, um alle Dateien nach online zu übertragen, ein paar Stunden
Fakt ist, die besagte Datei hieß bis vor 3 Tagen noch class.wbmailer.php, danach wurde der phpMailer noch mal aktualisiert

Bitte um Rückmeldung



« Last Edit: January 03, 2014, 12:48:50 PM by jacobi22 »

Offline easyuser

  • Posts: 832
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #2 on: January 03, 2014, 12:56:43 PM »
@nordsee:
Es gab einen Bug im Release der 2.8.4, der inzwischen gefixt wurde.
Bitte lade die 2.8.4 erneut  herunter und installiere dann nochmal.
« Last Edit: December 09, 2015, 09:45:02 PM by Luisehahne »

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4320
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #3 on: January 03, 2014, 12:57:35 PM »
Hallo,

Du gehörst wohl wahrscheinlich unter den ersten 21 Downloader.

Da war ein Fehlerhaftes Downloadpaket, welches aber inzwischen bereinigt wurde. Bitte nochmal downloaden, dann funktioniert es.

Dietmar

« Last Edit: January 03, 2014, 01:05:56 PM by Luisehahne »
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline nordsee

  • Posts: 3
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #4 on: January 03, 2014, 01:44:18 PM »
Hallo,
habe jetzt das Paket nocheinmal geladen und neu installiert.
Es kommt jedoch die gleiche Fehlermeldung. Wenn ich die Datei
"class.WbMailer.php" in "class.wbmailer.php" umbenenne läuft die Installation.

@jakobi22: Es funktioniert auch wenn ich Zeile 29 in class.wb.php anpasse.

Kann ich das jetzt so lassen, oder muss ich in Zukunft mit Problemen rechnen ?
Gruß
Thomas
« Last Edit: January 03, 2014, 02:12:04 PM by nordsee »

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #5 on: January 03, 2014, 03:29:46 PM »
Hallo,
habe jetzt das Paket nocheinmal geladen und neu installiert.
Es kommt jedoch die gleiche Fehlermeldung. Wenn ich die Datei
"class.WbMailer.php" in "class.wbmailer.php" umbenenne läuft die Installation.

@jakobi22: Es funktioniert auch wenn ich Zeile 29 in class.wb.php anpasse.


Gruß
Thomas

mit mir spricht keiner mehr, vielleicht hab ich meine Klappe zu weit aufgerissen oder wen auf den Schlips getreten.  :evil:
Es heißt wohl, das Problem wäre gefixt, aber auch im Fix werden die Dateien immernoch "falsch" benannt und offensichtlich war dein Problem ja noch das Gleiche nach dem Fix.
Ich hab das zumindest mal so gelernt, das es einem Windows-System z.b. egal ist, ob ich Groß- und Kleinschreibung von includierten Dateinamen nicht so genau nehme, ein Unix-Server reagiert aber unter Umständen etwas allergisch darauf, nennt sich case sensitive

Quote
Kann ich das jetzt so lassen, oder muss ich in Zukunft mit Problemen rechnen ?
Sollte das im Paket nicht geändert werden, wäre deine Änderung beim nächstem Upgrade wieder dahin, wird überschrieben.
Ich persönlich würde keine Datei umbenennen, weil das wieder zur Folge hätte, das diese Datei bei einem Upgrade eben nicht überschrieben wird.
Mein Favorit wäre also die Änderung des "falschen" Dateinamens in der class.wb.php. Das ist auch nur an dieser Stelle notwendig, es gibt keinen weiteren Link zur dieser Datei im System.
Auch diese Änderung würde beim nächstem Upgrade überschrieben, aber dann u.U. auch in korrekter Weise, z.b. wenn dann z.b. die class.WbMailer.php wieder class.wbmailer.php heißen würde

P.S.: wenn es bei dir nun läuft, lass es so, der Zweck heiligt die Mittel  :wink:
« Last Edit: January 03, 2014, 03:34:11 PM by jacobi22 »

Offline nordsee

  • Posts: 3
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #6 on: January 03, 2014, 03:54:49 PM »
Hallo,
ich habe den Dateinamen in der Datei angepasst.
Das System läuft jetzt ohne Fehlermeldung.
Gruß
Thomas

Offline Jeanette

  • Posts: 165
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #7 on: January 03, 2014, 03:57:23 PM »
Hallo :)

Welcher Fehler da auch immer behoben wurde...
Auch ein neuer Download und erneute Installation führen nach wie vor zu den gleichen Fehlermeldung.

Erst das umschreiben in Zeile 29 funktioniert.

Von "Letzte stabile Version" kann also noch nicht wirklich die Rede sein...

:(

Liebe Grüße von Jeanette
It's better to burn out than to fade away ...

Offline DarkViper

  • Forum administrator
  • *****
  • Posts: 2993
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #8 on: January 03, 2014, 04:19:33 PM »
erst mal 'guten Morgen' ;)

Ich hab mir jetzt die letzte Stunde mal die wichtigsten Fehlermeldungen vorgenommen und die Ursache dafür gesucht. Und anscheinend auch gefunden.

a) der falsche Variablenname in der news/save_post.php:
Mea culpa. Ich hatte die fertige Datei zu Dietmar gegeben um zu testen, was auch bei ihm, wie auch bei mir einwandfrei klappte. Als sein OK zurück kam... routinemäßig auf [strg]+S gedrückt und die Datei endgültig zugemacht... War wohl ein Fehler, die [strg] nicht ganz gedrückt zu haben... so schlich sich an der Cursorposition das dämliche 's' ein. (hätte ruhig auch in einem Kommentar auftauchen können!)

b) der Fehler mit dem Mailer: Ich rätselte lange, bis ich feststellte, dass in der Hektik der Nacht anscheinend versehentlich nicht das neueste Paket mit dem bereits behobenen Fehler hochgespielt wurde. :(

Vorsichtshalber habe ich jetzt(leider erst jetzt, da ich erst spät wieder online kam) die offiziellen Downloadmöglichkeit en zur Sicherheit gesperrt, damit nicht noch mehr defekte Pakete in Umlauf kommen.
Sobald alles nochmal mindestens doppelt/dreifach geprüft wurde, gebe ich dann den DL so schnell als möglich/vertretbar wieder frei.
Was dann die Unterscheidbarkeit der Pakete betrifft, bin ich noch am Überlegen, welche Möglichkeit am sinnvollsten ist. Ein extra Fix-Paket gefällt mir persönlich am allerwenigsten.

Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are… but you can not leave them like that !" :-P
Das tägliche Stoßgebet: Oh Herr, wirf ihnen Hirn vom Himmel !

Offline easyuser

  • Posts: 832
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #9 on: January 03, 2014, 04:22:28 PM »
Was dann die Unterscheidbarkeit der Pakete betrifft, bin ich noch am Überlegen, welche Möglichkeit am sinnvollsten ist. Ein extra Fix-Paket gefällt mir persönlich am allerwenigsten.
Jetzt erstmal Ruhe bewahren, sorgfältig die paar Bugs fixen und dann testen lassen.
Die paar Downloads sollten einfach hingenommen werden, und ein neues Paket (mit einer dann anderen Revnummer) als 2.8.4 bereitgestellt werden. Fix-Paket macht wenig Sinn, sehe ich auch so.
Das hatten wir bei den letzten Releases auch schon, und nach 1-2 Tagen sind die zwischenzeitlichen Bugversionen auch nicht mehr aufgetaucht.

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #10 on: January 03, 2014, 04:39:16 PM »
Von "Letzte stabile Version" kann also noch nicht wirklich die Rede sein...

ach doch, wenn sie erstmal läuft, ist sie schon "stable" 

aber bitte jetzt nicht gleich aufgeben und die Version verfluchen. Ich kann mich garnicht mehr dran erinnern, wie oft ich beim Fahhrad fahren lernen hingefallen bin und da standen auch alle drum herum und riefen "du kannst das" (im Sinne von "last stable")
Ein bischen Geduld, dann wird das schon  :wink:

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #11 on: January 03, 2014, 04:42:00 PM »
Was dann die Unterscheidbarkeit der Pakete betrifft, bin ich noch am Überlegen, welche Möglichkeit am sinnvollsten ist. Ein extra Fix-Paket gefällt mir persönlich am allerwenigsten.
Jetzt erstmal Ruhe bewahren, sorgfältig die paar Bugs fixen und dann testen lassen.
Die paar Downloads sollten einfach hingenommen werden, und ein neues Paket (mit einer dann anderen Revnummer) als 2.8.4 bereitgestellt werden. Fix-Paket macht wenig Sinn, sehe ich auch so.

+1
vier der Downloads gehen auf mich, ist also nicht soooo viel im Umlauf  :-D

Offline badknight

  • WebsiteBaker Org e.V.
  • **
  • Posts: 819
  • Gender: Male
    • pinzweb
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #12 on: January 03, 2014, 04:43:27 PM »
Was dann die Unterscheidbarkeit der Pakete betrifft, bin ich noch am Überlegen, welche Möglichkeit am sinnvollsten ist. Ein extra Fix-Paket gefällt mir persönlich am allerwenigsten.
Jetzt erstmal Ruhe bewahren, sorgfältig die paar Bugs fixen und dann testen lassen.
Die paar Downloads sollten einfach hingenommen werden, und ein neues Paket (mit einer dann anderen Revnummer) als 2.8.4 bereitgestellt werden. Fix-Paket macht wenig Sinn, sehe ich auch so.

+1
vier der Downloads gehen auf mich, ist also nicht soooo viel im Umlauf  :-D
3 davon gehören zu mir... :P

--
@Jeanette

Ob du es glaubst oder nicht - aber das System ist stabil (wenn es mal läuft ;)) - Wir haben es bereits auf einigen - großen - Seiten im Einsatz und es gab noch keine Probleme!
Ich würde gern die Welt verändern, doch Gott gibt mir den Quellcode nicht...

Offline easyuser

  • Posts: 832
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #13 on: January 03, 2014, 04:44:53 PM »
Ein bischen Geduld, dann wird das schon  :wink:
Eben, die Elbphilharmonie wird auch fertig, wenn auch mit Problemen: http://www.der-postillon.com/2013/12/wegen-orkan-xaver-elbphilharmonie.html

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #14 on: January 03, 2014, 04:49:30 PM »
alsolut  OFFTOPIC  :wink:

Ein bischen Geduld, dann wird das schon  :wink:
Eben, die Elbphilharmonie wird auch fertig, wenn auch mit Problemen: http://www.der-postillon.com/2013/12/wegen-orkan-xaver-elbphilharmonie.html

wer sich auch mal mit Kleinem zufrieden gibt.......  -> Großartige Eröffnung unserer Miniatur Elbphilharmonie

Offline Jeanette

  • Posts: 165
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #15 on: January 03, 2014, 04:53:09 PM »
Hallo noch mal,

da ich hier auch gerade am Machen bin, ist es vielleicht von Interesse, dass
sich die "Abschnitte verwalten" nicht richtig verwalten lassen...

Trotz korrekter info.php kann man den Blöcken nicht zuweisen, ob Sie "main" oder "right" oder sonstwas sein sollen.

Wäre schön, wenn das wieder ginge.

DANKESCHÖN!!! :)
It's better to burn out than to fade away ...

Offline badknight

  • WebsiteBaker Org e.V.
  • **
  • Posts: 819
  • Gender: Male
    • pinzweb
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #16 on: January 03, 2014, 04:53:56 PM »
hast du auch in den Optionen die Blöcke aktiviert ;)?
Ich würde gern die Welt verändern, doch Gott gibt mir den Quellcode nicht...

Offline DarkViper

  • Forum administrator
  • *****
  • Posts: 2993
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #17 on: January 03, 2014, 04:54:26 PM »
So, ich hab jetzt mal einen Patch mit den 'echten' Dateien zusammengestellt (mit Hintergedanke an Uwe's schnelle Leitung;))
Für die , die das Paket - nur zum testen - komplett holen wollen, steht es temporär auf meinem lokalen Server zur Verfügung. (die offiziellen Quellen bleiben noch gesperrt, bis alles (fast alles) passt).

WebsiteBaker-2.8.4[2073] (zip)
WebsiteBaker-2.8.4[2073] (tar.gz)

Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are… but you can not leave them like that !" :-P
Das tägliche Stoßgebet: Oh Herr, wirf ihnen Hirn vom Himmel !

Offline Jeanette

  • Posts: 165
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #18 on: January 03, 2014, 04:57:47 PM »
hast du auch in den Optionen die Blöcke aktiviert ;)?

Huch...
Das ist neu - brauchte man vorher nicht extra aktivieren. War wohl sonst schon als Standardeinstellung auf AN

DANKE für den Hinweis :) :)
It's better to burn out than to fade away ...

Offline Jeanette

  • Posts: 165
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #19 on: January 03, 2014, 05:00:24 PM »
Weiß denn vielleicht auch jemand, wie man die Umlautfehler im neuen Backend wegbekommt?
Tauchen auf z.B. bei "Einstellungen ändern"

 :-D
It's better to burn out than to fade away ...

Offline DarkViper

  • Forum administrator
  • *****
  • Posts: 2993
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #20 on: January 03, 2014, 05:08:08 PM »
Weiß denn vielleicht auch jemand, wie man die Umlautfehler im neuen Backend wegbekommt?
Tauchen auf z.B. bei "Einstellungen ändern"
welches Backend-Theme?
und wie sieht der <head>-Bereich des benutzten Themes aus?
Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are… but you can not leave them like that !" :-P
Das tägliche Stoßgebet: Oh Herr, wirf ihnen Hirn vom Himmel !

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #21 on: January 03, 2014, 05:10:21 PM »
Quote
Weiß denn vielleicht auch jemand, wie man die Umlautfehler im neuen Backend wegbekommt?
Tauchen auf z.B. bei "Einstellungen ändern"

In dem man den Schrift- bzw. Zeichensatz auf Unicode (utf8) stellt (OPTIONEN -> erweiterte Optionen
Für eine Neuinstallation sollte das (meiner Meinung nach) Pflicht sein

Offline Jeanette

  • Posts: 165
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #22 on: January 03, 2014, 05:26:46 PM »
Ist in den Optionen richtig eingestellt: Unicode (UTF-8)

Backendtheme ist standardmäßig auf WB Theme

Kann es sein, dass es eine Zeichenbegrenzung für das Feld "Fußzeile" gibt?
Ich kriege dort nicht mehr unter als: "&copy; 2014 GUST Objekt- und Grundstst"

Wenn ich versuche mehr einzutragen, wird einfach gar nichts mehr angezeigt.
It's better to burn out than to fade away ...

Offline Jeanette

  • Posts: 165
  • Gender: Female
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #23 on: January 03, 2014, 05:28:39 PM »
und wie sieht der <head>-Bereich des benutzten Themes aus?

Was meinst Du damit?  :?
It's better to burn out than to fade away ...

jacobi22

  • Guest
Re: 2.8.4 (R2072) Fehlermeldung bei Installation
« Reply #24 on: January 03, 2014, 05:38:54 PM »
ich glaube page_footer() hat eine Begrenzung auf 50 Zeichen. Ich selber nutze ein modifiziertes simplepagehead-Modul, da tippe ich, was ich will

probiere mal, ohne Umlaute im Fußzeilen Feld


ist falsch, keine Begrenzung und kein Umlautproblem

Quote
und wie sieht der <head>-Bereich des benutzten Themes aus?

es geht in erster Linie um diesen Eintrag hier
<meta http-equiv="content-type" content="text/html; charset=utf-8" />


« Last Edit: January 03, 2014, 05:43:10 PM by jacobi22 »