Author Topic: Upgrade to latest jQuery before WB 2.8.4  (Read 30650 times)

Offline cwsoft

  • Posts: 605
Upgrade to latest jQuery before WB 2.8.4
« on: January 18, 2013, 11:03:03 AM »
Hi,

updated versions of jQuery and jQuery-UI were released yesterday. Maybe last chance for upgrading the WB 2.8 SVN files before releasing WB 2.8.4 :wink:

jQuery latest: 1.9.0 (WB-SVN 1.8.3)
jQuery-UI latest: 1.10.0 (WB-SVN 1.9.2)

Cheers

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8390
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #1 on: January 18, 2013, 12:26:37 PM »
Hello,

looking into the changelog of JQuery 1.9.0, I'm not shure if this is possible without changing additional some core files wich uses jQuery.

Matthias


Offline cwsoft

  • Posts: 605
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #2 on: January 18, 2013, 11:20:56 PM »
Hi,

Quote from: ruebenwurzel
I'm not shure if this is possible without changing additional some core files wich uses jQuery.
Easy to find out. Just replace the files in include folder and check the few core methods using jquery. Faster and more reliable than guessing :wink:

Cheers

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8390
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #3 on: January 21, 2013, 01:37:48 PM »
@cwsoft

Just tested it. Seems that the few core methods wich uses jquery works without problems.

But got some problems with modules and snippets wich uses the jquery from include folder. After adding "jquery-migrate-1.0.0.min.js" to includes/jquery folder and changing frontend and backend header to call this file too, all modules and snippets wich i use seems to work again.

But without changing core files (e.g. frontend.functions. php) a lot of users wich uses jquery will have problems.

Will send a package with all changed files to the devs. Hope they could have a look into it and maybe add the latest Versions of JQuery and JQueryUI to the next WB Release.

Regards
Matthias

Offline cwsoft

  • Posts: 605
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #4 on: January 21, 2013, 07:09:25 PM »
@ruebenwurzel

Thanks for taking action. Did a quick check yesterday evening with basic core, seems ok.
However as you already mentioned, most of the modules using jQuery (incl. my own ones) will not work out of the box when upgrading the files to latest jQuery version.

Guess it's better to stick with the actual version to keep backwards compatibility with existing modules for the 2.8.x series (or add the jquery-migrate script as you suggested and run further tests on existing modules before final 2.8.4 release).

Cheers
« Last Edit: January 21, 2013, 07:49:19 PM by cwsoft »

Offline badknight

  • WebsiteBaker Org e.V.
  • **
  • Posts: 819
  • Gender: Male
    • pinzweb
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #5 on: January 21, 2013, 08:29:16 PM »
JQuery UI
Quote
API Redesign: Dialog

The dialog widget has undergone an API redesign

Quote
API Redesign: Progressbar

The progressbar widget has undergone an API redesign,
Quote
Deprecated APIs

As mentioned above, dialog went through an API redesigns which resulted in some existing APIs being deprecated


Jquery
Quote
New .finish() method
.toggle(function, function, ... ) removed
jQuery.browser() removed
.live() removed
.die() removed
jQuery.sub() removed
.add()

and there is a Upgrade-Guide
----

there are many changes ..
Powermail 2.0 und jQuery 1.9.0 – nichts geht mehr! other Systems did try to test this version ;)
« Last Edit: January 21, 2013, 08:35:03 PM by badknight »
Ich würde gern die Welt verändern, doch Gott gibt mir den Quellcode nicht...

Offline BlackBird

  • Posts: 2573
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #6 on: January 22, 2013, 10:17:55 AM »
However as you already mentioned, most of the modules using jQuery (incl. my own ones) will not work out of the box when upgrading the files to latest jQuery version.

Guess it's better to stick with the actual version to keep backwards compatibility with existing modules for the 2.8.x series

It's simple enough: Keep old version in include for backward compatibility and use lib_jquery for the newest version. The only thing to keep in mind is that they must not be mixed.

Offline pattyland

  • Posts: 11
Re: Upgrade to latest jQuery before WB 2.8.4
« Reply #7 on: December 08, 2014, 12:37:00 AM »
Any updates on this? We should really stop using such an old version of jQuery, I can't use many plugins because they require jQuery > 1.9.X


 

postern-length