Author Topic: #GELÖST# Instllations Problem  (Read 3970 times)

Offline neuling

  • Posts: 85
  • Gender: Male
#GELÖST# Instllations Problem
« on: March 04, 2012, 07:32:31 PM »
Hallo,

ich hab auf meinem Server bereits 2 WB Installationen laufen. Eine war 2.6 -> hab ich diese Woche auf 2.8.3 upgegradet, war kein Problem. Die zweite war 2.8.1 -> hab ich auch auf 2.8.3 upgegradet, auch kein Problem.

Jetzt wolte ich eine dritte 2.8.3 installieren, da kann ich nicht mal den installer öffnen. Also versuchte ich 2.8.1 zu installieren, und das Installationsscript zeigt an, dass alles "im grünen Bereich" ist. Also installieren, da kommt folgende Fehlermeldung:

PHP Warning:  fopen(../config.php): failed to open stream: Permission denied in D:\XXXXXXXXX\install\save.php on line 316

meine Reaktion:  :?

kann man keine drei WB installationen laufen lassen? Das wäre ja der Witz des Tages!!!!
Wo liegt denn der Fehler, ein denkfehler bei mir?

Danke erst mal

Klaus
« Last Edit: March 05, 2012, 04:21:54 PM by neuling »

Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Instllations Problem
« Reply #1 on: March 04, 2012, 07:37:11 PM »
:) deine config.php heißt noch config.php.new?
benenne sie um und los gehts.

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #2 on: March 04, 2012, 07:41:26 PM »
ich hab sicherheits halber nachgesehen. sie heißt config.php
 :-(

Klaus

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #3 on: March 04, 2012, 08:05:50 PM »
ich hab etwas gestöbert, und auch die phpinfo() durchgesehen. Plötzlich ist allow_url_fopen   auf Off! Ich hab erst vor ein paar Tagen auf PHP5 umgestellt. Bei PHP4 hatte ich noch allow_url_fopen auf On.

Ich glaub das war's. Kann ich das für den aktuellen Ordner eventuell temporär wieder einschalten (.htaccess)?
Da hab ich keine Erfahrungen.

Danke

Klaus

Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Instllations Problem
« Reply #4 on: March 04, 2012, 08:20:24 PM »
wüßte nicht, dass wb "allow_url_fopen = on" braucht

was sagen denn die berechtigungen für besagte save.php? 644?

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #5 on: March 04, 2012, 09:00:02 PM »
sogar 777, wird ja nach erfolgreicher installation gelöscht, ...

Offline kweitzel

  • WebsiteBaker Org e.V.
  • **
  • Posts: 6983
  • Gender: Male
Re: Instllations Problem
« Reply #6 on: March 04, 2012, 09:04:36 PM »
sogar 777, wird ja nach erfolgreicher installation gelöscht, ...

Das kann je nach Server Konfiguration falsch sein ... probier mal 775 oder auch 755 ...

Gruß

Klaus

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #7 on: March 04, 2012, 09:51:17 PM »
auch kein anderes Ergebnis, ...
ich lass morgen mal gleich vom Server-Betreiber fopen auf on setzen.
Danke erst mal, ich sag dann, wie's gelaufen ist.

Klaus

Offline dbs

  • Betatester
  • **
  • Posts: 7977
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Instllations Problem
« Reply #8 on: March 04, 2012, 09:58:02 PM »
zur sicherheit auch mal diese beiden files laufen lassen:
http://www.websitebaker2.org/forum/index.php/topic,19267.0.html

Offline DarkViper

  • Forum administrator
  • *****
  • Posts: 3021
  • Gender: Female
Re: Instllations Problem
« Reply #9 on: March 04, 2012, 10:26:05 PM »
  • allow_url_fopen=on ist für WB absolut unnötig. Im Gegenteil, es kann unter Umständen das System angreifbar machen.
  • Für Dateien sind im gesamten WB Rechtemasken mit ungeraden Ziffern (1/3/5/7) ein absolutes NoGo und können auf verschiedenen Servern einen 500er Fehler auslösen!
  • Mögliche Rechtemasken für die /config.php sind: 640 / 644 / 660 / 664 / 666
  • Bei wenigen einzelnen Servern ist es jedoch konfigurationsbedin gt unmöglich, im Dokumentroot per Script schreibend auf Dateien zuzugreifen oder Unterverzeichnisse anzulegen. In diesem Fall (und nur in diesem) ist ein manueller Eingriff per FTP erforderlich.
Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are… but you can not leave them like that !" :-P
Das tägliche Stoßgebet: Oh Herr, wirf Hirn vom Himmel !

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #10 on: March 05, 2012, 09:32:12 AM »
Was ich nicht verstehe ist: warum schreibt er dann

PHP Warning:  fopen(../config.php): failed to open stream??

Klaus

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #11 on: March 05, 2012, 09:52:50 AM »
zur sicherheit auch mal diese beiden files laufen lassen:
http://www.websitebaker2.org/forum/index.php/topic,19267.0.html

Ergebnis check-wb.php:

Congratulations! Your server meets the requirements of WebsiteBaker CMS 2.8.x

    You have PHP 5.2.2 (or greater)
    Safe Mode is off
    You have MySQL 4.1.x (or greater)
    You have the gd extension

bei Fix-Permissions:

This script has no effect in PHP for Windows.

Note: Your PHP Server API is CGI-FCGI (excellent!)

ich hab einen Windowsserver. wird wohl nichts bringen

Danke trotzdem

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #12 on: March 05, 2012, 10:39:42 AM »
Ich hab jetzt folgende Parameter probiert:


Neu heruntergeladene WB Installationsdateie n,
WB 2.8.1
PHP4.4.0, allow_url_fopen:   On
Ergebnis:

Warning: fopen(../config.php): failed to open stream: Permission denied in D:\Web\HA\5\587_bvtye\l5uierwz\data\k_design\install\save.php on line 316

So,...

Das waren die Einstellungen der beiden letzten Installationen, die noch immer problemlos laufen - nur einen Ordner entfernt - so zu sagen, ...

Weitere Ideen? Sobald ich vom Server Betreiber Bescheid bekomme, dass allow_url_fopen: auf On gesetzt ist, versuch ich nocmal WB 2.8.3

Klaus

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8390
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Instllations Problem
« Reply #13 on: March 05, 2012, 10:50:59 AM »
Hallo,

Quote
ich hab einen Windowsserver

Apache oder IIS als Webserver?

Voraussetzung für WB ist ein Apache Webserver. IIS wird nicht unterstützt und wir können da auch keinen Support geben. Es gibt wohl welche, die WB auch auf einem IIS zum Laufen bekommen haben, aber keine Ahnung wie man den IIS dafür konfigurieren muss.

http://www.websitebaker2.org/de/download/neueste-version/systemvoraussetzungen.php

Matthias
« Last Edit: March 05, 2012, 10:56:54 AM by ruebenwurzel »

Offline DarkViper

  • Forum administrator
  • *****
  • Posts: 3021
  • Gender: Female
Re: Instllations Problem
« Reply #14 on: March 05, 2012, 11:31:14 AM »
PHP4.4.0, allow_url_fopen:   On
Die Mindestvoraussetzun g für WebsiteBaker ist derzeit PHP5.2.2. Das gilt auch für die WB2.8.1, da auch dort Sicherheitsfixes eingebaut wurden, die unter PHP4.4 eventuell Probleme machen.

Warning: fopen(../config.php): failed to open stream: Permission denied in D:\Web\HA\5\587_bvtye\l5uierwz\data\k_design\install\save.php on line 316
Mir fällt gerade auf, dass hier immer an den Rechten etc. für die /install/save.php herumgebastelt wird..
Dabei sagt die Fehlermeldung doch eindeutig, dass die "../config.php" nicht geöffnet werden kann. Und zwar durch das fopen-Statement in der /install/save.php Zeile 316.
Zusätzlich spielen unter Windows die Unix-Rechtemasken keinerlei Rolle. (ausser Du setzt die Datei '../config.php' unter Windows explizit auf 'ReadOnly'...  was ich jetzt mal nicht annehmen will.)

Der Fehler liegt eindeutig an Deiner config.php.
a.) Sie nicht da wo sie sein sollte
b.) Sie ist auf ReadOnly gesetzt
c.) Sie ist defekt
d.) Sie ist noch anderweitig (z.B. Notepad, FTP etc.) geöffnet und dadurch für Schreibzugriffe blockiert.

Weitere Ideen? Sobald ich vom Server Betreiber Bescheid bekomme, dass allow_url_fopen: auf On gesetzt ist, versuch ich nocmal WB 2.8.3
Nochmal: allow_url_fopen = on ist völlig unnötig und hat keinerlei Wirkung.
Das hat in diesem Zusammenhang etwa den selben Effekt, als ob Du in Deiner Wohnung die Badewanne schrubbst und Dich dann wunderst, dass die Windschutzscheibe Deines Autos davon nicht sauber wird...  ;-)
Der blaue Planet - er ist nicht unser Eigentum - wir haben ihn nur von unseren Nachkommen geliehen

"You have to take the men as they are… but you can not leave them like that !" :-P
Das tägliche Stoßgebet: Oh Herr, wirf Hirn vom Himmel !

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #15 on: March 05, 2012, 12:22:10 PM »
@ruebenwurzel:
laut phpinfo(), erste Zeile: Windows NT

ich hab trotzdem schon ZWEI laufende Installationen! Dass ich damit keinen Support bekomme, weiß ich. Ich hoffe nur, dass mir wer sagen kann, wo genau das Brett vor meinem Kopf festgenagelt ist - ich seh's vor lauter Brett nicht  :oops:

@DarkViper:
php4 hab ich nur probiert, weil die zwei anderen Installationen unter php4 installiert wurden. Ich hab genau die gleichen Voraussetzungen geschaffen, trotzdem ging's nicht.
Aktuell hab ich:

PHP5.2.9
SafeMode Off
PHP Session Support    Enabled

wb/config.php    Writeable
wb/pages/    Writeable
wb/media/    Writeable
wb/templates/    Writeable
wb/modules/    Writeable
wb/languages/    Writeable
wb/temp/    Writeable

bei der config.php hab ich nur ein eröffnendes <?php Tag. Kein schließendes ?>. Fehler?

Was mich zum Verzweifeln bringt ist, dass die anderen Installationen keinerlei Probleme bereiten, bzw noch nie gemacht haben!!!

Klaus

jacobi22

  • Guest
Re: Instllations Problem
« Reply #16 on: March 05, 2012, 12:45:59 PM »
Hast du mal die Benutzergruppen verglichen, z.b. die der config.php und die der install/save.php?

Hatte ich auch erst auf einem Kundenserver.

ich würde die Datei config.php auch mal löschen und neu übertragen - vorausgesetzt, du bist in der gleichen FTP-Group!

Code der leeren config.php ist korrekt (siehe auch im install-Paket config.php.new)




Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #17 on: March 05, 2012, 01:56:04 PM »
Benutzergruppen und Rechtemasken sind ident.

Quote
Zusätzlich spielen unter Windows die Unix-Rechtemasken keinerlei Rolle...

Weiters:

Quote
ich würde die Datei config.php auch mal löschen und neu übertragen -

Ich hab verschiedene WB Versionen mehrmals überspielt und versucht zu installieren. Bei WB 2.8.1 kommt wenigstens das Installations-Startscript.
Bei WB 2.8.3 kommt nur:
PHP Warning:  fopen(D:\XXX\XXX\XXX\kdesign/config.php): failed to open stream: Permission denied in D:\XXX\XXX\XXX\kdesign\install\index.php on line 211

Was nun?

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8390
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Instllations Problem
« Reply #18 on: March 05, 2012, 03:07:44 PM »
Hallo,

es liegt an den Berechtigungen, die du im IIS vergibst. Google mal nach "fopen" in Zusammenhang mit "IIS". Mein erster Treffer war:

http://www.phpfreaks.com/forums/index.php?topic=110885.0

So wie ich das verstehe, fehlen im Windows Exporer bei den Sicherheitseinstell ungen des Verzeichnisses, in dem sich deine Webseiten (oder halt die WB 2.8.3 Seite) befinden (befindet), die Zugriffsberechtigun gen (lesen und schreiben) für den IUSR_RECHNERNAME.

Matthias
« Last Edit: March 05, 2012, 03:59:45 PM by ruebenwurzel »

Offline neuling

  • Posts: 85
  • Gender: Male
Re: Instllations Problem
« Reply #19 on: March 05, 2012, 04:21:20 PM »
Tja, eigentlich ganz einfach, ... wenn man es weiß, wie's geht  :roll:

Ich hab in meiner Accoutverwaltung einen Punkt (der Link ist sogar ein Hauptlink) der heißt Rechteverwaltung. Hier für den Ordner, in den man WB installiert hat Schreibrechte setzen, und alles läuft wie geschmiert!

Es tut mir leid, wenn ich euch den Kopf zerbrechen hab lassen, für das, dass mein Gedächtnis ein Nudelsieb ist.

Danke trotz alledem,

Klaus