Author Topic: No images uploadable via news module in WB 2.7/2.8  (Read 2331 times)

Waldschwein

  • Guest
No images uploadable via news module in WB 2.7/2.8
« on: August 08, 2009, 06:55:30 PM »
Hello!

I know it's a really old bug, but I don't see why always drag along it to every new version...

---> --- Pages -> News Modul -> Add/Modify Group -> Picture: When uploading a picture (a real jpg), the message "you have to upload a jgp or png" comes. On some configuration also some not really nice bug messages like that one occur:
Quote
Warning: shell_exec() has been disabled for security reasons in /www/htdocs/w00751ba/framework/functions.php on line 491
Warning: shell_exec() has been disabled for security reasons in /www/htdocs/w00751ba/framework/functions.php on line 491
This message was on a 2.7 installation, but 2.8 RC2 has also this bug.

You can't return to admin after it, you are being redirected to your frontend start page.

So either disable uploading of the group pictures in the news module or fix the problem, but it would be not that nice have it in every new WB version.  8-)

Regards Michael

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8390
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: No images uploadable via news module in WB 2.7/2.8
« Reply #1 on: August 09, 2009, 10:58:13 AM »
Hallo,

Quote
shell_exec() has been disabled for security reasons

Has to do with your php.ini settings on your server. Did your server run in "Safe Mode"? If not did you have a special configured server?

No bug of WB as uploading pictures to groups works on all tested servers here.

Matthias

Waldschwein

  • Guest
Re: No images uploadable via news module in WB 2.7/2.8
« Reply #2 on: November 05, 2009, 10:19:27 PM »
Hello!

I know old topic, but there should be an error with uploading icons in news groups - News V 3.1 / WB 2.8.0 SVN 1171.

When I use (XAMPP, PHP 5.2.9, unchanged configs, Win 7 64bit) it on localhost with Internet Explorer 8, the WB error message "Please note that the file you upload must be of the following format: JPG (JPEG) or PNG b" is being displayed, after that as described before in August being redirected to startpage.
When I use Firefox 3.6 Beta 1 or Opera 10 it succeeds at it should be - with the very same picture!

Deleting the picture in IE8 and viewing is no problem.

Yours Michael

 

postern-length