Author Topic: WB 2.8 - a few questions  (Read 5679 times)

mickpage

  • Guest
WB 2.8 - a few questions
« on: March 02, 2009, 11:58:03 AM »
The WebsiteBaker start/homepage states that "WebsiteBaker 2.7 will be the last major update to the 2.x series with a minimum requirement for PHP 4.1.0". It has a "Go PHP5" logo next to this.
Now I see from the Project Roadmap page that WB 2.8 (due this month) "requires PHP 4.4.9 or higher". Do you not think the "Go PHP5" logo is a bit misleading here - I thought I was having to upgrade to PHP5 for the next release.

Also, the Roadmap page states that it "requires existing WB 2.7 to update to 2.8". I presume this is only applicable IF YOU ARE UPGRADING and not doing a fresh install! [CONFIRMED BELOW]
« Last Edit: March 02, 2009, 12:56:13 PM by mickpage »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8390
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: WB 2.8 - a few questions
« Reply #1 on: March 02, 2009, 12:34:32 PM »
Hello,

Quote
Do you not think the "Go PHP5" logo is a bit misleading here - I thought I was having to upgrade to PHP5 for the next release.

No, this is i think no missleading. The future is PHP5. Only due to the fact, that a few features wich was planned for WB 2.8, we moved now to 2.9 due to time-lack of the devs, WB 2.8 works further with PHP major than PHP 4.4.9. But you can be shure, the time will come, where WB only works with PHP5. Look at AMASP Project, there are right now a few features wich requires already now PHP5. Independent from the requirements of WB it is recommanded to update all servers to PHP5.

Quote
Also, the Roadmap page states that it "requires existing WB 2.7 to update to 2.8". I presume this is only applicable IF YOU ARE UPGRADING and not doing a fresh install!

Hmm, couldn't understand what you really mean. "requires existing WB 2.7 to update to 2.8" talks only from "update" and not from a clean install.

Matthias

doc

  • Guest
Re: WB 2.8 - a few questions
« Reply #2 on: March 02, 2009, 01:20:46 PM »
Hello,

some statements from my point of view.

The WB goes PHP 5 logo should be removed as soon as possible, as WB does not fulfill the requirements of the go PHP5 initiative.

Quote from: PHP5 initiative
Therefore, the listed software projects have all agreed that effective February 5th, 2008, any new feature releases will have a minimum version requirement of at least PHP 5.2.0. Furthermore, the listed web hosts have agreed that effective February 5th, 2008, they will include PHP 5.2 (or a more recent version) in their service offer.

The go PHP5 makes sense for the sucessor of WebsiteBaker which is Platform RAD. The WebsiteBaker project however should contact the go PHP5 initiative and ask to updated WebsiteBaker by Platform RAD.

However, sticking to the old and outdated PHP4 code is not the target of new WB version. At the moment it is not clear, which version of WB will be PHP 5.2.x only, but for sure this will happen in the future. It simply makes no sense not to use performant functions introduced with PHP 5 only for backwards compatibility reasons.

Conclusion:
Withdraw from the go PHP5 initiative as soon as possible, but keep in mind that future versions of WebsiteBaker will make use of PHP 5 functions. And for sure, at some point in time WebsiteBaker will have PHP 5.2.x or higher as minimum requirement. It makes no sense to stick with PHP 4 for the entire live cycle of WebsiteBaker.

Regards Christian

doc

  • Guest
WebsiteBaker and goPHP5 initiative
« Reply #3 on: March 04, 2009, 07:40:24 AM »
Hello,

have sent an email to the project leader of the goPHP5 initiative with the following text.
Quote from: doc
Dear goPHP5 project co-ordinators,

the WebsiteBaker CMS project (WebsiteBaker.org) has recently splitted into two seperate projects. The designated sucessor of WebsiteBaker will be published under the new name: "PlatformRAD Open Source Edition" (http://www.platformrad.org/), while WebsiteBaker will continue under the old name WebsiteBaker.

Due to the restructuring, the WebsiteBaker project can not meet target to release only new version which have PHP 5.2 as minimum requirement. In fact the next release of WebsiteBaker - Version 2.8 will have PHP 4.4.9 as minimum requirement. Therefore we kindly ask you to replace "WebsiteBaker" by it´s successor "PlatformRAD Open Source Edition", which will be a true PHP 5.2.x application.

Sorry for any inconvinience caused by that.

Best regards
Christian Sommer

As a consequence, Matthias or Klaus please delete the missleading goPHP5 logo from the WebsiteBaker start page. If you do not have the time, simply send me access data via E-Mail and I will do the required text changes.

Again. Even if we can not stick to the rules of the goPHP5 initiative (only to release new version which have a minimum requirement of PHP 5.2), the WebsiteBaker project will not support PHP 4 for ages. PHP 5 offers a lot more than PHP 4 can do and for sure the time will come (even for WebsiteBaker) when we decide to swicht to PHP5 or to make use of PHP 5 features.

Regards Christian

erpe0812

  • Guest
Re: WB 2.8 - a few questions
« Reply #4 on: March 04, 2009, 08:08:45 AM »
Hi Doc,

from my point of view some bad news.

Sounds to me like you personally would like to found a new initiative:
return to or stay with php4 and lets us try  to stop time.

Hope, that this is only your solo.

rgds

erpe

doc

  • Guest
Re: WB 2.8 - a few questions
« Reply #5 on: March 04, 2009, 09:38:44 AM »
Hi Erpe,

Quote from: erpe
Sounds to me like you personally would like to found a new initiative:
return to or stay with php4 and lets us try  to stop time.
sorry, but your reply is bulls***. Please read the stuff I have written carefully to avoid any further confusion.

Fact is the WebsiteBaker project can not meet the targets of the goPHP5 initiative.
Quote from: goPHP initiative
Therefore, the listed software projects have all agreed that effective February 5th, 2008, any new feature releases will have a minimum version requirement of at least PHP 5.2.0.
The next release of WebsiteBaker - Version 2.8 will work with a minimum requirement of PHP 4.4.9.

But again, withdrawing from the initative goPHP5 does not mean that future releases of WebsiteBaker will not make use of PHP 5 - in fact it will, but not sure if with WB 2.9 or e.g. WB 3.0. The only thing we need to adapt is that we have to remove the goPHP5 logo from the start page - that's all.

With respect to the future of WB. We are aware that PHP 5 offers a lot of new possibilities and for sure we will make use of PHP 5 in future version of WebsiteBaker - but not with the next release WebsiteBaker - version 2.8.

Honestly speaking I do not really understand all the hype. We just withdraw from the goPHP5 initiative as we can not stick to the agreements - thats it. And no it is not a solo, it is just telling the guys of the initiative that we can not stick to what was promissed by Ryan two years ago.

Whats your suggestion? Search and replace all strpos (PHP4) to stripos (PHP5) so we achieve the goal that WB 2.8 only works with PHP 5? The time will come when WebsiteBaker implements true PHP5, but this will be in line with an major update (e.g. WB 3.0) and not just due to the fact that we have to stick to any initiative.

Hope this make things clear to everybody.

Regards Christian
« Last Edit: March 05, 2009, 05:12:16 AM by doc »

erpe0812

  • Guest
Re: WB 2.8 - a few questions
« Reply #6 on: March 04, 2009, 10:35:46 AM »
Hi Doc,

I read your reply to mine, but this means, that as soon as 2.8 is released and the next WB-Release will be php5 you can move the icon back on the startpage and send a new message to the initative.

Well done............and I have never heard anyone else of the official Bakers talking about remove from php5 initiative but you.

And at last: you can think about my post whatever you want, but I think it is not a good idea to declare it as bulls***.
Remember, that your forum-status is an official one.

rgds

erpe

doc

  • Guest
Re: WB 2.8 - a few questions
« Reply #7 on: March 04, 2009, 11:16:39 AM »
Hi Erpe,

think you have not get the point. The WB goes PHP5 initiative was launched by Ryan with to goal in mind that WB 3.0 will be PHP 5.2 only. As we all know, this has changed and WB 3.0 as originally planned for WB is now Platform RAD. Therefore I asked to replace WebsiteBaker by Platform RAD.

The whole goPHP5 initiative was launched some years ago to push big projects to switch their code basis from PHP 4 to PHP 5 to enforce hosting companies, also to support PHP 5. All projects listed there have commited not to release any new version which uses PHP4 as baseline, as we do for WebsiteBaker 2.8. Deadline was set to February 2008 for any PHP 4 supported version.

What is your proposal, release WB 2.8 with PHP 4 and hope that no forum member or coordinator of goPHP5 will ask why we do not stick to our commitments? In fact for the WebsiteBaker developement, it has no impact if we are member of the goPHP5 initiative or not.

Time will come when WebsiteBaker has PHP 5 as minimum requirement, but it is for sure not WB 2.8. And yes, this fact that WB 2.8 is still PHP 4 compliant is known by all developers working on WebsiteBaker 2.8 release.

Think we should be as open as possible to the community and to the initiators of the goPHP5 initiative. At least that makes much more sense to me, having a big fat logo telling hey we are member of goPHP5 but we do not really care about the commitments we gave and will release WebsiteBaker 2.8 with minimum requirements of PHP 4.4.9.

This will be my last post on this topic. Think I have explained the situation as open and transparent as I could.

Regards Christian
« Last Edit: March 04, 2009, 11:18:39 AM by doc »

erpe0812

  • Guest
Re: WB 2.8 - a few questions
« Reply #8 on: March 04, 2009, 11:28:48 AM »
You were wrong.
I have got it from the first post.

And you are right.
It makes no sense to make further post in this thread.

rgds

erpe
« Last Edit: March 04, 2009, 01:20:44 PM by erpe »

mickpage

  • Guest
Re: WB 2.8 - a few questions
« Reply #9 on: March 04, 2009, 12:59:50 PM »
Doc - Sorry I started this topic.

I agree PHP5 is the way forward but it is wrong to pretend WB satisfies the goPHP5 initiative. As soon as 2.7 was released in April 2008 (i.e. after the goPHP5 date of 5 Feb 2008) - without a minimum requirement of PHP5.2 - the WB project broke its promise.

Shame erpe didn't understand that.
« Last Edit: March 04, 2009, 01:10:26 PM by mickpage »

doc

  • Guest
Re: WB 2.8 - a few questions
« Reply #10 on: March 04, 2009, 05:31:37 PM »
Hi mickpage,

Quote
As soon as 2.7 was released in April 2008 (i.e. after the goPHP5 date of 5 Feb 2008) - without a minimum requirement of PHP5.2 - the WB project broke its promise.
Almost true. We issued a first release candidate with all planned features for WB 2.7 beginning of February 2008 and used the two month up to April for testing and bugfixing. This "trick" allowed to publish WB 2.7 without violating the committments made - even if this approach is a bit fuzzy.

My final words on this topic unless I receive a message from the guys from goPHP5 which I will then post as my true final statement  :-)

Regards Christian

mickpage

  • Guest
Re: WB 2.8 - a few questions
« Reply #11 on: March 05, 2009, 12:36:36 PM »
Quote
We issued a first release candidate with all planned features for WB 2.7 beginning of February 2008
A sneaky trick!
Good to see the WB Start page has now lost the GoPHP5 logo. That was quick!

chio

  • Guest
Re: WB 2.8 - a few questions
« Reply #12 on: March 07, 2009, 09:41:12 PM »
Does PHP5 bring a better WB-media-management? Does it have a working calendar-module inside? Will PHP5 fix all bugs in some WB-modules?

I have (I guess) about 30 WB-Installations, most for clients. Only 2 of them have PHP5. Of course: PHP 5 will come. But: not that quick.


Offline Xagone

  • Posts: 482
  • Gender: Male
  • Developper
    • Xagone Inc
Re: WB 2.8 - a few questions
« Reply #13 on: March 09, 2009, 03:59:13 AM »
all my clients are on my webhosting system witch are on php 5.2.X (they vary)

are you telling me that some addons have problem under 5.2 ?

my major server will be upgrade to 5.3 when available... will there be problems ?
Xagone Inc. (formerly VotreEspace)
http://xagone.com/

chio

  • Guest
Re: WB 2.8 - a few questions
« Reply #14 on: March 09, 2009, 08:16:33 AM »
all my clients are on my webhosting system witch are on php 5.2.X (they vary)
Seems like PHP5 was a weightful criterium when you choosed the webspace.
For a lot of people it wasn't. And some of them even cant upgrade without problems.

Quote
are you telling me that some addons have problem under 5.2 ?
No, some modules have problems with all kinds of PHP ;-)