Author Topic: show_menu2 help  (Read 1326 times)

Availor

  • Guest
show_menu2 help
« on: May 30, 2008, 09:06:27 PM »
I've posted in this thread http://www.websitebaker2.org/forum/index.php/topic,9856.0.html regarding drop down menus.

I'm using show_menu2() for that matter.

There's a decription of how to use it, but I seem to lack the practice/understanding of it.

Code: [Select]
show_menu2(
        $aMenu          = 0,
        $aStart         = SM2_ROOT,
        $aMaxLevel      = SM2_CURR+1,
        $aFlags         = SM2_TRIM,
        $aItemOpen      = '[li][a][menu_title]</a>',
        $aItemClose     = '</li>',
        $aMenuOpen      = '[ul]',
        $aMenuClose     = '</ul>',
        $aTopItemOpen   = false,
        $aTopMenuOpen   = false
        )

Anyway, I have this code as a simple html I've made as my menu.

Code: [Select]
<ul id="MenuBar1" class="MenuBarVertical">
          <li><a class="MenuBarItemSubmenu" href="#">test</a>
              <ul>
                <li><a href="#">Item 1.1</a></li>
                <li><a href="#">Item 1.2</a></li>
                <li><a href="#">Item 1.3</a></li>
              </ul>
          </li>
          <li><a href="#">Item 2</a></li>
          <li><a class="MenuBarItemSubmenu" href="#">Item 3</a>
              <ul>
                <li><a class="MenuBarItemSubmenu" href="#">Item 3.1</a>
                    <ul>
                      <li><a href="#">Item 3.1.1</a></li>
                      <li><a href="#">Item 3.1.2</a></li>
                    </ul>
                </li>
                <li><a href="#">Item 3.2</a></li>
                <li><a href="#">Item 3.3</a></li>
              </ul>
          </li>
          <li><a href="#">Item 4</a></li>
        </ul>

I have the <ul> item with the id "MenuBar1" and class "MenuBarVertical". My submenu items have the class of "MenuBarItemSubmenu" in the <a class="MenuBarItemSubmenu" href="#">top menu</a>

How do I place these to work with show_menu2(); ?

This is how I've done it copying it from another script;
<?php show_menu2(0, SM2_ROOT, SM2_ALL, SM2_ALL, false, "\n</li>", false, false, false, '<ul id="MenuBar1" class="MenuBarVertical">'); ?>

It works in firefox but it doesn't work in internet explorer (here is the test link http://www.videoxone.com/demo/demo1/)

Can anyone please help me place the code in the right places of the menu?

Thanks in advanced,

Availor