Author Topic: Problem mit Template Edit 1.41  (Read 2262 times)

Offline InTimo

  • Posts: 70
Problem mit Template Edit 1.41
« on: January 24, 2008, 01:15:59 PM »
Hallo Experten .. hab auf WB 2.6.7 upgedatet und danach Template Edit deinstalliert und anschließend die neue Version installiert ..

Leider kommt nach dem Versuch, die Datei (CSS) zu speichern, folgender Fehler

savecontent error!!

Jemand ne Idee ??

Muss ich noch was spezielles für TempEdit ergänzen ??

Timo

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem mit Template Edit 1.41
« Reply #1 on: January 24, 2008, 01:31:31 PM »
Hallo,

bitte erst mal auf der Hilfe suchen bevor hier geposted wird:

http://help.WebsiteBaker.org/pages/de/knowledge-base/dateien-und-berechtigungen.php

Problem ist, dass du templates, die per ftp hochgeladen wurden nur dann mit einem script (template edit) bearbeiten kannst, wenn die zu bearbeitenden Dateien dies zulassen (per ftp chmod auf 777 setzen)

Matthias

Waldschwein

  • Guest
Re: Problem mit Template Edit 1.41
« Reply #2 on: January 24, 2008, 01:33:56 PM »
Hallo!

Welchen Browser benutzt du denn? Wenn du Internet Explorer verwendest, versuche es einmal mit dieser Template Edit. Also alte 1.41 löschen und diese (IE gefixte) neu installieren.

Gruß Michael

EDIT: ruebenwurzel war schneller, aber ich glaube trotzdem nicht (es sei denn du benutzt Firefox), dass es an den Berechtigungen, an FTP oder sonstwo liegt.  8-) Sonst würde sich ja template edit kaum zeigen, oder?  :wink:
 
EDIT2: Zur Klarstellung: Alle Codepress Module soweit haben einen "Bug" (ok, es ist nicht wirklich einer), der es für IE7 Benutzer unmöglich macht diese zu benutzen. doc hat soweit den Fehler hoffe ich gefunden.
Das mag IE7 nicht:
Code: [Select]
<textarea id="css_data" name="css_data" ...</textarea>Das mag IE7:
Code: [Select]
<textarea id="css_data" ...</textarea>
Also die "doppelte" Definierung name="xy" mag IE nicht.

Speziell beim Template Edit ist das in der tool_edit.php Zeile 155.
« Last Edit: January 24, 2008, 02:05:55 PM by Waldschwein »

Offline InTimo

  • Posts: 70
Re: Problem mit Template Edit 1.41
« Reply #3 on: January 24, 2008, 04:35:24 PM »
Hallo,

die Temps sind alle auf 777 gesetzt (hatte ich nämlich auch schon in verdacht .. aber mit der alten Version ging das auch perfekt mit dem Editieren).

Nutz eigentlich nur IE 7.0 .. FireFox hab ich nur zum Testen der komp. der geänderten Seiten zu testen.

Also werd ich mal den FIX testen ;)

Danke Euch


Offline InTimo

  • Posts: 70
Re: Problem mit Template Edit 1.41
« Reply #4 on: January 24, 2008, 05:28:08 PM »
Hallo .. lag an der Doppeldefinition .. funzt jetzt. Aber ohne JAVA ging das deutlich flüssiger mit dem Editieren

Timo

Waldschwein

  • Guest
Re: Problem mit Template Edit 1.41
« Reply #5 on: January 24, 2008, 05:46:45 PM »
Hallo!

Hmm, ja, die Entwickler wollen den codepress haben und nicht abschaltbar machen... Helfen nur zwei Möglichkeiten: Javascript des PCs ausschalten (was unschön ist) oder altes Script verwenden... Auf Internet Explorer gibt's leider keine Möglichkeit CodePress per Klick auszuschalten. 8-)
Ändern des Ordners (was logisch wäre) führt dann auch nur zu einer grauen, uneditierbaren Box...

Gruß Michael

doc

  • Guest
Re: Problem mit Template Edit 1.41
« Reply #6 on: January 24, 2008, 08:33:09 PM »
Hallo,

bitte date mal auf die Version v1.42 ab die ich eben released habe. Mit dieser Version sollte auch eine normale Textarea erscheinen, wenn Du /include/codepress z.B. in /include/_codepress umbenennst.

Auch das Hello world modul wurde auf v0.46 upgedatet.

Gruss Christian

 

postern-length