Author Topic: Problem with russia language  (Read 13918 times)

Taffman

  • Guest
Problem with russia language
« on: July 05, 2007, 10:31:23 PM »
Hello!

I have tryed to make russian language, but it doesnt want to work.
Menu side shows only #1050& etc but the content side works. What can be the problem?
http://www.ennuautoremont.ee/problem.jpg

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8375
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with russia language
« Reply #1 on: July 06, 2007, 06:30:29 AM »
Hello,

wich version of WB did you use? All language and charset issues should be solved in the actually version 2.6.7.

Matthias

Taffman

  • Guest
Re: Problem with russia language
« Reply #2 on: July 09, 2007, 10:42:08 AM »
267 version

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with russia language
« Reply #3 on: July 09, 2007, 07:42:53 PM »
Hello,

Hello!

I have tryed to make russian language, but it doesnt want to work.
Menu side shows only #1050& etc but the content side works. What can be the problem?
http://www.ennuautoremont.ee/problem.jpg


i don't understand the picture - what does it show?
Can you provide a link to that site?

And some more questions:
Have you done a new installation or an update?
What charset do you use: UTF-8 or ISO-8859-5 (cyrillic)?

Edit: There was a problem with 2.6.5, while using characters not part of the used charset, which produces exactly this behavior.
Are you sure you have a 2.6.7?  :evil:

thorn.
« Last Edit: July 09, 2007, 08:08:54 PM by thorn »

Taffman

  • Guest
Re: Problem with russia language
« Reply #4 on: July 10, 2007, 09:26:28 AM »
http://www.ennuautoremont.ee/problem-language.jpg

I have done instalation with 267
I tried to use both UTF-8 , ISO-8859-5 (cyrillic) , but they did´nt work. At the moment I use Latin-4 Baltic to see in content side russian letters, with oder languages I dont see anywhere russian. This is the only language with what content works.

What is wrong or must be done different to see also menu in russian letters`?

Thanks,

Taavi

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8375
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem with russia language
« Reply #5 on: July 10, 2007, 10:48:35 AM »
Hello,

did your template use the same charset as you have set in WB? Also changing the charset after pages are created could make issues. Please do the following:

- Make a clean new wb 2.6.7 install.
- Let the charset on "UTF8"
- Make shure the template also uses charset "UTF8"
- now create your pages

What is the result?

Again, please don't change the charset after pages are created and make shure your template uses the same charset as WB.

Matthias

Oxana

  • Guest
Re: Problem with russia language
« Reply #6 on: July 11, 2007, 01:45:33 PM »
Hi everybody

Just few day ago meet WB. Glad for his opportunity to build multi-language web-site.
Enjoy of his flexibility and friendly interface for non-technical-users.

Thanx a lot for great job!

But pity that some characters in Russian and Ukrainian languages displayed wrong in all titles :(
They are -- “И” (Capital letter) “ш” (small letter).

Is it possible to solve this?
Thanx forvard for any help!

p.s.
I can answer with confidence :) that:
- Have a clean new wb 2.6.7 installation
- Database in «UTF8» (in phpMyAdmin all WB tables has UTF8-unicode-ci)
- The charset in WB admin-panel is "UTF8"
- Template also uses charset "UTF8"
« Last Edit: July 11, 2007, 07:03:02 PM by Oxana »

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with russia language
« Reply #7 on: July 11, 2007, 07:36:58 PM »
Hello,

But pity that some characters in Russian and Ukrainian languages displayed wrong in all titles :(
They are -- “И” (Capital letter) “ш” (small letter).

Is it possible to solve this?

I can answer with confidence :) that:
- Have a clean new wb 2.6.7 installation
- Database in «UTF8» (in phpMyAdmin all WB tables has UTF8-unicode-ci)
- The charset in WB admin-panel is "UTF8"
- Template also uses charset "UTF8"

A month ago there was the same problem on a site using greek-chars (http://forum.WebsiteBaker.org/index.php/topic,6537.msg40916.html#msg40916).
Unfortunately i couldn't find out what the problem was...
I'm virtually certain the problem is the changed database-charset! Can you try it with a fresh new installation, without altering the database? Don't be afraid if it shows only garbage -- try to change the charset to utf-8 in your browser (there's a issue with some old apaches who need a .htaccess-file to deliver utf-8 well).
Can you a provide a URL to your site? It would help me a lot to try a few thing for my one.

thorn.

Oxana

  • Guest
Re: Problem with russia language
« Reply #8 on: July 13, 2007, 12:57:41 AM »
Hallo

Just trying to test it on my PC localhost to use WB in my practice and haven't any site based on WB in public view URL yet.

Again done absolutely new installation of WB 2.6.7.
Create new database by phpMyAdmin with options:
 - "MySQL connection collation" – utf8_bin
 - "Created new database collation" – utf8_bin
(or will be better if utf8_unicode_ci ?)

So new WB database in utf8_bin, database collation in utf8_bin
but “И” and “ш” -- displayed wrong.

Solved -- only when open in notepad and edit this stroke --
default-character-set = utf8
in file my.cnf (stored in /usr/local/mysql4/)

И” and “ш” -- displayed perfectly now :).

Great thanks for answering and tips!

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with russia language
« Reply #9 on: July 13, 2007, 07:20:52 PM »
Hallo

Just trying to test it on my PC localhost to use WB in my practice and haven't any site based on WB in public view URL yet.

Again done absolutely new installation of WB 2.6.7.
Create new database by phpMyAdmin with options:
 - "MySQL connection collation" – utf8_bin
 - "Created new database collation" – utf8_bin
(or will be better if utf8_unicode_ci ?)

So new WB database in utf8_bin, database collation in utf8_bin
but “И” and “ш” -- displayed wrong.
:-( Let website baker create the database (it will be latin1_swedish_ci)!
Then use utf-8 inside website baker.
This will solve your problem (i hope so!) - and don't forget to redo your changes in my.cnf before.

Quote
Solved -- only when open in notepad and edit this stroke --
default-character-set = utf8
in file my.cnf (stored in /usr/local/mysql4/)

И” and “ш” -- displayed perfectly now :).

Great thanks for answering and tips!
Can can't change your service-provider's my.cnf (if you get some webspace for wb in future).

thorn.

Oxana

  • Guest
Re: Problem with russia language
« Reply #10 on: July 14, 2007, 05:36:22 PM »
Hello

Quote
Can can't change your service-provider's my.cnf (if you get some webspace for wb in future).

Hm... bed news
In my.cnf was stroke -- default-character-set = cp1251 (before I changed it to utf8).
If this info has meaning to this problem.

Quote
Let website baker create the database (it will be latin1_swedish_ci)!
Then use utf-8 inside website baker.
This will solve your problem (i hope so!) - and don't forget to redo your changes in my.cnf before.

Done this recommendation.
Result – all letters displayed wrong :(



Thenks for your time
and willingness to help me.

p.s.
As non-technical user I hate MySQL more and more...
So much headache with transfer from host to host... now yet characters surprise...
Really dream about easy & friendly XML or  text flat database in WB :)

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with russia language
« Reply #11 on: July 14, 2007, 06:55:03 PM »
Hello,

would be nice if you could do some more testing...

In my.cnf was stroke -- default-character-set = cp1251 (before I changed it to utf8).
If this info has meaning to this problem.
Comment this line out. It should read
#default-character-set = cp1251

Quote
Done this recommendation.
Result – all letters displayed wrong :(
Have you tried to change your browser's charset? Try to change it to e.g. UTF-8, ISO-8859-1 and windows-1252. There are changes that your apache sends wrong header-information.

thorn.

PS: a question to XAMPP-users: how is that configured in XAMPP? Is there an entry for default-character-set?

Oxana

  • Guest
Re: Problem with russia language
« Reply #12 on: July 14, 2007, 11:53:35 PM »
Hallo!
would be nice if you could do some more testing...
Test report :)

database – latin1_swedesh_ci
in file my.cnf  -- #default-character-set = cp1251 (commented)
website and admin – all RU/UA characters display well
(brauser by auto in utf8)

But in database table «pages» all RU/UA text – display in strange characters.
And I found bit strange to do ru/ua website in latin_swedesh_ci... traditionally in win1251 or utf8... but its just my impression :)

Thank you!

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with russia language
« Reply #13 on: July 15, 2007, 09:34:45 AM »
Hello,

But in database table «pages» all RU/UA text – display in strange characters.
And I found bit strange to do ru/ua website in latin_swedesh_ci... traditionally in win1251 or utf8... but its just my impression :)

WB doesn't set the client-charset while opening the mysql-connection.
Doing so now, will break many modules -- and break the compatibility with older installations (and setting default-character-set [to something different than latin1?] will break things even more).
For now, we have to live with this ugly database-garbage.

thorn.

Oxana

  • Guest
Re: Problem with russia language
« Reply #14 on: July 16, 2007, 02:02:19 PM »
Hallo,

Please explain for people without tech-knowledges  :?

If we already check no default-character-set-entry in mysql's my.cnf or my.ini!
So why database has to be in latin1_swedish_ci by default
instead UTF8?

(Perhaps better keep WB database in UTF8 and just carefully choose hoster-provider who meet this requirement?)

Thanx forward!

Offline thorn

  • Posts: 980
  • Gender: Male
    • Projects
Re: Problem with russia language
« Reply #15 on: July 20, 2007, 02:16:59 PM »
Hallo,

Please explain for people without tech-knowledges  :?

If we already check no default-character-set-entry in mysql's my.cnf or my.ini!
So why database has to be in latin1_swedish_ci by default
instead UTF8?

(Perhaps better keep WB database in UTF8 and just carefully choose hoster-provider who meet this requirement?)

Thanx forward!

WB will break if you change the column-charset without changing the connection-charset.

WB doesn't set (although it should!) a character-set neither while table-creation (column-charset) nor while connecting to the database (connection-charset), so mySQL assumes latin1 for both.
Because there will be no conversion [connection-charset==column-charset], this works with e.g. UTF-8, too.
If you change one side (e.g. setting the column-charset to utf8), your UTF-8-string in WB will be wrongly converted from _latin1_to_utf8_ while writing to database and vice versa while reading from it.
Most characters resist this wrong conversion, but some will break. If you change the connection-charset [-> "default-character-set"], you will have the same effect.

You would have to set both to the same value (both uft8, or both cp1252, ...), but most of the time, you can't change the "default-character-set".

thorn.

SergeV

  • Guest
Re: Problem with russia language
« Reply #16 on: June 15, 2008, 12:24:54 AM »
Russian language file is written down by symbols instead of letters.
Example:
Code: [Select]
$MENU['START'] = 'Старт';It is necessary to transfer simply all symbols in letters through a Notepad:
Code: [Select]
$MENU['START'] = 'Ñòàðò';

Offline shlack

  • Posts: 25
Re: Problem with russia language
« Reply #17 on: July 01, 2008, 02:59:26 PM »
Russian language file is written down by symbols instead of letters.
Example:
Code: [Select]
$MENU['START'] = 'Старт';It is necessary to transfer simply all symbols in letters through a Notepad:
Code: [Select]
$MENU['START'] = 'Ñòàðò';

You need to use UTF-8 encoding for Russian language. It woks perfectly (WB 2.7), you don't need to do any manipulations with language file .

SergeV

  • Guest
Re: Problem with russia language
« Reply #18 on: July 04, 2008, 12:02:26 AM »
At me all russian letters are displayed perfectly and without translation in symbols, it is just necessary to register in a file .htaccess
Code: [Select]
AddDefaultCharset UTF-8

 

postern-length