Author Topic: Installationsproblem Datenbank-Zugriff  (Read 3066 times)

damu

  • Guest
Installationsproblem Datenbank-Zugriff
« on: April 08, 2007, 12:24:01 PM »
Hallo Forumgemeinde,

mein erstes Post und gleich mein erstes Problem.

Habe zwar schon einiges an Themen zu diesem Thema gelesen aber keine Lösung für mein Problem gefunden.

Folgende Fehlermeldung erhalte ich bei der Installation von WB mit dem DB-Hostname localhost:

Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'XYZ123-01sql1'@'localhost' (using password: YES) in .../wb/install/save.php on line 345

Warning: Cannot modify header information - headers already sent by (output started at .../wb/install/save.php:345) in .../wb/install/save.php on line 80


Mit Angabe von 127.0.0.1 als DB-Hostname erscheint diese Fehlermeldung:

Access denied for user 'XYZ123-01sql1'@'127.0.0.1' to database 'DB-Name'

Username/Passwort habe ich mehrmals überprüft.

Seltsam ist das ein Zugriff auf die Datenbank mit PHPMyAdmin ohne Probleme möglich ist.

Folgendes habe ich schon probiert.

User/PW überprüft.
PW geändert (da evtl. zu lang / zu kurz)
Cache und Temp-Dat. vor Installation im Browser (IE6) geleert.
Anderen Browser verwendet (Opera9)

Beim Installationswizard werden in Step1 alle drei grün angezeigt.
Rechte nach entsprechender Vergabe (incl. Dateien und unterverzeichnisse) in Step2 alle grün.

Server Linux
Datenbank unter SysCP angelegt (Username wird automatisch vergeben)
Mysql-Version 5.0.32

Weis echt nicht mehr weiter, kann mir von euch jemand nen Tip geben wie ich WB noch zum laufen bekommen kann.

MFG Daniel

PS: Eine Vermutung hätte ich evtl. noch: Kann es sein das WB bei der Anmeldung an die Datenbank Probleme mit dem "-" im Benutzername hat?

EDIT: PPS: PHPMyAdmin meldet sich mit 127.0.0.1 über TCP/IP (utf8-german) und den selben Username/PW an. - ohne Probleme
« Last Edit: April 09, 2007, 03:24:02 PM by damu »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Installationsproblem Datenbank-Zugriff
« Reply #1 on: April 08, 2007, 02:17:23 PM »
Hallo,

Läuft Mysql im strict mode?
Nutzt du die Original WB Dateien? Ich meine damit. hast du das Paket von WebsiteBaker.org heruntergeladen oder von woanders? Hast du die Dateien irgendwie verändert (umgespeichert in UTF8?) ?

Dein Datenbankhost ist "localhost"?
Dein Datenbankname ist "wbnm"?
Dein Datenbankuser ist "XYZ123-01sql1"?

Das sollten eigenlich die Eingaben sein, die du bei der Installation brauchst.

Hast du mal versucht vor der Installation die Datenbank berieits anzulegen?

Hast du den Webserver selbst konfiguriert oder war das ein vorkonfigurierter Server. Damit php mit mysql kommunizeren kann muss das entsprechend auf dem Server eingerichtet sein. (Extensions enabled, Dateien in die richtigen Verzeichnisse gelegt).

Matthias
« Last Edit: April 09, 2007, 08:59:33 PM by ruebenwurzel »

damu

  • Guest
Re: Installationsproblem Datenbank-Zugriff
« Reply #2 on: April 08, 2007, 11:17:43 PM »
Hallo, wow ging ja schnell...

Zu den Fragen:

Wie bekomme ich raus ob die DB im strict mode läuft?
(Kann per PHPMyAdmin befehle auf dem Mysql-Server ausführen, hilft das?
Lässt sich so eine Info über diesen Strict-Mode abfragen?)

Ja habe die originale *.zip datei von "download.WebsiteBak er.org" gedownloadet.
Nein, habe keinerlei Veränderungen an den Dateien vorgenommen (nur per FTP auf Server geladen).

Ja, der DB-Host ist "localhost".
Ja, der DB-Name ist "DB-Name".
Ja, der Username ist XYZ123-01sql1.

Diese Daten habe ich im Installationswizard auch angegeben.

Ja habe versucht mit bereits existierender DB zu installieren.
(DB vor installation neu angelegt (keine Tabellen enthalten)).

Ist ein vorkonfigurierter Server.
Wie kann ich prüfen ob "Extensions enabled sind?

Auszug aus PHPMyAdmin-Oberfläche:

127.0.0.1
Server Version: 5.0.24a-Debian_9-log
Protokoll-Version: 10
Server: 127.0.0.1 via TCP/IP
Benutzer: XYZ123-01sql1@localhost
MySQL-Zeichensatz: UTF-8 Unicode (utf8)
Zeichensatz / Kollation der MySQL-Verbindung: utf8_unicode_ci
phpMyAdmin - 2.9.0.3-Debian-1
MySQL-Client-Version: 5.0.32
Verwandte php-Erweiterungen: mysql

Hilft das evtl.?

MFG Daniel
« Last Edit: April 09, 2007, 03:25:21 PM by damu »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Installationsproblem Datenbank-Zugriff
« Reply #3 on: April 09, 2007, 10:02:59 AM »
Hallo,

MySQL strict mode wird seit Version 5.0 standardmäßig aktiviert. Vom Prinzip her bedeutet es, dass nur noch scripte laufen, die allen Anforederungen entsprechen. Dies ist jedoch noch bei kaum einem System der Fall. Strict mode kann man in der my.ini/my.cnf deaktivieren.

Suche:
Code: [Select]
sql-mode="STRICT_TRANS_TABLES,NO_AUTO_CREATE_USER,NO_E NGINE_SUBSTITUTION"
und ändere es in:
Code: [Select]
sql-mode=""
Nach einem Neustart sollte dann alles funktionieren.

Mehr infos hier: http://dev.mysql.com/doc/refman/5.1/de/server-sql-mode.html

Matthias

P.S.
Habs vergessen, sonst sollte eigentlich alles in deiner config passen  :wink:

damu

  • Guest
Re: Installationsproblem Datenbank-Zugriff
« Reply #4 on: April 09, 2007, 01:21:12 PM »
Hallo,

auf die Konfigurationsdatei en habe ich leider keinen Zugriff.

Auf die SQL-Abfrage SHOW VARIABLES gibt der SERVER unter sql_mode "nix" zurück (Feld leer).
Leider gibt der Server auf die Anweisung "Set @@session.sql_mode = 'ansi'; " eine Fehlermeldung zurück. Selbiges mit der Variable 'MYSQL40' oder nur ''.

Fehlermeldung: Warning: Cannot modify header information - headers already sent by (output started at .../libraries/header_meta_style.inc.php:27) in .../libraries/common.lib.php on line 1154

Liest sich für mich wie Rechte-Sache...

Dennoch sollte sich doch der Session.sql_mode doch dynamisch andern lassen. (lt. MYSQL 5.1 Referenzhandbuch)

Darin steht ebenfalls das jeder client seinen Session.sql_mode selbst jederzeit ändern kann.

Steh mom. im Wald...

Noch irgeneine Idee.... oder muss ich doch den Hoster anschreiben damit er den Modus für mich Dateiseitig ändert.

Für Tips wäre ich Dankbar.

MFG Daniel

damu

  • Guest
Re: Installationsproblem Datenbank-Zugriff
« Reply #5 on: April 09, 2007, 03:22:42 PM »
Hallo,

Fehler gefunden!!!  :-D

Aus folgendem Grund lies sich WB nicht richtig installieren: (Falls noch mal jemand dieses Prob hat.)

Unter SysCP kann eine Datenbank angelegt werden.
Wobei ein DB-Name vergeben werden kann.
Der hier angegebene DB-Name wird jedoch (aus welchem Grund auch immer) nicht verwendet.
Sondern es wird als Datenbankname der Connection-Username mit angehängtem sql(Zahl) verwandt.

Diesen DB-(Connection-Username)-Name wird auch als DB-Name verwendet.

Bsp. Unter SysCP als DB angegeben:
Username: XYZ123-01sql1 (automatisch von SysCP vergeben)
DB-Name: MeineDatenbank
Passwort: pass
Hostname: 127.0.0.1 (von SysCP festgelegt)

Einstellungen im Install Skript:
DB-Hostname: 127.0.0.1
DB-Username: XYZ123-01sql1
DB-Name: XYZ123-01sql1
Passwort: pass

Mit diesen Einstellungen lässt sich WB dann Problemlos installieren.

(Habe in meinen vorigen Posts die User/DB-Name aus Sicherheitsgründen nachträglich verfälcht, bitte um nachsicht.)

MFG Daniel


PS: @ruebenwurzel: Wäre nett wenn du meinen Username in deinem 1. Post ebenfalls abändern würdest, da dieser von mir nicht geändert werden kann!
« Last Edit: April 09, 2007, 03:27:50 PM by damu »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Installationsproblem Datenbank-Zugriff
« Reply #6 on: April 09, 2007, 09:02:45 PM »
Hallo,

Quote
Fehler gefunden!!!
Freut mich. Wenn auch das generieren des datenbanknamens ein bisschen mysteriös ist.  :-D

Quote
Wäre nett wenn du meinen Username in deinem 1. Post ebenfalls abändern würdest
Erledigt.

Viel Spaß mit WB

Matthias