Author Topic: Hyperlink erzeugt seltsame Codierung mit FCKEditor  (Read 3984 times)

Roger

  • Guest
Hyperlink erzeugt seltsame Codierung mit FCKEditor
« on: January 17, 2007, 03:01:31 PM »
Hallo Liebe Leute

Ich habe ein Problem mit WebsiteBaker 2.5.2 und dem FCKEditor

Diese Version von WB habe ich bereits einmal verwendet und benutze nun dieselbe Version mit neuem Layout auf einem anderen Server.

Bei der ersten Installation klappte alles wunderbar. Bei der neuen Installation habe ich nun folgendes Phänomen:
Wenn ich auf einer Seite einen Link einfüge, wird der Inhalt im FCKEditor seltsam "codiert".
Das ist das Ergebnis eines kurzen Textes mit Link:
Code: [Select]
Das+ist+eine+Testseite.%3Cbr+%2F%3E%3Cbr+%2F%3E%3Ca+href%3D%5C%22http%3A%2F%2Fvfavfadsf%5C%22%3Esdfsdfasdf%3C%2Fa%3E
Wenn ich das ganze ohne Link speichere funktionierts. Mit Link, obiges Ergebnis.
Mit HTMLAREA funktionierts (den Editor möchte der Kunde aber nicht).

Ich habe verschiedene Echos eingebaut. Bereits in der save.php im WYSIWYG-Modul erscheint der content falsch. Ich bin ziemlich ratlos, was kann das sein?

Wie gesagt, der grösste Unterschied dürfte sein, dass die Installationen auf unterschiedlichen Servern laufen... Ansonsten ist das eine, eine Kopie des anderen...

Vielen Dank für Eure Hilfe.

Gruss aus der Schweiz

Roger




Offline kweitzel

  • WebsiteBaker Org e.V.
  • **
  • Posts: 6983
  • Gender: Male
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #1 on: January 17, 2007, 03:22:07 PM »
Wow ... noch nicht gesehen ... was ist denn der Unterschied zwischen den Servern? Hast Du schon mal den FCK deinstalliert und dann neu installiert? Ich gehe mal davon aus, das der vom Add-On Repository runtergeladen wurde ...

Wie wird der Link denn in der Datenbank gespeichert?

Gruß

Klaus

Roger

  • Guest
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #2 on: January 17, 2007, 03:31:37 PM »
Hallo

Es sind halt zwei verschiedene Server-Anbieter. Einmal läuft PHP als CGI und das andere Mal als FAST CGI. Auch sonst gibts natürlich Differenzen, aber ich hätte nichts Gravierendes gefunden, das so etwas verursachen könnte.

Nein, den Editor habe ich nicht deinstalliert und wieder installiert. Ich habe aber die Dateien nochmals kopiert von der funktionierenden Version.

Da der Text bereits mit dem Variablen-Zugriff
Code: [Select]
$_POST['content'.$section_id]in der Datei save.php falsch codiert ausgelesen wird, muss es irgendwo im Editor liegen (nach meinem Verständnis. Die save.php wird direkt nach dem Drücken des Speichern-Knopfs ausgeführt...
Daher ist der Text anschliessend falsch codiert in der DB.

Ich bin ratlos...

Roger

« Last Edit: January 17, 2007, 03:43:03 PM by Roger »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #3 on: January 17, 2007, 04:05:18 PM »
Hallo,

nur kurze Anmerkung. Bitte steig um auf WB 2.6.5. WB 2.5.2 hat doch einige gravierende Bugs. Außerdem dürfte das aktuelle FCKEditor modul damit nicht laufen. Für WB 2.5.2 braucht man einen Patch zum Anzeigen des FCK. Auch die FCK Version die unter 2.5.2 lief hat einige Fehler. Also auch hier wäre es besser das aktuellste Modul zu nutzen.

Matthias

Roger

  • Guest
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #4 on: January 17, 2007, 04:26:21 PM »
Ja, sowas habe ich doch befürchtet... :oops:

Kannst Du grad so sagen, ob ein Update möglich ist, oder muss ich dafür Neuinstallieren?
Können bestehende Seiten übernommen werden?
Ist die deutsche Übersetzung bei der neuesten Version durchgängig (also auch Editor und die anderen Module)?

Ich könnte den Kunden auch einfach zwingen, den Server-Anbieter zu wechseln...  :-D

Sorry für die Fragen, wahrscheinlich könnte ich auch durch einige Readme's kämpfen...

Danke trotzdem für einige Antworten.

Roger





Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #5 on: January 17, 2007, 04:50:52 PM »
Hallo,

ein update von 2.5.2 nach 2.6.5 sollte ohne Probleme möglich sein und auch ohne dass die Seiten verlorengehen. Allerdings gibt es dabei einiges zu beachten. Falls du updaten möchtest teil mir das mit. Die bisherigen upgrade scripte hatten alle Fehler, ich habe aber eines hier liegen, das funktionieren sollte. Aber bevor du irgendetwas machst, setz dich bitte mit mir in Verbindung. Du solltest aber auf jeden Fall einmal ein backup der Kompletten Seite machen.

Matthias

Roger

  • Guest
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #6 on: January 17, 2007, 05:14:00 PM »
Hallo Matthias

Ja, wenn es so einfach möglich ist, dann mach ich das doch. Dann hätte ich einen sauberen Stand mit der Software. Meine Mailadresse findest Du ja hier im Beitrag. Wäre Dir dankbar, wenn Du mir sagen kannst, wie ich vorgehen muss/kann/darf/sollte.  :roll:

Gruss aus der Schweiz

Roger


Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #7 on: January 17, 2007, 06:26:22 PM »
Hallo,

Quote
Meine Mailadresse findest Du ja hier im Beitrag

Wo?

Schick bitte grad ne Mail an info@familie-gallas.de. Ich lass dir die Infos dann zukommen.

Matthias

Roger

  • Guest
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #8 on: January 17, 2007, 09:59:32 PM »
Hi Matthias

Da auf der linken Seite gibt's so eine Symbol. Das sieht aus wie ein Briefchen. Weiss, klein und mit einer E-Mail-Adresse hinterlegt...  :wink:

Ciao + Danke.

Roger

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8383
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #9 on: January 17, 2007, 10:04:54 PM »
Hallo Roger,

solange du das in deinen Einstellungen auf versteckt setzt kanns nur du das sehen.  :-D

Matthias

Roger

  • Guest
Re: Hyperlink erzeugt seltsame Codierung mit FCKEditor
« Reply #10 on: January 17, 2007, 10:15:13 PM »
Oha Tschuldigung,
wusste gar nicht, dass man das kann... :roll:

Schicke Dir ein Mail...

Gruss

Roger