Author Topic: Problem mit deutscher Sprachdatei und WB 265  (Read 2466 times)

Offline MrRedlich

  • Posts: 88
  • Gender: Male
Problem mit deutscher Sprachdatei und WB 265
« on: January 16, 2007, 02:12:16 PM »
nachdem ich im adminfrontend die deutsche datei geladen und als standart gesetzt habe, ist das Adminfrontend wie erwartet 100% deutschsprachig geworden.

Melde ich mich ab und gehe wieder ins Adminfrontend, so geht das leider nicht mehr. Ich erhalte dann nur diese Meldung

Warning: Cannot modify header information - headers already sent by (output started at /srv/www/htdocs/web10/html/wb/languages/DE.php:537) in /srv/www/htdocs/web10/html/wb/admin/index.php on line 35

Ins Adminfrontend komme ich dann nur noch wieder rein, wenn ich per FTP die DE.php in DE.old umbenenne und eine Kopie von EN.php in DE.php umbenenne. Dadurch wird das Admin aber wieder englisch.
« Last Edit: January 16, 2007, 02:16:36 PM by MrRedlich »
I nur speek Deutsch
Ich only spreche German

Offline kweitzel

  • WebsiteBaker Org e.V.
  • **
  • Posts: 6983
  • Gender: Male
Re: Problem mit deutscher Sprachdatei und WB 265
« Reply #1 on: January 16, 2007, 03:16:22 PM »
1) Was passiert, wenn Du zusätzlich Dein Benutzerkonto auf deutsch umstellst?
2) Die übliche Frage, woher kommt die Datei DE.php
3) Hast Du schon versucht, die Datei einmal neu hochzuladen?

Gruß

Klaus

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Problem mit deutscher Sprachdatei und WB 265
« Reply #2 on: January 16, 2007, 03:43:13 PM »
Hallo,

das Problem liegt an den session cookies und IE. Wenn man die Sprache ändert, sich abmeldet und die Cookies nicht löscht nutzt WB die gespeicherten Informationen (EN) um sich anzumelden. Das geht aber nicht, weil ja auf DE umgestellt.

Problemlösung ist ganz einfach. Alle Browsercaches löschen. Dann sollte alles wieder funktionieren.

Was allerding nach deinen Änderungen jetzt los ist kann ich dir nicht sagen. Um es sicher wieder zum laufen zu bekommen bitte in der Datenbank alles auf EN einstellen. (Settings, Pages, User). Danach DE deinstallieren und neu installieren, alles auf DE umstellen, abmelden, Cache löschen, anmelden, das wars.

Matthias

Offline MrRedlich

  • Posts: 88
  • Gender: Male
Re: Problem mit deutscher Sprachdatei und WB 265
« Reply #3 on: January 16, 2007, 03:55:37 PM »
Quote
das Problem liegt an den session cookies und IE.

und Firefox? Den IE verwende ich seit gut 2 jahren nicht mehr  :-D

Ich will es gleich mal nochmal probieren.
I nur speek Deutsch
Ich only spreche German

Offline MrRedlich

  • Posts: 88
  • Gender: Male
Re: Problem mit deutscher Sprachdatei und WB 265
« Reply #4 on: January 17, 2007, 01:12:49 AM »
Jetzt hat es einwandfrei funktioniert. Danke
I nur speek Deutsch
Ich only spreche German

 

postern-length