Author Topic: Templatesuche, lauffähig unter PHP 8  (Read 251 times)

Offline Herbert

  • Posts: 38
Templatesuche, lauffähig unter PHP 8
« on: January 13, 2023, 05:45:12 AM »
Ein freundliches Hallo
Es geht um Templates. Ich muss meine Homepage nach Aufforderung durch den Provider umstellen, sodass sie unter PHP 8 lauffähig ist und benötige Euren Tipp, welches der auch hier angebotenen Templates sich dafür eignet.
Das derzeitig verwendete ist, wenn ich bei meinem Hoster/Provider auf PHP 8 umstelle, nicht lauffähig, nur weißer Bildschirm.
Es sollte ein Horizontales Menü besitzen und bei einigen Menüpunkten gibt es dann eine Unterebene.
Leider habe ich keine Englischkenntnisse und auch meine PHP-Kenntnisse sind äußerst gering, reicht allemal dazu, z.b. das Titelbild auszutauschen.
Keine guten Voraussetzung, oder ? :-(
Hier bei "WebsiteBaker" werden ja einige angeboten, aber gleich das erste, was ich ausprobiert hatte,  bringt auch wieder nur einen weißen Bildschirm. Und ich finde bei keinem den sinngemäßen Hinweis, auch lauffähig unter PHP 8 oder höher.
Habt Ihr einen Tipp für mich?? Mit besten Gruß, Herbert

Offline dbs

  • Betatester
  • **
  • Posts: 8777
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Templatesuche, lauffähig unter PHP 8
« Reply #1 on: January 13, 2023, 06:41:06 AM »
Moin Herbert, neue PHP Versionen benötigen nicht neue Templates, aber neues WebsiteBaker.
Dein Template geht nicht, weil es einen PHP Fehler in WB oder in einem der Module oder Droplets gibt.
Wenn du als Admin eingeloggt bist, solltest du in der oberen Button Reihe einen Button "X" (gelb oder rot) sehen, welcher dir Fehlermeldungen anzeigt. Klick drauf und kopier den Inhalt mal hier rein.

Auf jeden Fall steht dir ein WebsiteBaker Upgrade bevor. Aktuell ist Version 2.13.3 r166.

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8463
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Templatesuche, lauffähig unter PHP 8
« Reply #2 on: January 13, 2023, 06:43:34 AM »
Hallo,

die Lauffähigkeit von Templates hat nur dann was mit der php Version zu tun wenn im Template entsprechende php funktionen verwendet werden. Dein weißer Bildschirm liet vermutlich nicht am Template sondern hat eine andere Ursache.

Welche WB Version hast du im Einsatz? Für PHP 8 solltest du, falls noch nicht gemacht, dringend auf WB 2.13.3 (r166) upgraden.
Welches Template hattest du denn bisher im Einsatz und welches hast du heruntergeladen? Mit diesen Infos kann man sich dann auf die Suche nach möglichen Ursachen machen.
Wenn du schon WB 2.13.3 im Einsatz hast. Wie hast du das upgrade gemacht? Mittels der aktuellen "Unzip-Methode" oder klassisch durch hochladen der einzelnen Dateien per FTP? Abhängig vom eingesetzten FTP-Programm und dem Hoster kann es zu Übertragungsfehlern kommen, was eine fehlerhafte WB-Installation zur Folge hat.
Sollte WB 2.13.3 laufen, versuche mal auf das mitgelieferte DefaultTemplate umzustellen. Kommt da auch ein weißer Bildschirm?

Offline Herbert

  • Posts: 38
Re: Templatesuche, lauffähig unter PHP 8
« Reply #3 on: January 13, 2023, 03:01:33 PM »
Hi an Euch, also ich benutze die Version 2.12.2r379 und als bisheriges Template "drytzel".
Da habe ich es geschafft, Farben und Titelbild nach meinen Wünschen anzupassen, die Homepage läuft stabil, bisher.

Versucht habe ich es dann mit dem Template "Lounge-Responsive", welches ich hier von Angeboten von "WebsiteBaker" runtergeladen hatte und auch erfolgreich eingebunden hatte. Zumindest lief es hier im Adminmodus.

Anschließend habe ich in meinen Paket bei meiner Hoster die PHP-Version 8 eingestellt und eben nur die weiße leere Seite gesehen.
Zum Glück konnte man dann innerhalb eines kurzen Zeitfensters wieder auf die PHP-Version 7.4 zurückkehren.

Nun habe ich das Dilemma, 2 Homepages umzustellen. Die eine ginge ja mit etwas Aufwand, wenn ich zu einem reinen html-Modus zurückkehre da nur wenige Seiten Inhalt.
Aber die zweite ist weitaus viel komplizierter.
Bei der Gelegenheit noch die Frage, wo finde ich eine exakte ToDo-Anleitung wenn ich auf die neueste WebsiteBaker Version umsteigen will.?
Herzlichen Dank für Eure Mühe, mir zu helfen :-) :-)



Offline sternchen8875

  • Posts: 97
Re: Templatesuche, lauffähig unter PHP 8
« Reply #4 on: January 13, 2023, 04:07:10 PM »
Es wäre hilfreich, wenn du den Tips der Vorredner mal folgst und z.b. unter Optionen -> Standardeinstellung en probeweise auf das DefaultTemplate umstellst.
Weiterhin hilft es, wenn du mögliche Fehlermeldungen aus der error.log hier postest (i-Button im oberen Backend-Menü)

Es gibt nur ganz wenige Templates, die unter PHP 8.1 nicht laufen, die meisten hatten entweder viel früher schon Probleme, z.b. wegen der Umstellung von show_menu() auf show_menu2() oder es liegt an alten Modulen

Es ist auf jeden Fall nicht notwendig, ein Template auszusortieren oder gar umzubauen auf eine HTML-Page, wenn dieses Template mit WB 2.12.x und PHP 7.4.x gelaufen ist

Wichtig wäre zuerst, festzustellen, welche Module betroffen sind. Dazu schaut man sich über die Links in der Seitenübersicht die einzelnen Seiten im Frontend an. Nehmen wir an, du hast auf der Startseite schon einen Fehler und damit eine weiße Seite, dann schaut man, welche Sectionen sind dort eingebunden. Sie diese Sektionen Teil des WB-Paketes (z.b. News- oder Form-Modul) oder sind es extra Module ie Foldergallery, OneforAll usw.

Durch deaktivieren der einzelnen Sectionen lässt sich so genau bestimmen, welches Addon da in Frage kommt. Generell ist es von Vorteil, wenn alle Zusatz-Addons, also Module, die nicht zum WB-Paket gehören, erstmal upgedatet werden. Ist ein installiertes Modul nicht im modules-Ordner vorhanden, dann einfach hier mal nachfragen.

Und, wie gesagt, am Wichtigsten sind die PHP-Fehlermeldungen. Die sagen einem Fachmann am Schnellsten, wo das Problem liegt. Ich bin mir sicher, das sich die probleme auch kurzfristig lösen lassen, wenn entsprechende Informationen vorliegen.

Offline Herbert

  • Posts: 38
Re: Templatesuche, lauffähig unter PHP 8
« Reply #5 on: January 13, 2023, 04:50:42 PM »
Hallo, also im ErrorLog habe ich seit Monaten eine einzige Meldung, nämlich:
[12-Jan-2023 10:33:58 UTC] PHP Warning: Private methods cannot be final as they are never overridden by other classes in /mnt/web204/a0/05/51706105/htdocs/wb6/framework/class.database.php on line 63

Ich habe mir bewusste Datei mal angeschaut und in Zeile 63 steht:
 final private function __clone() {}
 (...alles mit dem bisherigen, lauffähigen Template...)

Wie ich eingangs schon sagte, habe ich keine Programmierkenntnis se in PHP und kann daher nicht beurteilen, was das bedeutet.

Und, bis heute laufen beide Homepages im "wahren Internet" unter der beim Provider noch eingestellten Version 7.4 ohne Makel, selbst das Template "Lounge", auf welches ich im Backend probeweise umgestellte hatte, macht keine Probleme bei der Anzeige meiner Homepage wenn ich diese Version testweise nter 7.4 veröffentliche.
Erst wenn ich beim Provider umschalte auf PHP 8, tritt der Effekt mit den leeren Seiten auf.
Ja soweit dazu

Offline sternchen8875

  • Posts: 97
Re: Templatesuche, lauffähig unter PHP 8
« Reply #6 on: January 13, 2023, 05:59:24 PM »
Auch, wenn ich jetzt nachplappere, was die Kollegen schon erwähnten hatten, die weiße Seite ohne irgendeine Ausgabe entsteht, wenn ein sog. fataler PHP-Fehler bereits beim Laden der Inhalte auftritt. Folge ist dann eben ein direkter Abbruch des Scriptes.
Offensichtlich ist PHP 7.4 mit dem verursachendem Code noch klar gekommen, neuere Versionen erlauben nun aber die Ausführung nicht mehr.
Die Fehlermeldung deutet auf ein Problem mit der Datenbankverbindung hin. Da die Module des jeweiligen WB-Paketes auch immer auf die angesagte PHP-version geprüft sind, tippe ich auf ein Nicht-Standard-Modul oder Dropletcode. Ich vermute ein $database = new database(); irgendwo.

Ich bin nicht sicher, ob wir hier weiterkommen ohne Hilfe von außen. Vielleicht kannst du einer Person deines Vertrauens Zugang zum Adminbereich, per FTP und ggf zur Datenbank gewähren, sonst wird das eine langwidrige Geschichte, denk ich

Offline Herbert

  • Posts: 38
Re: Templatesuche, lauffähig unter PHP 8
« Reply #7 on: January 13, 2023, 06:43:51 PM »
Ich bins schon wieder
ich war mal auf der Downloadseite von WebsiteBaker. Da werden mir einige Versionen angeboten, Version 2.13.1 R133 und 2.13.1 R103 sowie eine unzip-Version 2.20.
Bei allem steht aber, dass die unter PHP 7.4 nicht mehr laufen.

Selbst wenn mir der Upload einer Variante gelingt, ich würde auf jeden Fall die eine wichtige Homepage tot legen, wenn ich beim Hoster dann nach hoffentlich erfolgreicher Installation der neuenWB- Version umstelle auf PHP 8;
Zurückkehren zur alten Version kann ich ja dann wohl nicht mehr.....

Nochmals die Frage, steht bei der verschiedenen Versionen irgendeine Beschreibung, was ich genau machen muß, wenn ich die neue Version hochlade?
Sorry, bestimmt DAU-Fragen
danke nochmals für Eure Hinweise

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8463
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Templatesuche, lauffähig unter PHP 8
« Reply #8 on: January 13, 2023, 09:05:23 PM »
Hallo,

den Download der aktuellen Verion 2.13.3(r166), der auch hier im Forum rechts oben verlinkt ist, findest du hier:

https://wiki.WebsiteBaker.org/doku.php/downloads

Kurzanleitung zum Update:
- komplettes Paket herunterladen.
- unzip.php.zip herunterladen
- unzip.php.zip in unzip.php umbenennen
- unzip.php und komplettes Paket auf den Serverladen
- www.deinedomäne.de/unzip.php aufrufen
- nachdem die unzip.php das Paket entpackt hat als admin im Backend anmelden und das upgradescript aufrufen

Wichtig!!! Die Umstellung auf PHP 8 muss vor dem Upggrade erfolgen, sonst läuft das upgrade nicht.

Solltest du nach dem Upgrade immer noch eine weiße Seite haben, stelle im Backend das Template auf das DefaultTemplate um. Damit sollte deine Seite auf jeden Fall laufen, halt in einem anderen Design.

Um Herauszufinden, was an dem Template mit der weißen Seite nicht passt, müsstest du es entweder zur Verfügung stellen oder uns einen Backendzugang zu deiner Seite geben. Zugangsdaten bitte aber nur als PM und nicht hier im Forum öffentlich posten.

Matthias

Offline sternchen8875

  • Posts: 97
Re: Templatesuche, lauffähig unter PHP 8
« Reply #9 on: January 14, 2023, 01:57:33 AM »
Fangen wir mit dem Wichtigsten an:
eine Version WB 2.12.2 R 367 läuft nicht mit PHP 8.0.x, du benötigst mindestens eine 13er Version. Die empfehlung geht zur neuesten Version WB 2.13.3 R 166, wie von ruebenwurzel erwähnt und verlinkt, sonst fängst du im nächsten Herbst wieder an

Versucht habe ich es dann mit dem Template "Lounge-Responsive", welches ich hier von Angeboten von "WebsiteBaker" runtergeladen hatte

hab den Test mal gemacht und dieses Template installiert. Bis auf die für den Autor typisch fehlende Definition der Template-Funktion in der info.php
Code: [Select]
$template_function      = 'template';läuft dieses Template problemlos unter PHP 8.1.9

Wurde das Template also nicht noch umgebaut, kann man damit schon mal testen (aber das wäre mit dem DefaultTemplate ja auch gegangen)
Von meiner Seite schließe ich das Template "Lounge-Responsive" oder "DefaultTemplate" aus

Quote from: Herbert
ich war mal auf der Downloadseite von WebsiteBaker. Da werden mir einige Versionen angeboten, Version 2.13.1 R133 und 2.13.1 R103 sowie eine unzip-Version 2.20.
Bei allem steht aber, dass die unter PHP 7.4 nicht mehr laufen.

das steht dort nicht. Es steht da:
Quote
Note: PHP Version less then 7.4 are outdated and no longer run with this version!

auf deutsch
Quote
Hinweis: PHP-Versionen kleiner als 7.4 sind veraltet und laufen mit dieser Version nicht mehr!

Eine weitere Downloadquelle wäre der Addonbereich -> https://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?type=5

Die Fehlermeldung deutet auf ein Problem mit der Datenbankverbindung hin. Da die Module des jeweiligen WB-Paketes auch immer auf die angesagte PHP-version geprüft sind, tippe ich auf ein Nicht-Standard-Modul oder Dropletcode. Ich vermute ein $database = new database(); irgendwo.

Meine Vermutung war nur begrenzt richtig. Die alte WB-Version WB 2.12.2 baut unter PHP 8.x erst garkeine Datenbankverbindung auf. Damit kommt das Script garnicht erst bis zum Auslesen der Inhalte

Offline hgs

  • Betatester
  • **
  • Posts: 1687
    • EFG MG
Re: Templatesuche, lauffähig unter PHP 8
« Reply #10 on: January 14, 2023, 08:16:25 AM »
Um ein Update auf die aktuelle Version wird du nicht herumkommen.
Hier mal ein kleines Video, wie "einfach" es geht.
Video ist schon was älter, deshalb sind die Aussage zu den php-Versionen nicht mehr aktuell. ;D

Es muß!! mindestens php 8.0 sein.
Viel Erfolg
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline Herbert

  • Posts: 38
Re: Templatesuche, lauffähig unter PHP 8
« Reply #11 on: January 14, 2023, 09:20:48 AM »
Guten Morgen,
nochmals Danke für die Tipps.
Werde das bis morgen in Angriff nehmen und melde mich dann nochmals, ob alles geklappt hat.
Mit besten Grüßen

Offline Herbert

  • Posts: 38
Re: Templatesuche, lauffähig unter PHP 8
« Reply #12 on: January 14, 2023, 08:06:21 PM »
Ein freundliches Hallo an dieser Stelle nochmals.
dank Eurer Hinweise und der ToDo-Anleitung für das Update von Rübenwurzel hat alles geklappt. Meine Homepage läuft jetzt unter php8 und WB-Version 2.13....
Danke  :-) :-) :-)

 

postern-length