Author Topic: Bookings module for WB 2.12.2  (Read 507 times)

Offline svsanchez

  • Posts: 562
Bookings module for WB 2.12.2
« on: January 20, 2021, 03:29:48 AM »
Hello!

I have to update a site from WB 2.8.3 to 2.12.2 which is using the Bookings plugin (https://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?id=0811A32).

Has anyone tested this plugin on 2.12.2 with php 7.3 or higher?

Offline hgs

  • Betatester
  • **
  • Posts: 1396
    • EFG MG
Re: Bookings module for WB 2.12.2
« Reply #1 on: January 20, 2021, 08:01:30 AM »
I will build a website for testing purposes, what exactly is the problem?
I will start with WB 2.8.3 php 5.6 and then update to WB 2.12.2 php7.3.


I write about DeepL.com
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Bookings module for WB 2.12.2
« Reply #2 on: January 20, 2021, 09:07:13 AM »
Hi, you can try this version.
Works with WB 2.13 and PHP 7.4.
Not tested to install, maybe some fixes are needed. Upgrade should work.
Save your css changes! The backend view is horrable but works. Also here some changes needed.
But for testing it is good enough.

@Harald: please test also this version.
« Last Edit: January 20, 2021, 11:55:56 PM by dbs »

Offline svsanchez

  • Posts: 562
Re: Bookings module for WB 2.12.2
« Reply #3 on: January 20, 2021, 06:23:03 PM »
Hello you two!

Thanks a lot, hopefully it works. This site also uses Foldergallery so I am waiting a little bit to upgrade to 2.12.2 until I know how to fix the problem with it.

Would installing the Bookings plugin that I have on an already upgraded WB break the site just to see if it works with PHP 7.4?

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Bookings module for WB 2.12.2
« Reply #4 on: January 21, 2021, 12:03:58 AM »
I saw there was a newer version 2.41 from Blackbird.
With a little change in upgrade.php it works in WB.

You should never testing, updating modules or upgrading WB on the live site.
This have to be done in a test environment (e.g. a copie of your live site in a subdomain or in the WB Portable).
Ever. And in this case you not need the question for break or similar.

Offline hgs

  • Betatester
  • **
  • Posts: 1396
    • EFG MG
Re: Bookings module for WB 2.12.2
« Reply #5 on: January 21, 2021, 06:16:20 AM »
Have successfully tested the version of dbs with WB 2.12.2 and php 7.3 via update.

Same in the new WB 2.13 with php 7.4
Good Job (Y)
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline svsanchez

  • Posts: 562
Re: Bookings module for WB 2.12.2
« Reply #6 on: January 21, 2021, 07:25:38 AM »
Hello both of you, thanks for your replies.

I know how to create a subdomain on my webhost, but I don't know how to "duplicate" my site and place it on the subdomain. Specifically, I think I wouldn't have a problem copying the files into the subdomain, but I have no idea how to duplicate the DB.

I would greatly appreciate if you could point me to instructions for creating a duplicate of my site on a subdomain!


Offline svsanchez

  • Posts: 562
Re: Bookings module for WB 2.12.2
« Reply #7 on: January 21, 2021, 07:30:37 AM »
Have successfully tested the version of dbs with WB 2.12.2 and php 7.3 via update.

Same in the new WB 2.13 with php 7.4
Good Job (Y)

Hgs:

I understand by what you say that the Bookings plugin will only work on WB 2.12.2 with php 7.3, and will NOT work with php 7.4.

My webhost is about to remove php versions up tp 7.3 from my server, so I need to work with php version 7.4. Do you know if the mpform and foldergallery plugins will work on WB 2.13? This particular site that I have to upgrade uses the 3 plugins (Bookings, mpforms and foldergallery)

Offline hgs

  • Betatester
  • **
  • Posts: 1396
    • EFG MG
Re: Bookings module for WB 2.12.2
« Reply #8 on: January 21, 2021, 08:12:23 AM »
Ok, the translation by deepl.com seems to have translated something wrong.
The version of dbs also works with the latest WB 2.13 and php 7.4.

For this new version of WebsiteBaker there is also a working foldergallery.
Here is the link to a test page with all modules, but some of them are not yet php 7.4 ready. So don't be surprised that there are pages that don't work.
But the foldergallery , booking and mpform are also installed here and it works.
https://aktuell.umojasingers.de/de/module-aus-dem-addon/foldergallery/ (Foldergallery Version 3.4.0-dev2)
https://aktuell.umojasingers.de/de/module-aus-dem-addon/booking/ (Bookings Version 2.41.1)
https://aktuell.umojasingers.de/de/module-aus-dem-addon/mpform/ (mpForm Version 1.3.36)
The modules are not yet public, because they run partly only with WB 2.13
The links to the modules we can send by pm if it is wanted.

For testing it would be easiest to use the USB version of WebsiteBaker.
Here is the link:
https://portable.WebsiteBaker.org/en/about-portable-edition.php

Translated with www.DeepL.com/Translator (free version)
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline svsanchez

  • Posts: 562
Re: Bookings module for WB 2.12.2
« Reply #9 on: January 21, 2021, 09:25:59 AM »
Hello hgs, that's great news! Yes please, send me the links to the modules Foldergallery 3.4.0-dev2!

I already downloaded the Bookings 2.41.1 from dbs.

Can you also point me to the instructions for upgrading from WB 2.12.2 to WB 2.13 please!

Thank you...

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Bookings module for WB 2.12.2
« Reply #10 on: January 21, 2021, 09:52:47 AM »
The upgrade instruction are all the same like described here:
https://forum.WebsiteBaker.org/index.php/topic,31528.0.html

quote:
- make a backup of all files and the database (!important)

 +Recommanded way: (fast & safe)
 - download WB ZIP package & unzip.php.zip
 - rename unzip.php.zip to unzip.php
 - upload WB ZIP package & unzip.php to your WB root folder (where the config.php is located)
 - run unzip.php in your browser (https://yourdomain.com/unzip.php) (please replace yourdomain.com with your own domain)
 - login in your backend as Super-Admin (admin with id 1) and run upgrade-script via upgrade link or via wb-info panel (i-button)

The unzip.php and the WB ZIP delete themselves (if it is checked in the unzip script) after the successful execution of the unzip.php.

 +Alternative way: (slow & oldscool)
 - download WB ZIP package & unpack
 - upload via FTP (overwrite existing files!)
 - login as Super-Admin (ID 1)
 - start upgrade script

Offline hgs

  • Betatester
  • **
  • Posts: 1396
    • EFG MG
Re: Bookings module for WB 2.12.2
« Reply #11 on: January 21, 2021, 10:21:38 AM »
Here is the module as an attachment, but please note that it is still your development version. So it is still being worked on. But it all works.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline svsanchez

  • Posts: 562
Re: Bookings module for WB 2.12.2
« Reply #12 on: January 28, 2021, 07:36:58 AM »
Hello hgs and dbs, I finally decided to do this update to 2.13.0 and everything worked perfectly.

Foldergallery 3.4 .0-dev1 still required me to uninstall and reinstall to make the galleries work.

Thanks a lot!!! (Y) (Y) (Y)