Author Topic: Server move / upgrade problem  (Read 258 times)

Offline svsanchez

  • Posts: 562
Server move / upgrade problem
« on: December 04, 2020, 06:28:33 PM »
Hello!

I am in the process of moving / upgrading several sites to a new server. Most of the sites are 2.8.3 SP1 and I have been able to upgrade most of them to SP6 prior to jumping to 2.12.x

However, one of the sites has a problem with the FolderGallery. When I moved the site to the new server, the FolderGallery (Version 1.36) didn't load. I upgraded the site to SP6 and this made no difference. Only the WYSIWYG contents appeared, and then the pages were "cut" where the FolderGallery should have appeared. I upgraded FolderGallery to Version 1.38, and this made things worse: now the pages appear TOTALLY BLANK.

Here is a link to a page WITHOUT the FolderGallery module in it, which works:

https://fotos.deguate.net/mujeres/chapinas.php

And here is a link to a page WITH the FolderGallery module in it, which appears totally blank (even if you check the source of the page, it's blank):

https://fotos.deguate.net/mujeres/chapinas/aida-estrada.php

All the content and pictures IS available in the backend.

What could be wrong?

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Server move / upgrade problem
« Reply #1 on: December 04, 2020, 06:40:37 PM »
Hi, you should go from 2.8.3 to 2.12.2.
And then load the latest FG version from the addons repo.

Offline svsanchez

  • Posts: 562
Re: Server move / upgrade problem
« Reply #2 on: December 05, 2020, 05:10:57 AM »
Thank you dbs, I have upgraded to 2.12.2, now I'm having a few problems:

1) I'm not being able to upgrade to the latest FolderGallery version (or any other version), I get the following message:

  [170] It is not possible to upgrade or install from a WebsiteBaker Versions before 2.12.1

2) The backend is horribly slow. I get this problem on every medium / big site which has kept me away from versions > 2.10, but I forgot about it and upgraded this one. Fortunately the frontend doesn't seem to be slow as has been the case with bigger sites.

Offline dbs

  • Betatester
  • **
  • Posts: 8624
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Server move / upgrade problem
« Reply #3 on: December 06, 2020, 09:49:25 AM »
Hi, if a FG upgrade is not possible from the very old version, deinstall the old one and install the new one.
It can be a problem if the images have titles and descriptions. They lose them after deinstalling.
Or look into info.php of old FG. Plattform should not be 2.80, replace with 2.8.0. and try again upgrade.

The slow backend we (myself) had fixed this. I hope you had made a backup before upgrading.