Author Topic: Problem when upgrading to PHP 7.3  (Read 1118 times)

Offline tobyw7

  • Posts: 60
  • Gender: Male
    • Toby White
Problem when upgrading to PHP 7.3
« on: July 06, 2020, 11:45:22 AM »
I have a problem with my webhost server, hosted by HostGator, where the mysqli module doesn't appear to be installed.
I get the following error;

There was an uncatched exception
Call to undefined function mysqli_connect()
in line (109) of (/framework/class.database.php):


They are looking to install or fix the module as it's a problem with the server.

The question I have is I can load other pages of the website directly by their explicit URL eg. https://www.frantik-web.co.uk/pages/hosting.php but the index.php doesn't load, presumably because the database connect request is called?

Is there a workaround to get this working?

Offline hgs

  • Betatester
  • **
  • Posts: 1276
    • EFG MG
Re: Problem when upgrading to PHP 7.3
« Reply #1 on: July 06, 2020, 12:37:07 PM »
You still coming to the Backend?

Which version of WebsiteBaker is installed?

What does the config.php look like? Please mask the access data
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline dbs

  • Betatester
  • **
  • Posts: 8399
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Problem when upgrading to PHP 7.3
« Reply #2 on: July 06, 2020, 12:44:46 PM »

Offline tobyw7

  • Posts: 60
  • Gender: Male
    • Toby White
Re: Problem when upgrading to PHP 7.3
« Reply #3 on: July 06, 2020, 10:03:58 PM »
You still coming to the Backend?

Which version of WebsiteBaker is installed?

What does the config.php look like? Please mask the access data

Yes, logging into the backend works fine still.

I'm using version 2.12.1, have tried the upgrade to 2.12.2 but the unzip.php failed and the upgrade.php won't run so this is looking more like a PHP problem?

The config looks like so ;

<?php
/*
 *** auto generated config file for 2.12.2
 ****[WebsiteBaker]****
 *** created at 2020-07-06 02:56:55 America/Chicago
 */
// define('DEBUG', false);
define('DB_TYPE',         'mysql');
define('DB_HOST',         'localhost');
define('DB_PORT',         '3306');
define('DB_NAME',         '*********');
define('DB_USERNAME',     '********');
define('DB_PASSWORD',     '********');
define('DB_CHARSET',      'utf8_unicode_ci');
define('TABLE_PREFIX',    '');

define('WB_URL',          'https://frantik-web.co.uk'); // no trailing slash or backslash!!
define('ADMIN_DIRECTORY', 'admin'); // no leading/trailing slash or backslash!! A simple directory name only!!

require __DIR__.'/framework/initialize.php';
// --- end of file ----------------------------------


Hi, please take a look:
https://forum.WebsiteBaker.org/index.php/topic,31729.msg222070.html#msg222070
Maybe it helps.

I actually found this when searching. It fixed another problem I had but not this one. I also had to # out the old entries in the .htaccess file for older versions of PHP.
HostGator had switched from using PHP Selector tool in CPanel to MultiPHP Manager.

Offline tobyw7

  • Posts: 60
  • Gender: Male
    • Toby White
Re: Problem when upgrading to PHP 7.3
« Reply #4 on: July 06, 2020, 10:36:49 PM »
Okay just to update here this was a problem on the host server and the PHP installation which had not completed successfully and prevented the PHP modules for loading. One of these is the mysqli module. HG have now run the PHP install again and the site is now loading.

Everything is now loading correctly and I have upgraded the site to 2.12.2 :)

Offline dbs

  • Betatester
  • **
  • Posts: 8399
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Problem when upgrading to PHP 7.3
« Reply #5 on: July 06, 2020, 11:27:28 PM »
Thanks for info and have fun with WB  :)

 

postern-length