Author Topic: WB Administrator Page editor fails with <textarea>  (Read 223 times)

Offline richwingerter

  • Posts: 60
WB Administrator Page editor fails with <textarea>
« on: February 03, 2020, 01:14:40 AM »
I am using Google Chrome (Version 79.0.3945.130 (Official Build) (64-bit)) on Windows 10 and I have this issue with a code page (Code v3.0.5). The following code doesn't work when I try to edit it with WebsiteBaker Administrator:

Code: [Select]
echo '<div>';
echo '
    <div>
        <textarea id="eed-event-notes" cols="60" rows="5"></textarea>
    </div>';
echo '</div>';

When I put this in the editor in an existing page, it shows:

Code: [Select]
'; echo '
';

after the editor window.

That is, in the Pages tab under Modify or Delete Pages, I click the link for an existing page. On the Modify Page, I paste this into the window and click the Save button. The echo command appears above the Save and the Save & Back buttons.

If I change the <textarea> tag to <input>, then the page works normally.

Does anyone know what's causing this? Is there a way to fix it?

Offline dbs

  • Betatester
  • **
  • Posts: 8402
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: WB Administrator Page editor fails with <textarea>
« Reply #1 on: February 03, 2020, 07:57:21 AM »
Hi, you have a problem with code and textarea?
First, use this words with the forum search (next time).

Second search result is this:
https://forum.WebsiteBaker.org/index.php/topic,31553.msg221440.html#msg221440
Change </textarea> to
Code: [Select]
</text'.'area>