Author Topic: Fehlermeldung bei Update  (Read 527 times)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Fehlermeldung bei Update
« on: June 29, 2019, 12:35:30 PM »
Hallo,

nach Update auf 2.12.2 Rev. 378 hab ich im Errror Log folgende Meldung:

 
Code: [Select]
[E_WARNING] /framework/class.database.php:[152] from /modules/news/upgrade.php:[154] database->get_one "mysqli_fetch_array() expects parameter 1 to be mysqli_result, bool given"
Matthias

Offline hgs

  • Betatester
  • **
  • Posts: 1116
    • EFG MG
Re: Fehlermeldung bei Update
« Reply #1 on: June 29, 2019, 01:18:34 PM »
Hi Matthias
Von welcher Version hast du das upgrade mit welcherphp Version?

LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4368
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: Fehlermeldung bei Update
« Reply #2 on: June 29, 2019, 01:46:35 PM »
kann den Fehler nicht reproduzieren. Wenn die  mod_news_layouts vorhanden ist, diese löschen, anschliessend manuelles news upgrade, das sollte die Standard-Layouts wieder herstellen. Bin gespannt ob der Fehler dann immer noch auftritt.

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline hgs

  • Betatester
  • **
  • Posts: 1116
    • EFG MG
Re: Fehlermeldung bei Update
« Reply #3 on: June 29, 2019, 01:56:28 PM »
Hab gerade mal eine WB 2.12.1 rev 188 mit php 7.2 auf WB 2.12.2 rev 378 gebracht, sehr "große Seite mit allen Modulen aus dem addOn.
Der ErrorLog bleibt leer.
Hoffen wir, dass der Tipp von Dietmar hilft.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: Fehlermeldung bei Update
« Reply #4 on: June 29, 2019, 03:07:57 PM »
Hallo,

- upgrade war von WB 2.12.2 Rev. 377 auf WB 2.12.2 Rev. 378.
- PHP Version ist 7.3

- nochmaliges hochladen aller Dateien des News-Moduls, nach vorherigem löschen aller Dateien auf dem Server brachte keinen Erfolg.
- manuelles ausführen des Upgrades des News-Moduls brachte auch keinen Erfolg

Ursache:
Ursache der Meldung im Error_log war die fehlende Tabelle mod_news_layouts in der Datenbank.

Lösung:
Das manuelle Ausführen des Installatonsscripte s des News Moduls legt diese Tabelle wieder an. Danach taucht die Fehlermeldung nicht mehr auf.

Das manuelle Ausführen des Installationsscript es ist nur auf Installationen möglich, auf denen noch keine News angelegt sind. Dort wo News existieren werden diese durch die Neuinstallation des News-Moduls gelöscht. Vielleicht kann man einen kleinen Reparaturscript anlegen, der nur diese Tabelle nachträglich anlegt.

Problem tauchte nur bei einer einzigen von einer Vielzahl von Installationen auf. Kann also gut sein, dass gerade bei dieser Installation bei einem früheren Upgrade bereits was schiefgelaufen ist, kann das aber nicht mehr rekonstruieren.

Danke auf jeden Fall für die schnelle Reaktion und die Anregungen, die zwar nicht die Lösung waren, mich aber auf die richtige Fährte gebracht haben.

Matthias

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4368
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: Fehlermeldung bei Update
« Reply #5 on: June 29, 2019, 03:36:05 PM »
Quote
Problem tauchte nur bei einer einzigen von einer Vielzahl von Installationen auf. Kann also gut sein, dass gerade bei dieser Installation bei einem früheren Upgrade bereits was schiefgelaufen ist, kann das aber nicht mehr rekonstruieren.

Vermute ich auch. Werde es beobachten und gegebenfalls reagieren. Ausser der Änderung im CKEditor ist die REV378 eigentlich die getestete REV 377

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung