Author Topic: Old version (2.6.7) - can't login in admin with valid credentials  (Read 465 times)

Offline devil666

  • Posts: 6
  • Gender: Male
Hello community,

I'm running a very old version (2.6.7) of WebsiteBaker. Yesterday I login in to the admin, but almost immediately I was logged out. After that I was not able to login again anymore. Following the instructions in this topic I have managed to change email (the old one was abandoned years ago) via phpMyAdmin. So I request (and received) new password. The problem is that, even with it, I still can login. I also tried to change the password (MD5 encoded) directly in PhpMyAdmin (as described in topic above) and than login, but still no success. Regarding the server - current version of PHP is 7.2.14 - can't this be the problem? If yes - to which version should I switch PHP back to?

Please advice what should I do?

Offline dbs

  • Betatester
  • **
  • Posts: 8008
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #1 on: March 21, 2019, 11:05:05 AM »
Hi and yes, the very old WB can't used with newer PHP versions.
Go down to PHP 5.6 and pray. I think PHP 5.4 you can't choose.

Offline devil666

  • Posts: 6
  • Gender: Male
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #2 on: March 21, 2019, 11:25:50 AM »
Hi and yes, the very old WB can't used with newer PHP versions.
Go down to PHP 5.6 and pray. I think PHP 5.4 you can't choose.
Hello,

Thank you for reply. So I checked first with 5.6, than with 5.4 but unfortunately there was no change - I still can't login.

Offline jacobi22

  • Posts: 5863
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #3 on: March 21, 2019, 12:48:48 PM »
alternative solutions (need some experients..)

1. Use a older version of locale and portable servers like WBPortable, UWamp etc with a older PHP-Version (max PHP 5.4)
build there a copy of the old page
then install the latest wb-version somewhere in a subfolder from the server and rebuild this project from the beginn, add a page like the old project and use Copy&Paste to bring the content from the old to the new project
i know, it's only good, if you have a small project

2. my method:
i install a fresh, latest wb-version and copy the insert's from the pages modules into the new, empty database. but this works not in every case, sometime, i have to change the field structure or the inserts. After all, i start the WB-Upgrade-Script
This method needs a lot of experience in the work with phpmyadmin, mysql and WB

3. last way-out
make a zip from all files and folders and a database-backup an put it somewhere on your server to download for me and i'll do that for you and send you the same file back (or build a download). Than you have only to clear the WB-own-folders on the webspace and the database and copy my work to this place
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline evaki

  • Posts: 2701
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #4 on: March 21, 2019, 08:39:36 PM »
Habe im Moment leider kein Zeitfenster für die Übersetzung.

Lokale Installation

Test WB v2.6.7 mit php v5.3.27 und MySQL v5.1.62 unter Win7

Vor Beginn der Installation 2 Dateien ändern.
install\save.php
alt:
if(eregi("^([0-9a-zA-Z]+[-._+&])*[0-9a-zA-Z]+@([-0-9a-zA-Z]+[.])+[a-zA-Z]{2,6}$", $_POST['admin_email'])) {
neu:
if(preg_match("/^([0-9a-zA-Z]+[-._+&])*[0-9a-zA-Z]+@([-0-9a-zA-Z]+[.])+[a-zA-Z]{2,6}$/i", $_POST['admin_email'])) {


framework\initialize.php
set_magic_quotes_ru ntime(0);
neu:
////   set_magic_quotes_ru ntime(0);

Ohne diese Korrektur müßte er noch 'ne 4er-PHP-Version instaliieren.
Hab ich zwar vorliegen, aber das kann ich mir momentan nicht antun (liege flach)
Außerdem ist es für die Upgrades günstiger >5.6>7.2

Offline jacobi22

  • Posts: 5863
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #5 on: March 22, 2019, 03:22:12 PM »
mir sträuben sich die Nackenhaare, wenn hier Fixes für einen 2.6.7-Install zu finden ist, wir sind schon 10 Jahre weiter

@ Derek: i send you the download-link for the updated package, see more instruction in my email. i'm back at home in the evening, but i see it in the source-code of your domain

P.S: tested with latest WB-Version and PHP 7.3.2
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline evaki

  • Posts: 2701
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #6 on: March 22, 2019, 04:03:42 PM »
Quote
(max PHP 5.4)
Da wollt ich doch nicht hinterm Berg halten. Wer weiß was noch kommt.  :roll:
Jedenfalls funktioniert's, falls es jemand braucht.
Netscape 2.2 funktioniert hier auch  :evil: ,
auch  WfW 3.11, anscheinend alles in VM.
Und noch älter sehe ich gerade, irgendwas aus Compuserve-Zeiten (vor AOL).
Da waren wir in DE auch schon Vorreiter - mit BTX ::GRÖHL:: Weltmeister

MfG. Evaki
« Last Edit: March 22, 2019, 04:14:41 PM by evaki »

Offline jacobi22

  • Posts: 5863
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Old version (2.6.7) - can't login in admin with valid credentials
« Reply #7 on: March 26, 2019, 11:42:27 PM »
@ Derek:  no answer, no reaction - i hope, everything is good and you're okay?
Pls send a short replay here or via email
Wer nicht will, findet Gründe, wer will, findet Wege.