Author Topic: ugradee von 2.8.3 - stell mich dumm an  (Read 2788 times)

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #50 on: February 23, 2019, 01:51:11 PM »
Hallo Jacobi!

Ich find die Zwangswarterei zwecks künstlerischem Minimalismus auch irgendwie verquer.

Block sichtbar machen nach n sec ist wohl auch eine Möglichkeit.

:-)

Offline jacobi22

  • Posts: 5891
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #51 on: February 23, 2019, 03:02:29 PM »
Am Ende gibt es da jemanden, der als Auftraggeber fungiert, von daher sollte man sich vielleicht keine Gedanken drum machen  :wink:

10 Sekunden ist aber wirklich etwas viel. Ich habe, sicher auch aus Unwissenheit über die Umschaltung, nie gewartet, sondern mittig aufs Bild geklickt. Ich denke, das machen auch 99% der Besucher so - einzige Ausnahme wohl die Kundin selbst  :-D
Also vielleicht mal mit 3 oder max 5 Sekunden Wartezeit probieren

Für's FadeIn gibt es dann auch noch andere Effekte als das aktuelle slow, fadeIn(2000) zieht es z.b. auf 2 Sec hin, fadeTo("slow", 0.7); zeigt den Block mit einer Transparenz von 0.7 usw, Schau dir die Try It Beispiele hier an, vielleicht ist was nettes dabei, das der Dame gefällt
https://www.w3schools.com/jquery/jquery_fade.asp
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #52 on: February 24, 2019, 01:35:32 PM »
Hi!

Es waren ursprünglich 3 Sekunden, zwecks Testen des Problems hab ich das auf 10 verlängert um das genauer verfolgen zu können, also daß die richtige Seite (bei mir) mit dem falschen Template aufgeht.

Eh seltsam. Manche Installationen (noch 2.8.3) funktionieren nach Umstellung auf php 7.2 noch auf Anhieb, bei anderen
sind gerade bei einfachen Templates (round / all CSS / Uboot) die Menüs weg. Das ist gerade mein Hauptproblem. Die Zeit überbrücken ohne daß die Kunden nörgeln.


:-)
« Last Edit: February 24, 2019, 01:50:56 PM by gottfried »

Offline ruebenwurzel

  • Betatester
  • **
  • Posts: 8391
  • Gender: Male
  • Keep on Rockin
    • Familie Gallas Online
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #53 on: February 25, 2019, 06:11:59 AM »
Quote
...sind gerade bei einfachen Templates (round / all CSS / Uboot) die Menüs weg...

showmenu durch showmenu2 ersetzen :-D

Matthias

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #54 on: February 25, 2019, 06:51:05 PM »
Hallo Mathias!

Nö -sind showmenu2. Simple taugt aber u.U als Brückenlösung falls der Kunde schmollend abzuwarten geruht.

 :-)


Offline jacobi22

  • Posts: 5891
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #55 on: February 25, 2019, 07:32:00 PM »
dafür gibt es ein Forum und ein paar Leute, die da rumlungern  ;-)  :-D

Am Showmenu2 hat sich nicht allzuviel geändert, im Idealfall bitte den Code posten, der nicht funktioniert und den groben Seitenaufbau dazu, mit MenuLink vorweg oder nicht, usw.
Und nicht vergessen: eine möglicherweise vorhandene Intro-Seite muß nach wie vor von Hand eingetragen werden
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #56 on: February 25, 2019, 07:42:02 PM »
Hi!

Ich meinte mit "Simple" funktioniert die Seite ja unter 2.8.3 mit php 7.2 . Sieht nur nicht so doll aus wie uboot
Ist also nicht dringlich.

Ich will ja in den nächsten Tagen umstellen.

Danke!  :-D


Offline evaki

  • Posts: 2786
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #57 on: February 25, 2019, 08:24:18 PM »
Uboot
Code: [Select]
Install.:
WebsiteBaker Error log
"created: [Mon, 25 Feb 2019 19:18:18 +0000]
Mon, 25 Feb 2019 19:19:37 +0000 [E_USER_NOTICE] \admin\templates\install.php:[168] from \admin\templates\install.php:[168] trigger_error "Missing Template-Parameter [$template_function] in uboot/info.php!""
====================
Template:  Uboot als default gesetzt
Aufruf im Frontend:
"created: [Mon, 25 Feb 2019 19:21:09 +0000]
[25-Feb-2019 19:22:57 UTC] show_menu2 error: $aOptions is invalid. No flags supplied!"

MfG. Evaki

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #58 on: February 25, 2019, 08:41:55 PM »
Hi!

Hört sich an wie Chio der Inquisition unterziehen zu müssen.


 :-)

Offline evaki

  • Posts: 2786
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #59 on: February 25, 2019, 09:04:56 PM »
Probier mal den Anhang
 (ohne Gewehr: Peng / auffe Schnelle)
Falls Menü "noch nicht stimmt", z.B. jacobi22 fragen  :-D
Der hat sowas "im Kopf".

Die Frage, die sich mir beim Lesen der Lizenz noch stellt, ist" Darf man das hier korrigiert reinstellen?
Quote
3. Das Anbieten des Template auf anderen Seiten, zum Download, ist nicht erwünscht. Sie können jedoch einen Link zum Download auf www.WebsiteBaker.at setzen.

Frag mal den Author, damit gegebenenfalls der Anhang wieder gelöscht wird (vom Forenboss)
« Last Edit: February 25, 2019, 09:12:01 PM by evaki »

Offline jacobi22

  • Posts: 5891
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #60 on: February 26, 2019, 01:29:06 AM »
siehe auch hier -> https://forum.WebsiteBaker.org/index.php/topic,31341.msg218760/topicseen.html#msg218760

Quote
Hört sich an wie Chio der Inquisition unterziehen zu müssen.

es gibt Sachen, die waren immer schon vorgegeben, z.b. der Pflichtparameter aus Group1 im show_menu2

Auszug aus einer readme zum show_menu2 von 2010!!!
Quote
    GROUP 1
    -------
    Aus dieser Gruppe muss stets genau ein Flag angegeben werden. Diese Flags
    bestimmen auf welche Weise die Geschwisterelemente im Menübaum in der
    Ausgabe unterdrückt werden.

und auch das angemeckerte $template_function - steht bestimmt seit 10 Jahren in den Richtlinien, die die Urväter/-mütter hier mal festgelegt hatten.
An Hand dieser Definition unterscheiden sich ein Backend-Theme ($template_function = 'theme') und ein Frontend-Template ($template_function  = 'template') z.B in der Auswahl unter WB-Optionen usw. Die Themes werden aber nur nach deren Definition abgefragt, also 'theme', darum ist das bisher nicht aufgefallen. Seit WB 2.11 oder so wird aber auch auf 'template' gecheckt
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #61 on: March 02, 2019, 03:03:31 PM »
Hallo!  :-(

Ich hab nun besagte website, die auf 2.8.3 und php7.2 mit template "Simple" eigentlich ganz gut funktioniert nach Anleitung oben auf den aktuellen wb hochziehen wollen.

(Die Umsetzung einer anderen Installation hatte eigentlich schon ganz gut funktioniert und ist im Einsatz)

Wenn ich im aktuellen Fall nun den adminbereich aufrufen will, kommt das login und sonst nichts.
angeblich immer wieder falsch Zugangsdaten.

wenn ich url/upgrade-script.php aufrufe, sagt mir das, das ein config.php erfolgreich von 2.8.3 auf 2.12.x erstellt wurde
und ich z.B F5 drücken soll.

Dann kommt diese Meldung im Browser:

Quote
There was an uncatched exception
missing template file maintenance.htt
in line (771) of (/framework/class.wb.php):

und dann immer wieder.

im Frontend von http://firmlinge2.channel-1.de/ erscheint die Meldung

Menü:There was an uncatched exception
Call to undefined function show_menu()
in line (75) of (/templates/simple/index.php):

Ich hab den Upgrade paarmal wiederholt. mit uboot als showmenu2 kam beim ersten mal keine Fehlermeldung dafür aber alle Seiten in einem Handtuch untereinander.

Die Dateien sind aber wirklich alle an dem Platz an dem Sie seien sollten (z.B maintenance.htt)

ich vermute nun unprofessionel, daß der domainname da einen Einfluß haben könnte, wegen Bindestrich?

 :roll:


Offline dbs

  • Betatester
  • **
  • Posts: 8076
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #62 on: March 02, 2019, 04:30:26 PM »
Du musst dir immer sicher sein, dass wirklich alle Dateien übertragen und die alten Dateien überschrieben wurden.

Quote
Call to undefined function show_menu()
Wurde weiter oben schon mal erwähnt, gegen show_menu2() tauschen.

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #63 on: March 03, 2019, 03:28:07 PM »
Hallo DBS

Quote
Du musst dir immer sicher sein, dass wirklich alle Dateien übertragen und die alten Dateien überschrieben wurden.

Ich bin mir da ganz sicher und hab die page zum ca 4.Mal Male von der funktionierenden 2.8.3 mit 7.2 Version mit Filezilla heruntergeladen, nach Beschreibung auf 2.12.1 geändert und wiederholt hochgeladen / überschrieben /neue verzeichnisse.

Ich komme aber trotzden micht in's Backend und das upgrade-script.php sagt mir (beim 2. Aufruf oder mehr) immer
Quote
There was an uncatched exception
missing template file maintenance.htt
in line (771) of (/framework/class.wb.php):

nach Änderung im class.wb.php mit ergänzender Pfadangabe kam dann


    }
Quote
There was an uncatched exception
missing template file /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/templates/argos_theme/templates/maintenance.htt und /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/admin/themes/templates/maintenance.htt
in line (771) of (/framework/class.wb.php):


Aus

    public function correct_theme_sourc e($sThemeFile = 'start.htt') {
    $sRetval = $sThemeFile;
    if (file_exists(THEME_PATH.'/templates/'.$sThemeFile )) {
        $sRetval = THEME_PATH.'/templates/'.$sThemeFile;
    } else {
        if (is_readable(ADMIN_PATH.'/themes/templates/'.$sThemeFile )) {
        $sRetval = ADMIN_PATH.'/themes/templates/'.$sThemeFile;
        } else {
            throw new InvalidArgumentExce ption('missing template file '.THEME_PATH.'/templates/'.$sThemeFile.' und '.ADMIN_PATH.'/themes/templates/'.$sThemeFile);
        }
    }
    return $sRetval;

was stimmt. Da ist kein maintenance.htt im ordner argos_theme/templates/

muß wohl rein?


:-)


Offline hgs

  • Betatester
  • **
  • Posts: 1127
    • EFG MG
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #64 on: March 03, 2019, 05:16:29 PM »
Schalte mal die Seite auf das Default-Theme um, WB 2.12.1 funktioniert nur mit diesem, nicht mit argos_theme!!!
Das  argos_theme hätte beim upgrade von WB 2.8.3 auf WB 2.12.1 deinstalliert werden müssen.

Gerne kann ich mir das mal mit den Zugangsdaten anschauen, oder du spielst mir das mit einem DB-Backup mal auf meinen Testserver. Und wir schauen uns das gemeinsam an.

Wenn das in deinem Sinne ist, schreib mir eine PM mit deiner E_Mail-Adresse, dann bekommst du die FTP-Zugangsdaten von mir.
LG Harald

LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #65 on: March 03, 2019, 06:15:11 PM »
Hallo!

umschalten konnte ich im Original (ich setze eine Kopie um)

aber jetzt kommt

Quote
There was an uncatched exception
missing template file /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/templates/wb_theme/templates/maintenance.htt und /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/admin/themes/templates/maintenance.htt
in line (771) of (/framework/class.wb.php):

im  templates/wb_theme der 2.8.3 ist ja auch kein maintenance.htt

das finde ich  im 2.12.1 download im ordner templates/DefaultTheme/templates 

einen ordner templates/wb_theme gibt es nicht.

ich find im 2.12.1 download auch kein maintenance.htt im ordner admin/themes/templates wo es eigentlich auch sein sollte.




Offline jacobi22

  • Posts: 5891
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #66 on: March 03, 2019, 06:17:27 PM »
nur mal am Rande - es ist für mich nicht ersichtlich, das hier überhaupt das Upgrade-Script gelaufen ist. Und wenn das so ist, wurde weder in der Datenbank etwas aktualisiert, noch veraltete Dateien wie eben das WB_Theme gelöscht
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #67 on: March 03, 2019, 06:43:53 PM »
Hallo!

Ja schreib ich doch.
Das Backend nimmt meinen login nicht an. Also startete ich das update script.

Das upgrade_script.php kam zu dem punkt, wo es die config.sys erzeugt hatte und ich F5 drücken sollte.

Ab da kamen beim beim wiederholten Probieren (Backend läßt mich ja nicht einloggen) des upgrade scripts besagten Fehlermeldungen.

das login nimmt nebenbei keinen der 4 möglichen logins an.

 :-o
muß das unbedingt "admin" sein ?

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #68 on: March 03, 2019, 06:53:24 PM »
Hi!

Ha! Es muß admin sein! Und Uboot hat sein Menü wieder!

 :-D :-D :-D :-D :-D :-D :-D :-D :-D :-D :-D :-D

Offline jacobi22

  • Posts: 5891
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #69 on: March 03, 2019, 06:55:27 PM »
There was an uncatched exception
missing template file /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/templates/argos_theme/templates/maintenance.htt und /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/admin/themes/templates/maintenance.htt
in line (771) of (/framework/class.wb.php)


Zur Erklärung, was hier passiert ist......

Das Dateisystem der alten Version 2.8.3 wurde herunter geladen, mit den Dateien der WB 2.12.1 überschrieben und wieder hoch geladen.
In der Datenbank stehen aber noch die alten Einstellungen, wie eben in der settings-Tabelle der Wert "wb_theme" für das Backend-Theme.
Dadurch bauen sich natürlich die Pfade auch falsch zusammen, wie man hier

Quote
missing template file /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/templates/argos_theme/templates/maintenance.htt

oder hier

Quote
missing template file /mnt/web012/e1/50/5428950/htdocs/channel-1/dbs/firmlinge2/templates/wb_theme/templates/maintenance.htt

sehr gut sieht. Durch die manuelle Anpassung der Core-Dateien wird das Chaos dann perfekt

Quote
Das Backend nimmt meinen login nicht an. Also startete ich das update script.

Das upgrade_script.php kam zu dem punkt, wo es die config.sys erzeugt hatte und ich F5 drücken sollte.

Das Upgradescript kann nicht starten, wenn du nicht im Backend eingeloggt bist

Quote
muß das unbedingt "admin" sein ?

Nein, natürlich muß der Displayname des SuperAdmin's mit dem in der Datenbank übereinstimmen, er muß aber nicht "admin" heißen, es kann auch "PeterPan" sein oder "HansMueller" oder sonst etwas. Wichtig ist, das man auch den SuperAdmin-Account benutzt, nur der User mit der User-ID == 1 darf ein Upgrade ausführen. Aber wenn der displayname des Users mit ID = 1 nun mal admin ist, muß er natürlich auch admin benutzen.

Mal ein Beispiel, das ich hundertfach im letztem Jahr hatte. Person XY, vielleicht Webmaster für das Projekt, hat das alte WB installiert und damals die User-ID == 1 bekommen. Mittlerweile ist er aus dem Projekt ausgeschieden und wurde in der Datenbank manuell gelöscht, dann ist aber kein User mit der User-ID == 1 mehr vorhanden und das Upgrade startet nicht. Hier hilft nur das manuelle Umschreiben in der Datenbank, also das Ändern der User-ID eines funktionierenden Accounts,  mit der möglichen Folge, alle Beitragszuordnungen zu verlieren, z.b. in den News (created by, modified_by usw). Die anderen Möglichkeiten wie das Anlegen eines Neuen SuperAdmins spare ich mir, ist zu kompliziert, wenn man nicht ständig mit der Datenbank arbeitet.
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #70 on: March 03, 2019, 06:58:38 PM »
Hi!

Hatte vergesen, daß es "admin" überhaupt gab, hab ich vor 1/2h gottseidank in der Datenbank gesehen und das Passwort getürkt (andres kopiert)

juchu !!!

Offline paulchen

  • Posts: 142
  • Gender: Male
    • PV-Steuer-Shop
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #71 on: March 03, 2019, 07:57:39 PM »
Und ich glaube, da wurde noch etwas vergessen, drum tu ich es:

Herzlichen Dank den Helfern in diesem Forum, die mit viel Fachwissen noch mehr (fast schon unendlicher) Geduld dabei halfen, das Problem zu lösen und zu einem guten Ende zu führen.

mfg
Paulchen

Offline hgs

  • Betatester
  • **
  • Posts: 1127
    • EFG MG
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #72 on: March 04, 2019, 06:38:17 AM »
 (Y)
Dann weiter viel Spaß und Erfolg mit dem besten WebsiteBaker aller Zeiten.
Die nächste "Stufe" ist schon in Vorbereitung.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline gottfried

  • Posts: 1339
Re: ugradee von 2.8.3 - stell mich dumm an
« Reply #73 on: March 04, 2019, 11:43:50 AM »
Hallo!

Ich schließ mich den Ausführungen von Paulchen an. Es ist super, daß da Leute gibt, die Blinde sehend machen
und dabei nie die Nerven verlieren!

 :-D :-D :-D :-D :-D

 

postern-length