Author Topic: Hilfe für Upgrade von 2.8.3 SP1 benötigt  (Read 175 times)

Offline FS72

  • Posts: 62
  • Gender: Male
Hilfe für Upgrade von 2.8.3 SP1 benötigt
« on: November 29, 2018, 12:21:21 PM »
Hallo zusammen,

ich habe hier eine Website mit WB 2.8.3. SP1 welche unter PHP 7 nicht mehr läuft und nun upgedatet werden müsste.

Ich habe nun inzwischen die 2.10 drüber gespielt.
Das Upgrade Script markiert nun einige Module rot und ich weiß nicht genau, wie ich damit umgehen soll.
Die entsprechende Meldung habe ich angehängt.

Was mir direkt aufgefallen ist, was nicht funktioniert ist das Modul Foldergallery und Event Calendar.

Wie kann man die Module am Besten aktualisieren?


VG Frank

Offline jacobi22

  • Posts: 5210
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #1 on: November 29, 2018, 12:28:57 PM »
Quote
Das Upgrade Script markiert nun einige Module rot und ich weiß nicht genau, wie ich damit umgehen soll.
Die entsprechende Meldung habe ich angehängt.

das "rot" (orange) bedeutet lediglich, das diese Module nicht mit im automatischen Upgrade des WB-Systems mit läuft. Diese Module müssen manuell upgegradet werden.

Ich würde jetzt direkt auf die neueste WB Version 2.12.1 upgraden und danach die FG aktualisieren und alles, was du sonst an Modulen im Addonsbereich findest.

Eventkalender kann ich nicht helfen, noch nie gesehen, noch nie benutzt
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline FS72

  • Posts: 62
  • Gender: Male
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #2 on: November 29, 2018, 01:06:02 PM »
Kann ich die FG einfach drüber installieren oder wie mache ich das?

VG Frank

Offline FS72

  • Posts: 62
  • Gender: Male
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #3 on: November 29, 2018, 01:45:20 PM »
Ich habe nun die WB Version 2.12.1 installiert.

Die Foldergallery kann ich aber trotzdem nicht installieren.

Ich bekomme beim drüber installieren von Version 3.0.14 die Meldung: "[170] Ein Upgrade oder Installation von einer WebsiteBaker Version kleiner 2.12.1 ist nicht möglich."

Was mache ich falsch?


VG Frank

Offline jacobi22

  • Posts: 5210
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #4 on: November 29, 2018, 01:50:04 PM »
Quote
Kann ich die FG einfach drüber installieren oder wie mache ich das?

theoretisch soll das gehen, ich hatte allerdings schon desöfteren Probleme mit den Uraltversionen der FG, weil die eine andere settings-Tabelle habe und manchmal bei der neuen ein Eintrag fehlt. Dieser eine hat aber zur Folge, das man scheinbar alles verloren glaubt, weil nix mehr zu sehen ist auf der FG-Seite.

Ich habe aber seit Version 3.0 bei der FG nix mehr getestet, möglicherweise ist das jetzt schon behoben. Ich verwende da eine eigene Version mit erweiterten Funktionen wie Suche nach Kennwörtern, detaillierte Beschreibung, wo, wann ein Event war usw

Quote
Ich bekomme beim drüber installieren von Version 3.0.14 die Meldung: "[170] Ein Upgrade oder Installation von einer WebsiteBaker Version kleiner 2.12.1 ist nicht möglich."

gerade mal probiert in einer Testinstallation, geht ohne Probleme bei mir
Vielleicht hängt noch was im Speicher.
Grundsätzliche Tips: aus WB ausloggen, Browser schließen, Cache leeren. Geht es danach immernoch nicht, in Datei /admin/interface/version.php kontrollieren, was dort drin steht (ggf nicht überschrieben?)
und in der Datenbank / Tabelle settings die WB-Version und Revision kontrollieren
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline hgs

  • Betatester
  • **
  • Posts: 924
    • EFG MG
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #5 on: November 29, 2018, 02:09:35 PM »
Fehler konnte ich gestern leider nachstellen, an einem Fix wird gearbeitet
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Online evaki

  • Posts: 2223
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #6 on: November 29, 2018, 02:24:53 PM »
Was passiert eigentlich, wenn man in der info.php der v3.0.14
$module_platform        = '2.12.0';
auf 2.12.1 setzt?

MfG. Evaki
Einmal Pizza Quattro Stagioni bitte, aber ohne Herbst.

Offline jacobi22

  • Posts: 5210
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #7 on: November 29, 2018, 02:27:31 PM »
Fehler konnte ich gestern leider nachstellen, an einem Fix wird gearbeitet
Die Bedingungen, unter denen ein Upgrade nicht geht, könnten mich schon interessieren, schon, weil ich es nun mehrmal erfolgreich getestet hab, es aber scheinbar nur bei mir funktioniert. Ich steh hier ungern als Lügner da
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Online evaki

  • Posts: 2223
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #8 on: November 29, 2018, 03:04:13 PM »
Die Forensuche ergibt, daß das Problem nicht soooooo selten erscheint.
MfG. Evaki
Einmal Pizza Quattro Stagioni bitte, aber ohne Herbst.

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4160
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #9 on: November 29, 2018, 03:10:31 PM »
Ihr könntet mal was für mich testen. Habe einen kleinen Fix für den Module Installer.

Den Fix entpacken und per FTP hochladen,
oder mit der neuen Methode installieren, den Fix und die unzip.php in den Anwendungs Pfad, unzip aufrufen, fertig

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4160
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #10 on: November 29, 2018, 03:18:25 PM »
Die Bedingungen, unter denen ein Upgrade nicht geht, könnten mich schon interessieren, schon, weil ich es nun mehrmal erfolgreich getestet hab, es aber scheinbar nur bei mir funktioniert. Ich steh hier ungern als Lügner da

Meiner Meinung ist im neuen Installer der 2.12 ein kleiner Denkfehler. Es soll die ModulePlatform aus der neuen info.php mit der aktuellen Platform Version verglichen werden. Es wurde aber die Platform aus der info.php des installierten Modul verglichen. Was  aber verkehrt ist. Wenn diese auf kleiner 2.12 steht schlägt die installation fehl.

Ich hoffe das ich es verständlich erklären konnte. 

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline FS72

  • Posts: 62
  • Gender: Male
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #11 on: November 29, 2018, 03:56:07 PM »
Ich kann gerade das Bugfix nicht testen.

Aber ich habe inzwischen das alte Modul deinstalliert und das neue installiert.
Das hat ohne Probleme funktioniert.


VG Frank

Offline jacobi22

  • Posts: 5210
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #12 on: November 29, 2018, 04:06:55 PM »
wenn man nur eine Kategorie ohne Beschreibungen hat, ist das auf jeden Fall z.Z. die schnellste Lösung.

Ich habe allein auf meiner Seite 945 Bilder und jedes hat eine eigene Beschreibung. Wäre ein Haufen Arbeit, die alle neu zu machen.

@ Dietmar: letzte FG-Version, die ich mit WB 2.12.1 aktualisiert habe, war eine 3.0.0. dev5 aus 2016 oder so) in der letzten Woche. So stand es in der info.php und zu dieser Zeit hat kein Mensch an WB 2.12 oder neuer gedacht.
Wie gesagt, hab ich mehrmals durch, auch mit älteren Version, in denen als Platform eine 2.8 steht.
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline hgs

  • Betatester
  • **
  • Posts: 924
    • EFG MG
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #13 on: November 29, 2018, 05:29:20 PM »
Zur Info für alle Mitleser

Ich habe gestern auf eine WB 2.8.3 unter php 5.6 die FG 1.21 installiert.
Danach die WB 2.12.1 drüber gespielt.
Dann die FG 3.0.14 aus dem addON versucht drüber zu installieren. Dann habe ich diese Fehlermeldung bekommen.
Quote
"[170] Ein Upgrade oder Installation von einer WebsiteBaker Version kleiner 2.12.1 ist nicht möglich."

Nach dem Fix von Dietmar war die Meldung bei mir weg.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline Luisehahne

  • WebsiteBaker Org e.V.
  • **
  • Posts: 4160
  • Gender: Male
    • Webdesign und Entwicklung WebsiteBaker
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #14 on: November 29, 2018, 06:12:11 PM »
wenn man nur eine Kategorie ohne Beschreibungen hat, ist das auf jeden Fall z.Z. die schnellste Lösung.

Ich habe allein auf meiner Seite 945 Bilder und jedes hat eine eigene Beschreibung. Wäre ein Haufen Arbeit, die alle neu zu machen.

@ Dietmar: letzte FG-Version, die ich mit WB 2.12.1 aktualisiert habe, war eine 3.0.0. dev5 aus 2016 oder so) in der letzten Woche. So stand es in der info.php und zu dieser Zeit hat kein Mensch an WB 2.12 oder neuer gedacht.
Wie gesagt, hab ich mehrmals durch, auch mit älteren Version, in denen als Platform eine 2.8 steht.

Uwe schick mir doch mal die FG-Tabellen der Version 3.0.0. dev5 als dump, dann Teste ich das upgrade,

Dietmar
Immer nur von der Zukunft reden, die Gegenwart vergessen und auf die Vergangenheit schimpfen
Neues Unwort: Schnappatmung

Offline princessofia

  • Posts: 1
Re: Hilfe für Upgrade von 2.8.3 SP1 benötigt
« Reply #15 on: December 04, 2018, 02:33:40 PM »
Quote
Kann ich die FG einfach drüber installieren oder wie mache ich das?

theoretisch soll das gehen, ich hatte allerdings schon desöfteren Probleme mit den Uraltversionen der FG, weil die eine andere settings-Tabelle habe und manchmal bei der neuen ein Eintrag fehlt. Dieser eine hat aber zur Folge, das man scheinbar alles verloren glaubt, weil nix mehr zu sehen ist auf der FG-Seite.

Ich habe aber seit Version 3.0 bei der FG nix mehr getestet, möglicherweise ist das jetzt schon behoben. Ich verwende da eine eigene Version mit erweiterten Funktionen wie Suche nach Kennwörtern, detaillierte Beschreibung per click, wo, wann ein Event war usw

Quote
Ich bekomme beim drüber installieren von Version 3.0.14 die Meldung: "[170] Ein Upgrade oder Installation von einer WebsiteBaker Version kleiner 2.12.1 ist nicht möglich."

gerade mal probiert in einer Testinstallation, geht ohne Probleme bei mir
Vielleicht hängt noch was im Speicher.
Grundsätzliche Tips: aus WB ausloggen, Browser schließen, Cache leeren. Geht es danach immernoch nicht, in Datei /admin/interface/version.php kontrollieren, was dort drin steht (ggf nicht überschrieben?)
und in der Datenbank / Tabelle settings die WB-Version und Revision kontrollieren

Danke für die Antwort, es hilft mir sehr

 

postern-length