Author Topic: Step 5 fails (Upgrade 2.10 to 2.12)  (Read 415 times)

Online CodeALot

  • Posts: 418
  • Gender: Male
Step 5 fails (Upgrade 2.10 to 2.12)
« on: October 11, 2018, 01:41:18 PM »

When I try to upgrade a 2.10 installation to 2.12, it fails on step 5:

Step 5 : Modify PRIMARY KEY in settings table and add missing entries
unable to recreate table `settings` FAILED

After that, the complete 'settings' table is gone in the database.

I copied the whole 2.10 website to another host and tried again, but with the same result.  Any ideas?

Offline jacobi22

  • Posts: 5836
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Step 5 fails (Upgrade 2.10 to 2.12)
« Reply #1 on: October 11, 2018, 02:20:26 PM »
Dont stop the upgrade after the first break, reload the page with F5 (on windows systems) or alternate keys on other systems

if needed, reload the page (upgrade-script.php) multiple times, so that you see the buttons " Kick me to the Backend" in the bottom of the page at the end. "Worst case" for me was 8 reloads, but this was not a WB 2.10.x as start version

maybe you check the files or upload it again in Folder "install" and the file upgrade-script.php in wb-root.
it's important, that you have there the files from your target version (WB 2.12) - i see it again and again, that the guy's try it with the upgrade-script from the old version
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.