Author Topic: Beim Öffnen von Seiten in CKEditor 4.9.2 werden die css-styles gelöscht  (Read 193 times)

Offline gurkenhals

  • Posts: 90
  • Gender: Male
Moin Leute,

wenn ich im WB 2.12.0 eine Seite in Bearbeitung nehme, sind plötzlich alle händisch eingetragenen css-Styles, aber auch ein <p style="clear:both;">&nbsp;</p> z.B., verschwunden; die werden einfach gelöscht.

Was kann ich tun?, denn so kann ich nicht arbeiten.

Grüße,
gurkenhals
     


Offline dbs

  • Betatester
  • **
  • Posts: 7553
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Hi, du hast mind. 3 Möglichkeiten.
- statt Wysiwyg einen Code2 Abschnitt nehmen
- auf die nächste Version warten, da ist der Filter im CKeditor deaktiviert
- den Filter selbst deaktivieren (Doppelslash davor // ) in modules/ckeditor/
  - include.php Zeile 224 und
  - wbconfig/wb_ckconfig.js Zeile 241 und dort unter der deaktivierten Zeile dies hinzufügen:
   
Code: [Select]
config.allowedContent = {
        $1: {
            // Use the ability to specify elements as an object.
            elements: CKEDITOR.dtd,
            attributes: true,
            styles: true,
            classes: true
        }
    };
    config.disallowedContent = 'script; *[on*]';

Hoffe eins davon hilft.

Denkbar ist auch von true auf false oder andersrum zu setzen statt zu deaktivieren. Die Zeilen sehen so aus:
Code: [Select]
        //disable ckes Advanced Content Filter (ACF) to avoid wblinks to be filtered?
        $ckeditor->config['allowedContent'] = false;

      //disable ckes Advanced Content Filter (ACF) to avoid wblinks to be filtered?
      config.allowedContent = true;
« Last Edit: October 01, 2018, 08:08:00 PM by dbs »

Offline gurkenhals

  • Posts: 90
  • Gender: Male
Danke für die Antwort. Allerdings hätte ich bei der Installation gerne vorher eine Option gehabt.
Dieser Filter ohne Abschaltoption in den Admin-Einstellungen ist für mich absolut kontraproduktiv und sinnfrei.
Mit der 4.10.0, wie sie woanders genutzt wird, habe ich das Problem nicht. Dann probiere ich die mal...

Offline dbs

  • Betatester
  • **
  • Posts: 7553
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Ja, es ist ärgerlich.
Die Lösung für dich in der 2.12 ist, ckeditor/wb_config/wb_ckconfig.js Zeile 231
Code: [Select]
    config.allowedContent = true;
true = alles erlaubt.

In der nächsten Version WB 2.12.1 ändert sich das nicht. Man kann sogar Ausnahmen definieren.

 

postern-length