Author Topic: Update van 2.8.1 blijft steken  (Read 1294 times)

Offline HK

  • Posts: 91
  • Gender: Male
    • Pierewaaien Scheveningen
Update van 2.8.1 blijft steken
« on: August 14, 2018, 10:28:09 AM »
Beste Bakkers,

http://www.perfectimperfection.nl/ :
Deze site stond nog in 2.8.1 en ik probeer nu een update volgens de handleiding:
https://forum.WebsiteBaker.org/index.php/topic,23412.0.html.
Ik blijf steken in step 5 als ik moet inloggen op de backend; ik krijg dan een foutmelding die zegt dat het classic theme ontbreekt:
Template Error: set_root: /home/perfecti/public_html/templates/classic_theme/templates is not a directory.
Halted.

Maar die moest ik juist verwijderen! Ik heb nog geprobeerd met het classic theme toch maar weer toegevoegd, maar dat werkt ook niet. Ik kan dus nu niet meer bij de backend; het classic theme heb ik inmiddels toch maar weer verwijderd.
Groeten, HK Amstelveen

Offline jacobi22

  • Posts: 5865
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update van 2.8.1 blijft steken
« Reply #1 on: August 14, 2018, 10:49:58 AM »
the script search for a template in the folder /templates/classic_theme/templates, but did'nt found it. Unpack the ZIP from the attachement to your template-Folder and start your job again

alternate: go into the database, there to the settings-table and change the value for "default_theme" to "wb_theme". i'm sure, there is actually the value "classic_theme"
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline HK

  • Posts: 91
  • Gender: Male
    • Pierewaaien Scheveningen
Re: Update van 2.8.1 blijft steken
« Reply #2 on: August 14, 2018, 12:05:59 PM »
OK,
Classic theme toegevoegd van de bijlage. Ik kan nu inloggen, ook als super-admin, maar het upgrade script start niet. Toen geprobeerd met http://www.perfectimperfection.nl/upgrade-script.php.
Reactie: default_theme: already exists. OK. Verder geen aanwijzingen. Backside zegt: Version 2.8.1. Kennelijk is de database niet bijgewerkt?
 
Groeten, HK Amstelveen

Offline jacobi22

  • Posts: 5865
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update van 2.8.1 blijft steken
« Reply #3 on: August 14, 2018, 12:19:33 PM »
the upgrade instruction say's, you have to upgrade to WB 2.8.3 first, then from this Version 2.8.3 to WB 2.10.x
the DefaultTheme was not Part of WB 2.8.3, so it looks, that you try, to upgrade WB 2.8.1 up to WB 2.10.x or newer in one step, without the way over WB 2.8.3

P.S.: this file upgrade-script.php is the version from WB 2.8.1
IMPORTANT: every WB-Version has a own upgrade-script.php (and also a own index.php in the main folder). Dont forget to overwrite this files with the files from the new WB-Version
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline HK

  • Posts: 91
  • Gender: Male
    • Pierewaaien Scheveningen
Re: Update van 2.8.1 blijft steken
« Reply #4 on: August 14, 2018, 01:14:08 PM »
Dank, Jacobi.
Het was toch een beetje anders: de files en folders waren niet overschreven door een instelling bij FileZilla; ook het upgrade-script was dus nog oud. Ik heb de voorinstelling bij FileZilla nu aangepast en de files en folders opnieuw geüpload en het script gedraaid. Een en ander ziet er nu goed uit. Binnenkort door naar 2.10 of 2.12?
Groeten, HK Amstelveen

Offline jacobi22

  • Posts: 5865
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Update van 2.8.1 blijft steken
« Reply #5 on: August 14, 2018, 03:27:18 PM »
sorry for the late peplay, i've a lot of work at the moment....

Quote
Binnenkort door naar 2.10 of 2.12?

yes, why not? it make's no sense, to work longer with older versions, because, there are too many changes in PHP in the last two years. i've the same problem actually with a old WB 2.8.0 and specially with the used modules and also with some trouble in the charset the most letters are correct translated, but not all. i think, the server charset change in the past, so that i've not all correct converted.
if you can, use PHP 5.6.x and change it at the last step, when you have WB 2.10 or newer. It's recommended, to use the lastest WB-Version 2.12.x. the hardest step with the most possible problems come's, when you upgrade from 2.8.3 up to 2.10. x. In all my upgardes, i've never problems, when i upgrade from WB 2.10.x to a newer version (if i solve all problems in WB 2.10.x)
Wer nicht will, findet Gründe, wer will, findet Wege.

 

postern-length