Author Topic: Problem upgrading  (Read 238 times)

Offline svsanchez

  • Posts: 449
Problem upgrading
« on: July 02, 2018, 07:44:36 PM »
Hello, I hope someone can help me with the upgrade process. I am trying to upgrade my site www.embajadadeespan a.org from version 2.8.3 rev 1638 to 2.10

I first upgraded to 2.8.3 rev 1645, I think this is SP6?

The upgrade script worked ok, I reloaded the modules and the site loads fine. HOWEVER, after the upgrade, when I click a page to EDIT it, the wysiwyg doesn't load. I added a form module and placed it first on the list of modules on a test page, with the wysiwyg second on the list. The form module does appear when I click MODIFY PAGE, but the Wysiwyg still doesn't appear.

Please help, thank you!

Offline hgs

  • Betatester
  • **
  • Posts: 920
    • EFG MG
Re: Problem upgrading
« Reply #1 on: July 03, 2018, 08:03:22 AM »
Unfortunately, it often happens that not all data is overwritten during the upgrade via FTP.
Please overwrite the data of WB 2.10 again with "overwrite everything" and run the upgrade script again.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline dbs

  • Betatester
  • **
  • Posts: 7553
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Problem upgrading
« Reply #2 on: July 03, 2018, 08:15:00 AM »
Is this the same problem like here?
Also a thread by you from 2017: https://forum.WebsiteBaker.org/index.php/topic,30554.msg212906.html#msg212906

Offline svsanchez

  • Posts: 449
Re: Problem upgrading
« Reply #3 on: July 03, 2018, 05:41:57 PM »
Hello dbs, as always thanks a lot for your help. The problem is exactly the same, only this time I didn't upgrade to version 2.10 but to version 2.8.3 rev 1645 and the wysiwyg module stopped loading. I wanted to upgrade this account little by little as a test before I upgrade the account that really worries me which had some code injected.

This account was using PHP 5.4 and I changed to PHP 5.6 after I tried to upgrade it and received a message that I needed PHP 5.6 or higher. I was able to solve the wysiwyg module loading problem by switching to PHP version 7 instead of 5.6 without having to upload all the files again. I don't know why it didn't work with PHP 5.6, I am guessing I needed to switch to version 5.6 BEFORE running the upgrade script the first time?

Anyway, I am going to proceed upgrading to SP7 now and then to 2.10, hopefully it all goes smoothly.

Regarding the other thread, I had totally forgotten about it. When I checked it again, it was working. I have no idea of how it fixed itself!