Author Topic: error in SecureTokens.php  (Read 276 times)

Offline noname8

  • Posts: 135
error in SecureTokens.php
« on: April 16, 2018, 07:44:16 AM »
Using php 7.x and wb 2.8 i have error in the logs, not every time but some times
from the line 440:
Code: [Select]
            $sReplacement = $iWords ? implode(':', array_fill(0, $iWords, '0000')) : '';it's making an output, perhaps warning or notice, but i cannot find out what

error in the log is:
[date] PHP Warning:  Cannot modify header information - headers already sent by (output started at /path/path/framework/SecureTokens.php:440) in /path/path/public_html/index.php on line 116

maybe this is related to more strict type defs of php 7.x?

Offline dbs

  • Betatester
  • **
  • Posts: 7553
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: error in SecureTokens.php
« Reply #1 on: April 16, 2018, 08:08:45 AM »
Hi, you know the answer:
https://forum.WebsiteBaker.org/index.php/topic,29670.msg207754.html#msg207754

Old unsecure WB version + newer PHP versions = more and more problems.
Come on, do the upgrade.

Can you tell us something about your changes?
Maybe we take it into the next WB versions.
« Last Edit: April 16, 2018, 10:09:38 AM by dbs »

 

postern-length