Author Topic: OFA Anyitems und Topitems Problem  (Read 337 times)

Offline astricia

  • Posts: 577
  • Gender: Female
    • netSchmiede24
OFA Anyitems und Topitems Problem
« on: August 22, 2017, 09:05:02 AM »
Hallo - neues Projekt, WB 2.10.0. Soweit funktionierte bislang alles. Jetzt habe ich aber das OFA-Modul verwendet (funktioniert auch) und versuche auf einer Unterseite mit entweder Anyitems oder Topitems die OFA-Einträge aufzurufen, so wie ich es schon zigmal bei anderen Projekten gemacht habe.

Dabei zerschießt es mir die Seite. Ein Headerbild - welches zuvor ohne den Anyitems-Abschnitt (ist ein Code-Abschnitt) einwandfrei funktionierte - wird nun nicht mehr angezeigt (statt dem Media-Pfad steht da {SYSVAR:MEDIA_REL}. Und anschließend bricht die HTML-Ausgabe dort, wo der Code-Abschnitt beginnt, komplett ab. Der Seitenquelltext hört dort also auf.

Die Log-Datei gibt folgendes aus: PHP Fatal error: Call to a member function numRows() on null in /homepages/23/d611829432/htdocs/cms/modules/oneforall_anyitems/include.php on line 97

Ich habe schon sämtliche Filter versucht, ein- oder auszuschalten. Das ändert nichts.

Irgendjemand ne Idee?

LG,
Astrid

Offline jacobi22

  • Posts: 5683
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: OFA Anyitems und Topitems Problem
« Reply #1 on: August 22, 2017, 11:24:50 AM »
Quote
Die Log-Datei gibt folgendes aus: PHP Fatal error: Call to a member function numRows() on null in /homepages/23/d611829432/htdocs/cms/modules/oneforall_anyitems/include.php on line 97

bedeutet, das diese Abfrage hier keine Ergebnisse bekommt, entweder, weil die Tabelle leer ist oder die Abfrage falsch gestellt wurde, z.b. wenn $mod_name nicht aufgelöst wird. $mod_name  wird etwas weiter oben in der include.php ermittelt, hier würde ich mir mal ein echo setzen

$query_fields = $database->query("SELECT * FROM ".TABLE_PREFIX."mod_".$mod_name."_fields");
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline astricia

  • Posts: 577
  • Gender: Female
    • netSchmiede24
Re: OFA Anyitems und Topitems Problem
« Reply #2 on: August 22, 2017, 11:42:45 AM »
Ah, ich bin so doof.... hatte im Code-Aufruf nicht die Section-ID, sondern die Page-ID eingetragen.... das kann ja nicht klappen... Danke, dass du mich indirekt drauf gebracht hast. :-D