Author Topic: Miniform getting better again  (Read 1657 times)

Offline Ruud

  • Posts: 3649
  • Gender: Male
  • Do not use PM for help! Please use the forum!
    • Dev4Me - Professional WebsiteBaker Development
Miniform getting better again
« on: June 30, 2017, 02:21:33 PM »
Today I released miniform 0.11.

This version will allow you to submit the form through Ajax without reloading the page. This will keep the errormeesage (or succesmessage) in the viewport even when you form is in the footer of a page.

Note: jQuery must be enabled, if it is not enabled the form will fallback top normal operation.

Demo: https://miniform.dev4me.com/demo/ajax-form/
Download: https://dev4me.com/modules-snippets/opensource/miniform/


Offline johnbroeckaert

  • Posts: 192
  • Gender: Male
Re: Miniform getting better again
« Reply #1 on: June 30, 2017, 02:59:11 PM »
You are a busy man, @ruud
Thanks again (Y)
It is a happy talent to know how to play!

Offline Hans

  • Posts: 912
  • Gender: Male
Re: Miniform getting better again
« Reply #2 on: July 02, 2017, 11:36:34 PM »
Thanks Ruud!  (Y)
Hans - Nijmegen - The Netherlands

Offline zirzy

  • Posts: 168
Re: Miniform getting better again
« Reply #3 on: August 15, 2017, 10:13:29 AM »
Hi,

Thanks Ruud for great work!  (Y)

I have one question, if I have installed reCaptcha in miniform and then I want to get rid of it (or just replace it to anoteher..). How to do it? If I just take option reCaptcha "off" from miniform backend, it doesn't do that.. And if I go to WB/ admin-tools/captcha/Advanced Spam Protection Configuration --> disable, still reCaptcha is there  :lol:

Need some advice  :-D

Offline Ruud

  • Posts: 3649
  • Gender: Male
  • Do not use PM for help! Please use the forum!
    • Dev4Me - Professional WebsiteBaker Development
Re: Miniform getting better again
« Reply #4 on: August 15, 2017, 10:58:03 AM »
Hi,

Thanks Ruud for great work!  (Y)

I have one question, if I have installed reCaptcha in miniform and then I want to get rid of it (or just replace it to anoteher..). How to do it? If I just take option reCaptcha "off" from miniform backend, it doesn't do that.. And if I go to WB/ admin-tools/captcha/Advanced Spam Protection Configuration --> disable, still reCaptcha is there  :lol:

Need some advice  :-D
Disabling reCaptcha in the backend should change the captcha back to to the standard WB captcha's.

If you do not want any captcha at all, just remove {CAPTCHA} (including the html markup around it) from your template.
That will completely disable any captcha's.
See: https://miniform.dev4me.com/template-help/basic-structure/#captcha

Offline zirzy

  • Posts: 168
Re: Miniform getting better again
« Reply #5 on: August 15, 2017, 11:49:00 AM »
Code: [Select]
Disabling reCaptcha in the backend should change the captcha back to to the standard WB captcha's.
Yes I did that but nothing happened..

Ok, I will take captcha away from there  (Y)

Offline zirzy

  • Posts: 168
Re: Miniform getting better again
« Reply #6 on: September 26, 2017, 11:39:37 AM »
Another problem.. :-D

This error comes even if all recipients have been added:
You must provide at least one recipient email address.

Or is this roblem (again) just with the pre domain (www.provider.com/~client/) and goes a way when correct domain is added?

Offline Ruud

  • Posts: 3649
  • Gender: Male
  • Do not use PM for help! Please use the forum!
    • Dev4Me - Professional WebsiteBaker Development
Re: Miniform getting better again
« Reply #7 on: September 26, 2017, 12:34:51 PM »
It looks to me your hosting has some issues. An error like this (generated by the 3rd party phpmailer class) should never happen (just like your previous problem shouldn't).
Combining this issue with the other problem it looks like a problem with too strict mod_security settings.
These strict settings will silently block php, form and/or mysql actions that it thinks are suspicious.

Ask your host to lower the level (or disable temporarily for testing) and try again.

Offline zirzy

  • Posts: 168
Re: Miniform getting better again
« Reply #8 on: September 27, 2017, 09:54:55 AM »
Quote
Ruud:
It looks to me your hosting has some issues. An error like this (generated by the 3rd party phpmailer class) should never happen (just like your previous problem shouldn't).
Combining this issue with the other problem it looks like a problem with too strict mod_security settings.
These strict settings will silently block php, form and/or mysql actions that it thinks are suspicious.

Ask your host to lower the level (or disable temporarily for testing) and try again.

Yes, this is different server provider.. it may be the security level or there is too old phpmailer installation. SMTP seems to work correct  (Y)

 

postern-length