Author Topic: Problem upgrading  (Read 1160 times)

Offline svsanchez

  • Posts: 466
Problem upgrading
« on: May 17, 2017, 07:40:44 PM »
Hello!

I'm having problems upgrading from 2.8.3 SP3 to SP7. I couldn't find step by step instructions for the upgrade, but I remember I had to upload the new files and run the upgrade script. I downloaded the patch packet from December 2016, unzipped it and uploaded the new files on top of the old ones. Then I tried accessing the upgrade script at http://kreativa.com.gt/upgrade-script.php and got the following error:

There was an unknown exception: unable to create logfile '/var/logs/php_error.log' in line (94) of (/framework/initialize.php)

Not only does the upgrade script show that error, all pages are now showing it: http://kreativa.com.gt/index.php

I searched for the kwyword initialize.php on the forum but only found a topic talking about redirection and the problem being that WB was installed in a subfolder. My WB is NOT installed in a subfolder.

I was going to revert to SP3 but prefer not to because of the vulnerabilities so any help will be very much appreciated.

Also, could someone point me to step by step instructions for upgrading from SP3 to SP7?

Thank you!

Offline jacobi22

  • Posts: 5614
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Problem upgrading
« Reply #1 on: May 17, 2017, 10:31:57 PM »
add the folder called "var/logs" and the empty file called php_error.log manually

Important: read here -> WB-2.10.0 stable version published and also here -> Warning: SQL Injection vulnerability
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline svsanchez

  • Posts: 466
Re: Problem upgrading
« Reply #2 on: May 17, 2017, 11:41:42 PM »
Hello Jacobi, thanks a lot for your help. Adding the /var/logs/error_log.php directories and file removed the error, but now I get an Internal Server Error (500). What could it be?

The server is configured with PHP 5.6.

I guess I should solve this issue before upgrading to 2.8.10?!?!

Offline hgs

  • Betatester
  • **
  • Posts: 1018
    • EFG MG
Re: Problem upgrading
« Reply #3 on: May 18, 2017, 08:28:29 AM »
Here is a step by step instructions from the current software package 2.10
You can find it in your installation folder  /DOCU/README.EN

Quote
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[1] General Information about version 2.10.0
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

WB-2.10 is the compatible follow up of all previous WB-2.8.3 releases.
This packet includes all you need to run a website. In addition to the core you get a basic collection of add-ons. You also get all needed 3rd party packages like PHPMailer, pclzip, phplib, Twig, JQuery and more.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[2] Requirements
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

WebsiteBaker is developed in a Linux & Apache environment, therefore we can not give any guarantee that it will work without any problem in a Windows(r) Environment.

Operating system: Linux (recommended), Windows (maybe)
Database        : mySQL 5.6 and up
Webserver       : Apache
PHP             : 5.6 and up, PHP-7 up recommended
                  PHP running as Apache-Module can produce malfunctions in WebsiteBaker !!!
Diskspace       : 25MB and up

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[3] Instructions for Installing WebsiteBaker 2.10
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This install pack includes a complete WebsiteBaker version 2.10.0-RC1 and can be installed
on all compatible hosts.

a) Check that your webspace meets the requirements described above!

b) Make sure that you have a mySQL database available and obtain the access data!

c) Download the packet to your workstation and unzip all into an empty folder.

d) Move all to your webspace using ftp and 'overwrite all' setting.

e) switch the PHP version to 5.6 or 7.x if it's not already done.

f) now simply call your installation like  http://example.com/ and follow the
   instructions of the install script.


Enjoy your new WebsiteBaker installation!

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[4] Upgrade WebsiteBaker from any versions of WB-2.8.3
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This install pack includes a complete WebsiteBaker version 2.10.0 and can be installed
on all previously published WB 2.8.3 versions (with or without Service Pack). Additional
Instructions for upgrading WebsiteBaker versions older than 2.8.3 can be found at [5].

a) IMPORTANT::  in any case make a backup of your webspace and the database too !!!

b) Download the packet to your workstation and unzip all into an empty folder.

c) Move all to your webspace using ftp and 'overwrite all' setting.

d) switch the PHP version to 5.6 or 7.x if it's not already done.

e) now start the upgrade-script.php file and follow possible instructions.

f) some add-on pakets are not delivered with this version and must be upgraded manually.
   Some new versions are available on http://addon.WebsiteBaker.org/

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[5] Upgrade WebsiteBaker from older versions before WB-2.8.3
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Before you upgrade from an older version, first you must upgraded to [WB 2.8.3 from Feb.2012].
That version is downloadable from either of these links:
http://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?id=0EA85F12    or
http://wiki.WebsiteBaker.org/doku.php/en/downloads#websitebaker_283

Instructions for upgrading to WB-2.8.3 can be found in our forum:
english: http://forum.WebsiteBaker.org/index.php/topic,23412
german:  http://forum.WebsiteBaker.org/index.php/topic,23658
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline jacobi22

  • Posts: 5614
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Problem upgrading
« Reply #4 on: May 18, 2017, 11:19:41 AM »
Quote
but now I get an Internal Server Error (500). What could it be?
maybe a intern problem on the server if he try to write into the error-log-file

if you ask me.....
delete the folders account, admin, framework, include, language, search and in modules all the folders, all folders that were also included in the WB 2.10.0 package (like form, news etc)
then upload the WB 2.10.0-Package, be sure, that you set your ftp-client to the option "overwriting all"
now go to the backend and login, the upgrage-script starts automatically.
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline jenerik

  • Posts: 1
2.6.5 to 2.10 upgrade how
« Reply #5 on: May 18, 2017, 05:38:17 PM »
I have a CMS built with WebsiteBaker 2.6.5. How can I upgrade the latest version.
Thanks

Offline contactjw

  • Posts: 121
Re: 2.6.5 to 2.10 upgrade how
« Reply #6 on: May 18, 2017, 08:16:12 PM »
I have a CMS built with WebsiteBaker 2.6.5. How can I upgrade the latest version.
Thanks
Here is a step by step instructions from the current software package 2.10
You can find it in your installation folder  /DOCU/README.EN

Quote
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[1] General Information about version 2.10.0
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

WB-2.10 is the compatible follow up of all previous WB-2.8.3 releases.
This packet includes all you need to run a website. In addition to the core you get a basic collection of add-ons. You also get all needed 3rd party packages like PHPMailer, pclzip, phplib, Twig, JQuery and more.

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[2] Requirements
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

WebsiteBaker is developed in a Linux & Apache environment, therefore we can not give any guarantee that it will work without any problem in a Windows(r) Environment.

Operating system: Linux (recommended), Windows (maybe)
Database        : mySQL 5.6 and up
Webserver       : Apache
PHP             : 5.6 and up, PHP-7 up recommended
                  PHP running as Apache-Module can produce malfunctions in WebsiteBaker !!!
Diskspace       : 25MB and up

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[3] Instructions for Installing WebsiteBaker 2.10
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This install pack includes a complete WebsiteBaker version 2.10.0-RC1 and can be installed
on all compatible hosts.

a) Check that your webspace meets the requirements described above!

b) Make sure that you have a mySQL database available and obtain the access data!

c) Download the packet to your workstation and unzip all into an empty folder.

d) Move all to your webspace using ftp and 'overwrite all' setting.

e) switch the PHP version to 5.6 or 7.x if it's not already done.

f) now simply call your installation like  http://example.com/ and follow the
   instructions of the install script.


Enjoy your new WebsiteBaker installation!

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[4] Upgrade WebsiteBaker from any versions of WB-2.8.3
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

This install pack includes a complete WebsiteBaker version 2.10.0 and can be installed
on all previously published WB 2.8.3 versions (with or without Service Pack). Additional
Instructions for upgrading WebsiteBaker versions older than 2.8.3 can be found at [5].

a) IMPORTANT::  in any case make a backup of your webspace and the database too !!!

b) Download the packet to your workstation and unzip all into an empty folder.

c) Move all to your webspace using ftp and 'overwrite all' setting.

d) switch the PHP version to 5.6 or 7.x if it's not already done.

e) now start the upgrade-script.php file and follow possible instructions.

f) some add-on pakets are not delivered with this version and must be upgraded manually.
   Some new versions are available on http://addon.WebsiteBaker.org/

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
[5] Upgrade WebsiteBaker from older versions before WB-2.8.3
++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

Before you upgrade from an older version, first you must upgraded to [WB 2.8.3 from Feb.2012].
That version is downloadable from either of these links:
http://addon.WebsiteBaker.org/pages/en/browse-add-ons.php?id=0EA85F12    or
http://wiki.WebsiteBaker.org/doku.php/en/downloads#websitebaker_283

Instructions for upgrading to WB-2.8.3 can be found in our forum:
english: http://forum.WebsiteBaker.org/index.php/topic,23412
german:  http://forum.WebsiteBaker.org/index.php/topic,23658

Offline jacobi22

  • Posts: 5614
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Problem upgrading
« Reply #7 on: May 19, 2017, 12:17:01 AM »
Quote
I have a CMS built with WebsiteBaker 2.6.5. How can I upgrade the latest version.

the last post show's the install instruction, but you need an upgrade

version 1 : follow all! steps from this instructions here -> https://forum.WebsiteBaker.org/index.php/topic,23412.0.html

version 2 : install a fresh, clean WB 2.10.0 in a empty subfolder, use in the installer a different TABLE_PREFIX, not the same like your WB 2.6.5, and rebuild there the new project via copy&paste

version 3 : (only recommended, if you have enough experients with PHP & WB) - simple overwriting all files with the WB-2.10.0 Package, but its needs some edit's in your database (like a new settings table)
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline svsanchez

  • Posts: 466
Re: Problem upgrading
« Reply #8 on: May 19, 2017, 08:03:11 AM »
Hello, thank you very much for the instructions. I was about to do this when I noticed the installed files were pretty old. I now understand what happened:

Prior to the upgrade, I made a backup. The backup used almost all of the disk space of that hosting account, so when I uploaded the files, only the upgrade script and a few other files were uploaded and the rest couldn't be uploaded without me noticing (I left the computer uploading the files unattended and only came back a few hours later when I thought everything was uploaded).

So, the Internal Server Error problem was due to most files not being uploaded! I upgraded the hosting account and uploaded the files, and this time it worked :)

 

Offline hgs

  • Betatester
  • **
  • Posts: 1018
    • EFG MG
Re: Problem upgrading
« Reply #9 on: May 19, 2017, 10:34:19 AM »
 (Y)
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)