Author Topic: AddonFileEditor kann nicht installiert werden  (Read 776 times)

Offline Herbert

  • Posts: 30
AddonFileEditor kann nicht installiert werden
« on: February 12, 2017, 05:04:11 PM »
Hallo, wollte einiges an der CSS-Datei des Templates ONLINE ändern.
Die bisherige alte Version des Moduls kann ich zwar aufrufen aber es wird keine editierbare Datei angzeigt.

Wollte dann eine neue Version des Moduls (3.0.3  oder 3.0.7) installieren aber da bricht der Installationsvorgan g ab mit der Fehlermeldung, dass WB 2.8.3 notwedig wäre und ich hätte nur 2.8.
PHP-Version beim Provider ist 7.0

Verstehe ich nicht, habe doch gestern die neueste Patchversion installiert und bei mir wird CMS-Version 2.8.3+SP7, Admin Version 1.6 angezeigt und irgendwo stand auch 1647
Hat da doch etwas nicht geklappt mit dem Update von WB, trotz der neuen Datei upgrade-script welche jacobi22 zur Verfügung gestellt hatte?
Wenn ja, würde es etwas bringen, sowohl die das gesamte Paket SP7 nochmals drüber zu installieren einschlißlich anschließenden Patch übertragen OHNE das die gegenwärtige Homepage Schaden nimmt?
Ja mir ist bekannt, dass ich auch extern mit Notepad die Datei bearbeiten kann aber mich irritiert die Fehlermeldung :-(

Herbert

Offline jacobi22

  • Posts: 5872
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: AddonFileEditor kann nicht installiert werden
« Reply #1 on: February 12, 2017, 05:11:04 PM »
bitte einfach dieses Paket WB 2.10.0-RC1 herunterladen und auf deine Testumgebung kopieren. Es beinhaltet alles, was an Reparaturen notwendig ist und sollte dein Problem lösen.

ich suche grad noch den Ursprung dieser Fehlermeldung, sollte eigentlich nicht auftreten, sofern beim Upgrade auch alle Dateien überschrieben werden.

FTP-Programme wie Filezilla sind da der Erfahrung nach eher unzuverlässig und mit Vorsicht zu geniesen. Ich selbst benutze das Firefox-Addon FireFTP und hatte noch keine Probleme damit. Infos dazu -> https://addons.mozilla.org/de/firefox/addon/fireftp/
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline jacobi22

  • Posts: 5872
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: AddonFileEditor kann nicht installiert werden
« Reply #2 on: February 12, 2017, 06:31:58 PM »
Quote
Wollte dann eine neue Version des Moduls (3.0.3  oder 3.0.7) installieren aber da bricht der Installationsvorgan g ab mit der Fehlermeldung, dass WB 2.8.3 notwedig wäre und ich hätte nur 2.8.
PHP-Version beim Provider ist 7.0

Verstehe ich nicht, habe doch gestern die neueste Patchversion installiert und bei mir wird CMS-Version 2.8.3+SP7, Admin Version 1.6 angezeigt und irgendwo stand auch 1647

es gibt zwei Stellen in WB, die verwendet werden zum Abgleich

Tabelle "settings"



Datei admin / interface / version.php


if(!defined('VERSION')) define('VERSION''2.10.0-RC1');
if(!
defined('REVISION')) define('REVISION''25');
if(!
defined('SP')) define('SP''');


check mal, was in beiden steht, wenn du weiterhin Probleme mit der Installation von Addons hast
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline Herbert

  • Posts: 30
Re: AddonFileEditor kann nicht installiert werden
« Reply #3 on: February 13, 2017, 10:08:12 AM »
Hi
ich glaube ich werde die Empfehlung annehmen und mir in einem anderen Ordner die 2.10-er Version installieren und alles von vorn beginnen.
Habe zwar im admin-Ordner (der bei mir anders heißt) gefunden: 2.8.3, Ver.1647, SP7.
Aber: beim Blick in die Datenbank beim Provider mit meinen so gut wie gar nicht vorhandenen Kenntnissen über die "Untiefen" von Datenbanken habe ich gesehen, dass hier noch ein völlig anderes Problem aufgetaucht.
Hängt vermutlich mit der (fehlerhaften) Rücksicherung der Datenbank zusammen.
Da scheint ein Chaos entstanden zu sein. Wobei mich wundert, dass meine Seite im wesentlichen noch funktioniert und ich auch aktuell Ergänzungen an einigen Seiten vornehmen konnte...
Ich bedanke mich trotzdem für Deine Geduld und Hilfe

Mit Gruß, Herbert

Offline Herbert

  • Posts: 30
Re: AddonFileEditor kann nicht installiert werden
« Reply #4 on: February 13, 2017, 12:17:19 PM »
Hi.
In der Datenbank-Tabelle / settings steht : wb-version 2.8 und wie gesagt im admin-Ordner steht 2.8.3, Ver.1647, SP7

Und was mir noch aufgefallen ist, z.B bei "website_title" stehen Umlaute maskiert, das heißt z.B.ein ü wird mit "Ä1/4" angezeigt.
Als Zeichensatz sowohl im Backend als auch bei der Datenbank sind aber meines Wissens utf-8 eingestellt.
Muss ich also doch noch mal das letzte Update einspielen bevor ich mich an Version 2.10 wage??
Herbert

Offline jacobi22

  • Posts: 5872
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: AddonFileEditor kann nicht installiert werden
« Reply #5 on: February 13, 2017, 12:23:59 PM »
es sollte reichen, wenn du die Version 2.10.0-RC1 drüber kopierst

Quote
Und was mir noch aufgefallen ist, z.B bei "website_title" stehen Umlaute maskiert, das heißt z.B.ein ü wird mit "Ä1/4" angezeigt.
in der Datenbank?
schau mal, was nachher ausgegeben wird unter WB-Optionen - wahrscheinlich lief da vorher mal dein Projekt mit einem anderen Zeichensatz
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline Herbert

  • Posts: 30
Re: AddonFileEditor kann nicht installiert werden
« Reply #6 on: February 13, 2017, 12:30:00 PM »
Oh ich bin ja so was von frustriert.
Habe jetzt mal mit dem "Info-Button" vom DefaultTheme gesehen, das da was völlig anderes steht, nämlich: WebsiteBaker-Version: 2.8.3+SP3  :-( :-( :-(
Ob da mal bei früheren Updates was schief gelaufen ist?
Was tun?  8-)

Offline jacobi22

  • Posts: 5872
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: AddonFileEditor kann nicht installiert werden
« Reply #7 on: February 13, 2017, 01:09:46 PM »
siehe Antwort oben

Quote
bitte einfach dieses Paket WB 2.10.0-RC1 herunterladen und auf deine Testumgebung kopieren. Es beinhaltet alles, was an Reparaturen notwendig ist und sollte dein Problem lösen.

;-)
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline Herbert

  • Posts: 30
Re: AddonFileEditor kann nicht installiert werden
« Reply #8 on: February 14, 2017, 01:02:48 PM »
Hi,
wollte nur mitteilen, dass die Integration von 2.10 geklappt hat. Update verlief ohne für mich erkennbare Probleme. Den o.g. FileEditor konnte ich nach Deinstalltion der vorhergehenden Version auch nutzen.
In den von jabobi22 genannten "Fundstellen" steht jetzt auch die aktuelle Version drinnen.
Muss nur noch klären, was das mit der Fehlermeldung von "show-menu2" in der error_log auf sich hat. Da gibst ja bereits einiges im Forum dazu.
Also nochmals Danke für die Hinweise (Y)
Herbert

Offline jacobi22

  • Posts: 5872
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: AddonFileEditor kann nicht installiert werden
« Reply #9 on: February 14, 2017, 01:39:44 PM »
schau mal, ob du dich hier im englischen zurecht findest

http://forum.WebsiteBaker.org/index.php/topic,18049.msg209373.html#msg209373

Wer nicht will, findet Gründe, wer will, findet Wege.

 

postern-length