Author Topic: Problem mit .htaccess  (Read 887 times)

Offline ecki9

  • Posts: 17
Problem mit .htaccess
« on: January 22, 2017, 12:01:08 PM »
Hallo,

ich wollte ein Verzeichnis durch .htaccess mit einem Password schützen.
Dazu habe ich folgende .htaccess Datei erstelle:

AuthName "Nur für Mitglieder von"
AuthType Basic
AuthUserFile var/www/vhosts/xxxxxxxxxxx/httpdocs/xxxxxxxxxx/mitglieder/.htpasswd
require valid-user

Die Datei .htpasswd habe ich auch erstellt.

Wenn ich nun diese Seite aufrufe, werde ich nach user/Password gefragt!
Nach der Eingabe bekomme ich dann folgenden Feher angezeigt:

Oops, da liegt eine Stoerung des CMS Systems vor. Bitte achten Sie darauf, dass in einer .htaccess Datei keine Zeile mit Options beginnt. Bitte kommentieren Sie diese Zeile aus. Beispiel: Options -FollowSymLinks -> #Options -FollowSymLinks

Hat jemand eine Info für mich, was da nicht stimmt oder einen anderen Vorschlag zur Sicherung
der Seite?

Gruss ecki9

Offline dbs

  • Betatester
  • **
  • Posts: 8039
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Problem mit .htaccess
« Reply #1 on: January 22, 2017, 12:21:36 PM »
Hallo, welches CMS/Version verwendest du?

Offline jacobi22

  • Posts: 5879
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: Problem mit .htaccess
« Reply #2 on: January 22, 2017, 12:58:39 PM »
Quote
Hallo, welches CMS/Version verwendest du?
die Frage sollte vielleicht eher lauten: welchen Anbieter nutzt du?
oder
laufen dort eventuell zwei .htaccess hintereinander?
zu 1.: nicht jeder Anbieter erlaubt das Setzen mehrerer .htaccess hintereinander in verschiedenen Unterordnern
zu2. setzen wir voraus, der angegebene Pfad ist auch gültig, muß die Fehlermeldung ja irgendwo her kommen und vom Code her nur aus einer weiteren .htaccess oder aus deiner conf-Datei, wo die Servereinstellungen gemacht werden
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline ecki9

  • Posts: 17
Re: Problem mit .htaccess
« Reply #3 on: January 22, 2017, 04:59:40 PM »
Hallo, welches CMS/Version verwendest du?

Ich nutze WebsiteBaker 2.8.3.

Offline dbs

  • Betatester
  • **
  • Posts: 8039
  • Gender: Male
  • tioz4ever
    • WebsiteBaker - jQuery-Plugins - Module - Droplets - Tests
Re: Problem mit .htaccess
« Reply #4 on: January 23, 2017, 07:22:00 AM »
Von WB kommt die Meldung nicht, dein Hoster ist da gefragt (wie jacobi22 oben schrieb).
Du findest es heraus.

 

postern-length