Author Topic: PHP Version  (Read 560 times)

Offline gottfried

  • Posts: 1339
PHP Version
« on: December 12, 2016, 04:43:16 PM »
Hallo meine Lieben!

Also - könnt Ihr das nicht so machen, daß neuere wb auch auf älteren php versionen z.B 5.3 fehlerfrei laufen?
Ich kann doch nicht jedesmal, wenn es ein neueres php für einen neuen wb braucht alle 15 cms meines webspace updaten, weil ich nur eie dafür einstellen kann.
Die laufen seit Jahren fehlerfrei.
Wo ist denn der Sinn in dieser Updateritis und Zwangsneuphpversion ???


:-)

Offline jacobi22

  • Posts: 5836
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Re: PHP Version
« Reply #1 on: December 12, 2016, 07:53:44 PM »
gelesen? -> http://forum.WebsiteBaker.org/index.php/topic,29641.0.html

Schon allein aus dieser Liste ist es möglich, das dein bzw jeder Anbieter die alten PHP-Version klein PHP 5.6. ab sofort abschaltet. WB und die Module im Addonsbereich sind vorbereitet und laufen auch unter den neuesten PHP-Versionen, aber auch abwärts bis PHP 5.3.8.
Niemand, von WB zwingt dich also, ein Upgrade zu fahren. Am Ende entscheidest du, ob es dir etwas ausmacht, wenn dein Provider nur noch 7er-Versionen im Angebot hat und deine Seite nicht mehr läuft, weil irgendein Uralt-Modul quer schießt.
Ebenso entscheidest du, ob die rot markierte Sicherheitswarnung für dich ein Problem werden könnte oder nicht.

WB selber läuft als Standard-Version, also mit den Core-Modulen übrigens auch mit einer 2.8.0 oder 2.8.1 im Frontend. Böse wirds (im Backend) erst, wenn der Anbieter auf MySQLi umstellt, das können die Versionen vor WB 2.8.3 SP4 nämlich nicht
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline gottfried

  • Posts: 1339
Re: PHP Version
« Reply #2 on: December 13, 2016, 09:02:28 AM »
Hall Jakobi!

Danke für deine Informationen. Mit der 5.3 funktioniert ja alles.

Außerdem hat mir mein Provider bei der 2. Rückfrage gut geantwortet:

Ja, Sie haben die Möglichkeit mehrere PHP-Versionen über eine .htaccess Datei zu nutzen. Die Fehlinformation bitte ich zu entschuldigen. Bitte tragen Sie folgendes in die .htaccess ein um die PHP-Version anzupassen.

PHP 7.0: AddHandler application/x-httpd-php70 .php
PHP 5.6: AddHandler application/x-httpd-php56 .php
PHP 5.5: AddHandler application/x-httpd-php55 .php
PHP 5.3: AddHandler application/x-httpd-php53 .php

:-))

Offline hgs

  • Betatester
  • **
  • Posts: 1102
    • EFG MG
Re: PHP Version
« Reply #3 on: December 13, 2016, 02:34:20 PM »
Mein Provider hat, nach 2monitiger Ankündigung, alles unter php5.5 vom Server entfernt.
Ist ja auch verständlich, da dieser Versionen ja EoL sind.

Das wird über kurz oder lang jeder Provider so machen müssen um nicht mit Regressansprüchen bei Hackerangriffen auf meinen Webspace wegen zu alter php-Versionen überhäuft zu werden.

Ja es ist lästig, aber wir testen uns den Wolf, damit der Core php7 (nicht erst die Zukunft sonder schon die Gegenwart) fit ist.
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)