Author Topic: Wenn Bild einfügen: This connector is disabled. Please check the "editor/fileman  (Read 1318 times)

Offline sabo-!

  • Posts: 121
Hallo liebe WB-Profis,

nach einer Neuinstallation (WB-Version: WB Version 2.8.3+SP7 r1646) erscheint beim Versuch, Bilder über den Editor einzufügen nach dem Klick auf "Server durchsuchen" folgende Meldung:

"This connector is disabled. Please check the "editor/filemanager/connectors/php/config.php" file"

Die erwähnte Datei wurde nach der Installation nachträglich nicht geändert.

Bildupload funktioniert aber.

Wie lässt sich das lösen?

Danke und Gruß
Sabo



Offline hgs

  • Betatester
  • **
  • Posts: 1063
    • EFG MG
Welche php-version ist aktiv?

Bei 100ten von Testinstallationen ist uns das Verhalten nicht passiert.
Wir haben von php 5.3.28 bis php7 alles erdenkliche getestet.

Vielleicht das SP7 Vollpaktet noch mal drücher copieren und zur Sicherheit das upgrade-script als SuperUser laufen lasssen.

Hoffe wir finden eine Lösung
LG Harald

"Fange nie an, aufzuhören - höre nie auf, anzufangen." Marcus Tullius Cicero (106-43 v.Chr.)

Offline jacobi22

  • Posts: 5687
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
das sieht mir eher nach einen modifiziertem CKEditor aus.
Besagte Meldung kann nur erscheinen, wenn der ckeditor-interne Uploader eingeschalten ist und der wurde in der include.php des Editors abgeschalten mit

Code: [Select]
$ckeditor->config['uploader'] = false;
Hintergrund ist, das mit diesem Uploader dann eine Steuerung der Berechtigungen, welcher User auf welchen Ordner zugreifen darf, nicht mehr korrekt funktioniert.

Bitte auch mal angeben, ob in den erweiterten WB-Settings "Persönliche Ordner" aktiviert ist und ob eventuellen Usern Ordner zur eigenen Verfügung eingerichtet wurden, wenn JA, ob diese auch physikalisch (noch) zur Verfügung stehen
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline sabo-!

  • Posts: 121
Ich habe testweise WebsiteBaker auf den Werbserver noch einmal komplett neu in einem anderen Verzeichnis installiert. Also alles ganz jungfräulich. Die Meldung tritt auch bei dieser neuen, bislang unveränderten und unbearbeiteten Installation.

In der Datei modules/ckeditor/include.php befindet sich in Zeile 223:

$ckeditor->config['uploader'] = false; // disabled for security reasons

"Persönliche Ordner" ist standardmäßig aktiviert. Usern wurden keine Ordner zur eigenen Verfügung eingerichtet. Bin als Administrator eingeloggt.

Provider: 1&1
PHP-Version: php5.4

Offline jacobi22

  • Posts: 5687
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Danke für die Rückmeldung   (Y)

wir versuchen, das nachzuvollziehen, haben aber noch keine Erklärung

zu deinem Eingangs-Post noch mal. Du schreibst:

Quote
Bildupload funktioniert aber.

Wie ist das gemeint?  Mit dem aktuellem Voll-Paket funktioniert es so, das Bilder entweder über die Media-Verwaltung oder per FTP in das Media-Verzeichnis geladen müssen und im Editor (FCK- oder CKEditor oder TinyMC) dann nur eine Auswahl des Bildes über eine solche Ordnerdarstellung erfolgt (siehe mein Bild)
Unten links im Bild habe ich die Stelle gekennzeichnet, wo der ursprüngliche Upload-Button mal saß bzw wo er sitzen würde, wenn man das alles aktiviert. Das wäre ein einfacher Button mit der Aufschrift UPLOAD



P.S.: ich spreche vom WB-Vollpaket SP7
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline sabo-!

  • Posts: 121
Also, zuerst habe ich ein Bild im Bereich Medien hochgeladen:



Dann gehe ich in die Seite, in der ich das Bild einfügen will und klicke im CKEditor auf das Bild-Symbol:



Dann klicke ich auf "Server durchsuchen". Normalerweise erscheinen dann alle hochgeladenen Dateien, wie auch in Deinem Screenshot. Hier erscheint dann aber diese Meldung:



Für die Test-Installation habe ich mir extra nochmal das aktuelle Paket von dieser Seite heruntergeladen:



(Ist das die gleiche Version, wie in Deinen Link?)

Offline jacobi22

  • Posts: 5687
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Danke für deine Antwort.  (Y)
Das scheint wohl ein 1&1-spezifisches Problem zu sein. Ich sehe da nur zwei mögliche Erklärungen:

1. falsche oder fehlende Berechtigungen (sollte aber für den Super-Admin und der Gruppe Administrators kein Problem sein, sofern diese Berechtigungen auch in die Datenbank geschrieben wurden)
2. der Array Config wird nicht übergeben

zu 1.: der Connector steht grundsätzlich auf false, es ist also deaktiviert. Dann werden die Berechtigungen für media gelesen, insbesondere das Recht "media_view" (Ansicht der Mediainhalte für diese Gruppe). Ist dieses Recht gesetzt, wird der $Config['Enabled'] freigeschalten

zu 2.: die Einbindung der Dateien erfolgt über einfache require-Anweisungen in der Datei modules/ckeditor/ckeditor/filemanager/connectors/php/connector.php
require('./config.php') ;
hier könnte man mal probieren, den Pfad ohne was dran einzusetzen, z.b.
Code: [Select]
require('config.php') ;
rein theoretisch wäre der absolute Pfad die bessere Lösung, wirft bei mir lokal aber einen XML-Fehler
« Last Edit: October 28, 2016, 12:35:31 PM by jacobi22 »
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline sabo-!

  • Posts: 121
Danke für die Antwort. Leider komm ich nicht ganz mit. Was genau muss ich machen?

Offline sabo-!

  • Posts: 121
zu 1) verstehe ich (als Nichtprogrammierer) nicht, was Du meinst.

zu 2) kommt die Meldung: The server didn't reply with a proper XML data. Please check your configuration.

Offline jacobi22

  • Posts: 5687
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
zu 1) verstehe ich (als Nichtprogrammierer) nicht, was Du meinst.

ich schrieb:
Quote
zu 1.: der Connector steht grundsätzlich auf false, es ist also deaktiviert. Dann werden die Berechtigungen für media gelesen, insbesondere das Recht "media_view" (Ansicht der Mediainhalte für diese Gruppe). Ist dieses Recht gesetzt, wird der $Config['Enabled'] freigeschalten

der gleiche Text mit anderen Worten:
grundsätzlich ist die Verbindung zur Auswahl von Bilder ab deinem media-Ordner deaktiviert oder "verboten". Möchte ein User diese Funktion nutzen, wird in den Gruppenrechten für seine Gruppe geprüft, ob er dazu berechtigt ist. Dieses Recht wird intern als media_view bezeichnet und wird für den SuperAdmin bzw dessen Benutzergruppe Administratoren automatisch bei der Installation von WB gesetzt.
Für andere Benutzergruppen muß es vom Admin extra genehmigt werden.

zu prüfen wäre, ob dieses Recht für die Gruppe Administratoren auch in der Datenbank drin steht (Tabelle groups)

Ist man weder SuperAdmin, noch in der Gruppe Administrators wäre dieses Recht natürlich erst einmal zu setzen

Ansonsten bleib ich dabei, das es eher ein 1&1-Problem ist und eher mit PHP-Einstellungen, Rechtevergabe usw zu tun hat
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline sabo-!

  • Posts: 121
Hallo Jacobi,

vielen Dank für Deine Antwort. Ich hatte gehofft, dass sich das Problem evtl. von alleine löst, wenn die Homepage online geht, da auf dem Werbserver auch noch alte Installationen von Joomla, Typolight Contao drauf sind. Ich hatte die Homepage mit WebsiteBaker zunächst in ein Unterverzeichnis vom Rootverzeichnis installiert. Jetzt habe ich bei 1&1 das Homepageverzeichnis auf ./WebsiteBaker geändert (d.h. ist jetzt das neue Rootverzeichnis). Im alten Rootverzeichnis (./) liegen noch die alten Dateien.

In der Datenbank-Tabelle "groups" steht group_id = 1, name = Administrator, system_permission: pages,pages_view,pages_add,pages_add_l0,pages_settings,pages_modify,pages_intro,pages_delete,media,media_view,media_upload,media_rename,media_delete,media_create,addons,modules,modules_view,modules_install,modules_uninstall,templates,templates_view,templates_install,templates_uninstall,languages,languages_view,languages_install,languages_uninstall,settings,settings_basic,settings_advanced,access,users,users_view,users_add,users_modify,users_delete,groups,groups_view,groups_add,groups_modify,groups_delete,admintools

Neu ist jetzt: Wenn ich jetzt im Editor auf das Bild-Symbol klicke, und dann auf "Server durchsuchen", erscheint in dem Fenster, wo sonst eigentlich das Mediaverzeichnis erscheint, nicht mehr die Fehlermeldung, sondern die Startseite der Homepage an sich!

Hast Du - aufgrund der neuen Informationen - eventuell noch einen Tipp für mich, wie ich das lösen könnte?

Danke und Gruß



Offline jacobi22

  • Posts: 5687
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
theoretisch geht er dort hin, wenn das Script keine Berechtigung auf das media-Verzeichnis hat oder dieses nicht erreichbar ist.
Wie schaut es denn in der media-Verwaltung aus? Kannst du dort Bilder hochladen und/oder Unterordner erstellen von WB aus??
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

Offline sabo-!

  • Posts: 121
Ja, ich kann in der media-Verwaltung problemlos Bilder hochladen, löschen, etc. Das Problem tritt nur auf, wenn ich Medien einfügen möchte und auf "Server durchsuchen" klicke. Wie ich gerade feststelle, im übrigen auch, bei der Verlinkung. Wenn ich ein Wort markiere und dann auf das Link-Symbol klicke und dann dort auf "Server durchsuchen", erscheint auch anstelle des Media-Verzeichnisses die Startseite der Homepage.

Offline sabo-!

  • Posts: 121
Problem gelöst!!! Es lag an der Zeile

define('WB_URL', 'http://www.meine-domain.de');

in der config.php. Der Fehler tritt (in meinem Fall) auf, wenn dort http://meine-domain.de (also ohne "www") hinterlegt ist.

Offline jacobi22

  • Posts: 5687
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
hab ich wieder was dazu gelernt - Dank für die Rückmeldung  (Y)

ich war aber dicht dran ->
Quote
theoretisch geht er dort hin, wenn das Script keine Berechtigung auf das media-Verzeichnis hat oder dieses nicht erreichbar ist.
  :wink:
Probleme sind da, um sie zu lösen, nicht, um nach Ausreden zu suchen.

 

postern-length