Author Topic: Hilfe - Fehlermeldung: There was an unknown exception: Call to undefined functio  (Read 2024 times)

vermedia

  • Guest
Hallo,

ohne irgendwelche Änderungen vorgenommen zu haben erhalte ich folgende Fehelrmeldung:

There was an unknown exception: Call to undefined function mysql_connect() in line (59) of (/framework/class.database.php)

Was kann ich machen?

vermedia

  • Guest
Habe das Problem gefunden, es liegt daran, dass ich auf PHP7.0 umgestellt habe.  :roll: :roll:

Offline jacobi22

  • Posts: 5843
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Quote
Habe das Problem gefunden, es liegt daran, dass ich auf PHP7.0 umgestellt habe

Kann man so sagen, (muß man aber nicht)  :wink:

Problem ist, das mysql nicht mehr unter PHP 7.x läuft, sondern nur noch mysqli. Leider hast du nur einen Teil der Fehlermeldung gepostet, so das man nun nicht sagen kann, welches deiner benutzten Module diesen Fehler produziert. Wenn man das raus bekommt, ist es relativ leicht zu beheben.
Wer nicht will, findet Gründe, wer will, findet Wege.

vermedia

  • Guest
nee, das war leider die ganze Fehlermeldung, die ich erhalten habe  :|  werde es mir aber dann nochmal genauer "ansehen" ...

Offline jacobi22

  • Posts: 5843
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
dann schau mal, was auf der gewünschten Seite alles angezeigt werden soll. Am besten, erstmal schauen in:
- Abschnittsverwaltun g für diese Seite (siehe Bild unten)
- Droplets auf der Seite
- Droplet oder globalBlocks im verwendeten Frontend-Template
- eigene Scripte, z.b. in einer Code- bzw Code²-Section
was wird noch an Erweiterungen eingebunden.
Auch hilfreich: eine Suche in deinem Backup nach dieser Buchstabenfolge -> mysql_connect

Alle Module, die im SP7-Paket mitgeliefert werden, kannst du ausklammern, die sind alle schon umgestellt

Beispielansicht Sektionsverwaltung
Wer nicht will, findet Gründe, wer will, findet Wege.

Offline jacobi22

  • Posts: 5843
  • Gender: Male
  • Support also via PM or EMail
    • Jacobi22
Ich nochmal - bevor ich dich auf den falschen Weg führe....  :oops:

Auf Grund deiner anderen Postings kann es natürlich sein, das obige Fehlermeldung auch aus einer älteren WB-Version stammt, die noch mit Mysql lief, z.b. eben die Version 2.8.2. Die gezeigte Fehlermeldung kann nämlich nicht aus einer Version WB 2.8.3 SP6 oder SP7 stammen.

Darum: erst updaten, dann probieren  :wink:
Wer nicht will, findet Gründe, wer will, findet Wege.